Aller au contenu
DroneBuilds
Madh@tter

Problème de vibrations (blackbox à l'appui)

Messages recommandés

Bon je désespère....

J'ai pas voulu créer un nouveau sujet pour mon problème et éviter de polluer le forum donc je reprend là.

Donc impossible de régler mon problème de vibrations. Je reprends du début pour ceux qui passerait par là et aurait un soucis similaire.

Frame : QAV-X charpu edition
ESC : FVT littlebee spring 30A flashée avec la version 16.6 de BLHeli
Motors : Emax RS 2205 "S" 2300KV
FC : BFF3 flashée with BF 3.1.7
VTX : Tramp HV v2 avec cam HS1177
Props : DALPROP T5045
Lipos : Tattu 1550mAh 4s (non racer version)
Receiver : XM+
Radio : 9XR PRO openTX

Tous les composants sont neufs. Les vibrations sont présentes depuis le début, ça s'est amélioré avec le soft mount moteur et FC mais le quad reste impossible à tuner à cause de ces vibrations qui s'excitent sur l'axe roll principalement. Du coup j'ai commencé à m'intéresser aux logs blackbox et, déjà, j'ai repéré des mouvements non désiré sur P roll/pitch/yaw alors que ma ligne RcCommand reste neutre.

J'ai aussi des choses bizarre qui se produisent sur l'axe roll et je pense que c'est le résultat de ces vibrations, en fait j'observe des mouvements trés rapide sur cet axe et dans un temps très court de l'ordre du centième de seconde et qui prend la forme d'une onde. Clairement il y a un soucis car ce n'est pas une commande que je suis capable de faire en si peu de temps (à moins d'être un robot).

Tout au long de la ma recherche du problème j'ai procédé par élimination, j'ai commencé par traiter les moteurs, puis la FC, ensuite j'ai essayé de descendre mes fréquences PID loop et gyros, essayé de passer en Dshot 300 mais sans résultat apparent. J'ai par la suite essayé de baisser mes filtres en vol (d term et gyro frequency) mais rien n'y a fait. La seule chose qui me reste à essayer serait de retirer un composant sur les ESC (manip vu sur RCgroup concernant le Dshot) et d'agrandir les trous de ma FC pour lui permettre d'être plus libre mais franchement je suis pas trop sûr de ça...

Pour le moment, pas possible de tuner mon quad, mes vols sont dégueulasses et je commence à être dégoûté... J'ai créer un post sur RCgroup et posé ma question à Joshua aussi mais pas de réponse depuis une semaine... Vous êtes mon dernier espoir !

Pour être complet, j'ai créer 3 logs blackbox avec 2 vidéos en espérant qu'il y ait des fous du logs qui puissent m'aider. J'ai appelé ça : LOG1 ; LOG2 et LOG 3.

LOG 1 avec vidéo ; "d_lowpass_type = PT1" ; "debug_notch" non activé ; PID et filtres par défaut
LOG 2 avec vidéo ; "d_lowpass_type = PT1" ; "debug_notch" non activé ; PID par défaut et "D term cutoff filter" à 50
LOG 3 sans vidéo ; "d_lowpass_type = PT1" ; "debug_notch" activé ; "gyros notch filter frequency" 1 et 2 à 0 ; PID par défaut

LOGS blackbox et vidéo

 

Je croise les doigts !

Partager ce message


Lien à poster
Partager sur d’autres sites

Pas de souci à créer un nouveau topic, je te l'ai fait du coup ;)

Y'a un max d'infos et t'as déjà bien investigué...

Je suis pas expert en BB mais ça m'intéresse, je regarde dès que j'ai un instant :)

Partager ce message


Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Je ne sais pas lire la black box mais on dirait que tu a des infos parasite sur l'axe roll.

Sa mais déjà arrivé sur simulateur la radio été parasitée et le quad avait aussi des réactions similaires sur tous les axes.

Tu a pas moyen de tester avec une autre radio et récepteur ?

Partager ce message


Lien à poster
Partager sur d’autres sites

j'avais un peu le même souci que toi, avec des éléments neuf aussi, hélices, moteurs, ESC (DSHOT 600), FC BFF3.

 

et j'avais cela :

 

J'ai fait une BB,  résultat, super moche

 

et après avoir monté ma FC sur silent block

nickel

 

 

 

 

Screen Shot 2017-01-21 at 9.15.40 AM.png

Screen Shot 2017-01-21 at 9.16.06 AM.png

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah oui, et la vid, avec les silents block, y a pas photo

(voir ce que t'as conseillé Darkbolt25)

Partager ce message


Lien à poster
Partager sur d’autres sites

oui, c'est un peu petit, surtout en FPV :)

Partager ce message


Lien à poster
Partager sur d’autres sites

Non, je plaisantais, surtout pas en FPV. Soyez tranquille, ce que vous voyez pas c'est que en fait je suis au niveau de la porte d'entrée de la chambre, et je vole à vue bien evidement. Je suis assez prudent de nature.

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Putain ça fait une semaine que je guette des réponses à mon sujet dans mes mails mais comme le sujet à été sorti du fil original je viens de me rendre compte que je ne suivais pas ce fil....

Bon je reprends vos commentaires et je vous tiens au jus. Déjà j'ai eu quelques éléments de réponses sur rcgroups mais toujours pas concernant ce problème sur l'axe roll...

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai peut être zappé, mais vérifie si tu n'as pas de jeu sur un de tes moteurs entre la base et la cloche (stator/rotor), c'est peut engendrer des vibrations sur le roll.

Partager ce message


Lien à poster
Partager sur d’autres sites
J'ai pris ça et ça a réglé mes pb de vibrations.
 
https://www.drone-fpv-racer.com/entretoises-m3-soft-mount-pour-fc-4pces-1487.html


Yep merci, j'ai exactement les mêmes ^^ ça a réduit le problème mais pas corrigé

Partager ce message


Lien à poster
Partager sur d’autres sites
Le Sat May 06 2017 at 22:01, nico19 a dit :
Je ne sais pas lire la black box mais on dirait que tu a des infos parasite sur l'axe roll.
Sa mais déjà arrivé sur simulateur la radio été parasitée et le quad avait aussi des réactions similaires sur tous les axes.
Tu a pas moyen de tester avec une autre radio et récepteur ?

 


Malheureusement non mais en regardant mes logs BB je ne vois pas le soucis sur l'axe du pitch donc je ne pense pas que ça vienne de la radio. Idem, sur simulateur pas de soucis mais peut être que rx ou tx sont en cause. J'avais soudé le gnd direct lipo du rx que j'ai déplacé finalement sur le gnd de l'uart mais pas de changement...

Modifié (le) par Madh@tter

Partager ce message


Lien à poster
Partager sur d’autres sites
Le Sun May 07 2017 at 01:51, rbellanc a dit :
j'avais un peu le même souci que toi, avec des éléments neuf aussi, hélices, moteurs, ESC (DSHOT 600), FC BFF3.
 
et j'avais cela :
[/url]  
J'ai fait une BB,  résultat, super moche
 
et après avoir monté ma FC sur silent block
nickel
 
 
 
 
590e611812393_ScreenShot2017-01-21at9_15_40AM.thumb.png.dab885fca20cacafbac8961d78981f65.png

590e61645c139_ScreenShot2017-01-21at9_16_06AM.thumb.png.0b73f4bdd935a1e7bb704886daeed01f.png

Oh con, c'est exactement ce que jai ! Bon comme je l'ai dit, le soft mount moteur et FC a réduit ça mais c'est toujours pas satisfaisant...

Modifié (le) par Madh@tter

Partager ce message


Lien à poster
Partager sur d’autres sites
J'ai peut être zappé, mais vérifie si tu n'as pas de jeu sur un de tes moteurs entre la base et la cloche (stator/rotor), c'est peut engendrer des vibrations sur le roll.


Yep, vérifié aussi mais moteurs impeccables...

Partager ce message


Lien à poster
Partager sur d’autres sites

Entre temps, sur RC groups on a détecté un problème sur le RCcommand du roll et du pitch. Les lignes étaient saccadées en forme d'escalier. Je suis passé en rc interpolation "manual" sur BF (onglet receiver) et j'ai testé 5ms par 5ms en partant de 10 jusqu'à 50ms. 

Ça a carrément fait du bien ! Malheureusement ça a eu l'effet inverse sur l'axe throttle et yaw. J'ai pas pu tester d'adoucir tous les axes grâce à la commande set rc_interp_ch = rpty (ou rpyt je sais plus mais en gros ça correspond à définir quelles seront les axes adoucis via le rc interpolation dans l'onglet receiver de BF en sachant que par défaut (quand on passe en mode manuel dans rc interpolation) les reglages en ms n'affectent que le roll et le pitch mais si on tape cette commande on peut choisir quels axes seront affectés r=roll p=pitch y=yaw et t=throttle).

Si jamais ça peut aider quelqu'un. Dans un post, Boris précise qu'il n'est pas forcément nécessaire d'adoucir les axes throttle et yaw d'où les valeurs par défaut ne concernant que le roll et le pitch mais c'est à adapter à chaque situation bien entendu

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui belle galère... le plus rageant c'est de ne pas savoir d'où ça vient ! Mais à force d'éliminer piste par piste j'espère bien trouver !

Partager ce message


Lien à poster
Partager sur d’autres sites

Je suis avec intérêt ce sujet, j'ai aussi des vibrations parasites sur mon nouveau martian 220 sous betaflight F3. J'ai softmounté mes moteurs avec 4 couches de scotch, mai j'ai pas l'impression que ça améliore. Je suis tenté par les silentbloc pour la FC, mais j'ai le sentiments que le problème ne vient pas juste d'un montage en dur ou non.

Un vieux eachine 250 racer monté tout rigide qui s'est pris des dizaine de crash n'a jamais vibré, pourtant c'est pas du matos de fou....

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 7 minutes, Fabien_D a dit :

Je suis avec intérêt ce sujet, j'ai aussi des vibrations parasites sur mon nouveau martian 220 sous betaflight F3. J'ai softmounté mes moteurs avec 4 couches de scotch, mai j'ai pas l'impression que ça améliore. Je suis tenté par les silentbloc pour la FC, mais j'ai le sentiments que le problème ne vient pas juste d'un montage en dur ou non.

Un vieux eachine 250 racer monté tout rigide qui s'est pris des dizaine de crash n'a jamais vibré, pourtant c'est pas du matos de fou....

oui, mais en BFF3 aussi ? cette FC est très sensible, malgré le MPU6000

Partager ce message


Lien à poster
Partager sur d’autres sites
BFF3 ouais

Je pense qu'il parle de ton vieux eachine 250

Partager ce message


Lien à poster
Partager sur d’autres sites

si c'est sur son eachine 250, c'est aussi une BFF3, alors là je ne comprends plus rien.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×