Aller au contenu
DroneBuilds

TX BIND mais non reconnue dans Betaflight (RX_FAILSAFE)


FlorianRbz
Aller à la solution Résolu par FlorianRbz,

Messages recommandés

Bonjour à tous! 

J'ai parcouru le forum avant de posté. Il y a bien des problèmes similaires mais avec des différences à chaque fois... Donc je post un énième sujet de ce problème!

Je débute dans le FPV, et j'ai fais l'acquisition d'un iFlight Nazgul5 Evoque F5 GPS Version HD avec le protocole BNF-DJI. Du coup, à la réception de celui-ci j'ai commandé un RX nano ELRS de chez BETAFPV pour pouvoir faire le BIND avec ma JUMPER T PRO VERSION ELRS 2,4 GHZ. 

Il me semble avoir bien tout effectué...

  1. J'ai branché le RX sur un UART libre (voir photo) en l'occurrence le R3 et T3
  2. Configuré le RX sur le bon UART dans Betaflightaflight et le bon protocole (CRSF)
  3. J'ai flashé le RX avec ExpressLRS Configurator à la dernière version (2.2.0) ISM_2400
  4. J'ai flashé la TX avec ExpressLRS Configurator à la dernière version (2.2.0) ISM_2400
  5. J'ai déposé le LUA SCRIPT dans le bon dossier de ma TX
  6. Le BIND est bien en place entre le TX et RX qui affiche désormais une led bleu fixe et j'ai bien un renvoie de signal sur ma TX
  7. Cependant, dans Betaflight, rien ne bouge dans les commandes et j'ai ce message comme quoi l'armement est impossible > RX_FAILSAFE

J'ai loupé quelques choses ? J'aurais dû brancher mon RX différemment ? Conflit avec le caddx vista receiver?

Tout semble si facile en regardant les tutos...

Mille mercis pour ceux qui m'aideront à éclaircir mon problème.

PS: il manque peut-être des infos, alors n'hésitez pas 🙂

cablage-rx.jpg

Modifié (le) par FlorianRbz
Lien vers le commentaire
Partager sur d’autres sites

Salut,

Alors on reprends sur les classiques 😉

TX / RX bien inversé ?

Protocole CRSF bien sélectionné sur Betaflight ?

Onglet port correctement paramétré en serial sur betaflight ?

Bon courage !

Lien vers le commentaire
Partager sur d’autres sites

Salut @Zhirself

J’ai brancher le Tx sur le tx et vise versa comme préconisée sur le shema…

Protocole CRSF bien sélectionné… Idem pour l’onglet port (voir photo).

J’ai repris plusieurs fois point par point, pour être sûr de ne pas passer à côté de quelques choses 🤔

E6654FC9-697E-4BD2-BE06-7AD14782DF3A.jpeg

Lien vers le commentaire
Partager sur d’autres sites

@FlorianRbz désactive le MSP sur ton UART3

@FlorianRbz Attends. Si le MSP est acivé sur l'UART 3 c'est certainement que c'est l'UART utilisé pour l'OSD du DJI.

Vérifie ce point. Au besoin, change d'UART pour ton RX.

EDIT : 1, 2 & 5 semblent dispo.

EDIT de l'EDIT : J'ai trouvé ca sur le site du constructeur :

https://shop.iflight-rc.com/Nazgul-Evoque-F5-with-Caddx-Polar-Vista-Digital-HD-System-pro1628

- 5 X Uarts

- UART1 for VTX HD/Analog

- UART2 for  Receiver

- UART3、UART4 for GPS or 0ther sensors that require a serial port

- UART6 for ESC Telemetry

Du coup tu devrais normalement te mettre en 2 et laisser le MSP activé en 1 pour l'OSD. Je pense que l'UART 4 devrait être en serial pour le GPS mais je ne suis pas sur (j'ai jamais utilisé ces bêtes là).

Modifié (le) par Zhirself
  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
  • YouTube / WE are FPV

×
×
  • Créer...