Aller au contenu
acheter dji air unit o3
DroneBuilds

Remplacement ESC sur Nazgul5 HD, moteurs de tournent pas


Gatoune

Messages recommandés

Bonsoir,

suite à un joli crash avec mon Nazgul5 HD a acheté en novembre 2020 sur BG: (iFlight Nazgul5 HD 6S 5 pouces 240mm Freestyle FPV Racing Drone PNP/BNF Caddx Vista XING-E 2207 1800KV SucceX-E F4 45A ESC) 3 moteurs ne tournaient presque plus, le 4eme pas de soucis. J’ai vérifié que les moteurs tournaient librement à la main: RAS, puis contrôlé à l’ohmmètre les enroulements: RAS. En inversant 2 fils moteurs sur la nape FC-ESC c’est toujours le même moteur qui tournait bien, j’en ai déduit que 3 voies sur l’ESC 4en1 était HS.

Du coup, ne voulant pas passer trop de temps (3 gosses 😅) a chercher un ESC et satisfait de mon Nazgul5 tel quel j’ai commandé le même ESC 4en1 que d’origine sur BG: iFlight SucceX-E V1 45A 2-6S Blheli_S 4 en 1 DSHOT600 https://banggood.onelink.me/zMT7/4b5f5e6f

Une fois reçu je l’ai soudé en lieu et place de l’original et pensais naïvement que ça allait repartir sans paramètrage particulier 🙄 mais non 😢

au branchement de la batterie, les 3 bips émit par les moteurs sonnent bien, mais il manque les 2 suivants. Et quand j’essaie d’armer il y a des pibs dans tous les sens quand je met les gaz, et les moteurs de tournent pas d’un pouce.

j’ai installé BLheli suite pour essayer de comprendre le problème (jamais utiliser jusque là), à priori les 4 ESC sont bien reconnus: (check)

26D6C630-9085-4EE3-821C-B1048062D1CA.thumb.png.b78171a17f5f43dbdda4101e9812ffd2.png

mais quand j’essai de faire tourner les moteurs ils ne bronchent pas, ou font quelques très bref sursauts quand je manipule les curseurs.

quand je fait un read setup ça l’air bon, mais je n’ai aucune expérience:

9A0A0926-6F52-4D4A-A85F-D48C007BAA11.thumb.png.4a09c34e610872feb8d45329fed87302.png
 
dans betaflight je n’ai touché aucun paramètres par rapport à ce qu’il y avait avant le crash et remplacement d’ESC. Concernant les ESC-moteurs pour infos:

7814C654-29B1-4052-8537-7F49A082F305.thumb.jpeg.688d5f8f5b2f178c92bdf7bd0aaa1572.jpeg
 
j’ai tenté le DSHOT300 et 600 ça ne change rien, et désactivé le Dshot bi-directionnel: pareil

Pour le moment je n’ai pas flashé les ESC via BLheli par peur de faire une connerie, est-ce que ça pourrait être utile?

les soudures des moteurs semblent corrects, j’ai remplacé la nape FC-ESC par la neuve fournie avec l’ESC 4en1. La communication via la FC semble fonctionner puisque BLheli suite vois bien les 4 ESC ?
J’ai plus trop d’idée et pas d’expérience a propos des DShot, BLheli et autres jargons du milieu 🤭

Un coup de main serait le bienvenu

merci 🙏

Gaëtan

Lien vers le commentaire
Partager sur d’autres sites

Personne pour un petit conseil? Même pas une cht’ite piste? Les beaux jours arrivent et je ne peux pas voler 😢

Je peux même payer en nature 😉 j’ai une soudeuse par point pour souder les éléments lithium cylindriques proprement et sans les faire chauffer. Ça permet de faire des pack 6s - 3000mAh (en 18650) ou 4000mAh (en 21700) pour un très bon prix (25-30€) avec des éléments de qualité acheté sur nkon. Si quelqu’un est intéressé pour le long range je peux vous monter des pack à l’oeil (hors composants), même si vous ne savez pas comment m’aider pour mes soucis ESC 😉

Lien vers le commentaire
Partager sur d’autres sites

Salut

Pas assez d'expérience pour te répondre mais je suis ton sujet car j'attend mon ESC (le 1er avait une voie KO suite a crash dans la terre humide fraichement labourée...)  de rechange et vais avoir la meme problématique que toi (changement d'ESC et remise en route).

N'ai pas peur de flasher tes ESC a la dernière version de FW (tu es actuellement a la 16.7 d'après ta capture d'écran), tu ne risques pas grand chose si tu ne te trompes pas de cible.

Si non-concluant, un flash de la FC peut aider tout ce beau monde a bien communiquer à nouveau mais il va donc falloir revoir les onglet un à un dans BF.

Lien vers le commentaire
Partager sur d’autres sites

Salut, déjà s'il n'y a pas les 5 bips c'est qu'il y a un soucis de com entre FC et esc, contrôle la nappe/soudure qui les relis. 

Vérifie qu'il n'y ai pas un court ju quelque part, y compris soudure ou prit bout de câble dénudé qui touche le carbone en général c'est ça... Check le condo au passage voir s'il est pas hs

Sinon ben FC hs... 

(l'électronique c'est fantastique !) 

Modifié (le) par dr greenskin
Lien vers le commentaire
Partager sur d’autres sites

Merci à vous deux pour les conseils,

J'ai bien revérifié la nape ESC/FC qui est neuve, fournit avec l'ESC, c'est des connecteurs donc pas de soudure, et ai même remis l'ancienne dans le doute.

J'ai pas flashé les ESC parce qu'ils sont déjà sur la dernière version dispo ( 16.7 )

J'ai flashé la FC avec betaflight 4.2.11 (précédemment en 4.2.0)

Pas de changement avec tout ça à part que j'ai maintenant les 5 bips au branchement de la batterie (donc  FC et ESC communiquent si j'ai bien suivis)

Par contre, sous betaflight onglet installation, dans infos, j'ai paramètres empechant l'armement: MSP et RPMFILTER

image.png.8f4675302a3bbb01d70aa5bbd76ae069.png

Et il semblerai que le RPMFILTER indique des soucis avec le DSHOT 🤔

Mais plus ça va plus j'ai de gros doute sur l'état de la FC. Maintenant quand je cherche à faire tourner les moteurs via le curseur de betaflight (onglet moteur) ou BLHeli S, le moteur 2 (avant droit) fait des accoups très brefs de quelques tours, toutes les demi secondes. Et si j'insiste un peu sur les 4 moteurs, ils se mettent à faire un peu tous la même chose. Puis si je coupe les "gaz", le moteur 2 continu ses accoups réguliers, plus moyen de l'arrêter même en déconnectant betaflight et le cable USB. Seul moyen de l'arrêter c'est de débrancher la batterie 🤪 et au passage le moteur fini par chauffer un peu.

J'étais en DSHOT300, mais DSHOT600 c'est pareil sauf que les accoups moteurs sont plus brefs...

C'est grave docteur? ça sent le roussi pour Madame FC ?

Bon, dans le désespoir je vient d'essayé de flasher les ESC avec BLHeli Suite, pour le #1 #3 et #4 ça s'est bien passé, mais le #2 ça a foiré (Le 2 comme part hasard, celui dont le moteurs ne s'arrêtait plus...), et maintenant je n'arrive plus rien à en faire de cet ESC #2 pas moyen de le flasher. Il y a une technique?

Je sent que ça va fini avec une commande de stack complète cette histoire

image.thumb.png.2ffa68ecf5bcada0ff82babdf4821052.png

Lien vers le commentaire
Partager sur d’autres sites

  • 2 months later...
Youtube WE are FPV

Bon, j'ai finalement fini par commander une stack complete directement chez Diatone: MAMBA F722 APP 55A 6S F55_128K

J'ai pris la version APP pour connection wifi via smartphone, mais du coup pas de prise pour le vista, mais bon on est pas a 4 soudures près.

Ca vol plutôt bien mais j'ai pas testé longtemps car impossible d'avoir l'OSD Betaflight qui s'affiche dans le masque DJI

La notice conseil de brancher le Vista sur l'UART 2, mais après avoir épluché le forum il semblerais que ça fonctionne seulement sur l'UART5, c'est ce que j'ai fais, mais toujours pas d'OSD. J'ai aussi essayé l'UART2 et lUART4 sans succès, bien veillé a croiser TX/RX (j'ai même fini par essayer dans l'autre sens des fois que je me sois planté...)

Je précise que mon masque était déjà configuré en "custom OSD", j'ai d'ailleurs mis à jours le vista et le masque via DJI assistant dans le doute.

Mon vista est alimenté en direct lipo (un condo de 470µF neuf fournit par diatone).

J'ai aussi dessoudé mon GPS de l'UART2 et désactivé dans l'onglet ports (vu sur un forum en anglais, quelqu'un avait un problème en ajoutant le GPS).

image.thumb.png.38361748452f69e53e19415f5252ef55.png

OSD et telemetry activé dans l'onglet configuration

image.png.cefb730235f6dc91e8aa5d61aacc8314.png

Dans les menus du masque, les PID et rate ne sont pas accessibles, donc j'ai l'impression que la communication entre le vista et la FC ne se fait pas du tout.

Quasi 5 mois que je ne peux pas voler 😢 (ok j'ai pas été très réactif dans ma réparation!), si vous avez une idée, je seche

Merci

Gaëtan

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...