Aller au contenu
DroneBuilds

Mamba MK2 / RX R9MM OTA : bind OK mais sticks ne répondent pas Betaflight


Nitneuq26
Aller à la solution Résolu par spid99,

Messages recommandés

Bonjour à tous,

 

Après remontage de mon drone, je rencontre un petit souci pour bouger les sticks sur Betaflight.

Actuellement mon RX est branché à la FC comme ceci :

RX (R9MM OTA) > FC (Mamba F405 MK2)

 

GND > GND

5V > 5V

SPort/FPort > TX1

 

La radio est bien bindée au RX (led verte OK) par contre dans l’onglet BetaFlight les sticks du récepteur ne bougent pas.

 

J’ai configuré dans l’onglet récepteur comme tel :

Mode du récepteur : UART

Type récepteur série: SBUS

 

J’ai aussi essayé de branché le fil SPort/FPort du RX sur SBUS de la FC mais sans succès.

 

Je précise aussi que dans l’onglet Port j’ai bien UART1 avec Serial RX.

 

Ai-je fais une erreur quelque part ? Peut-être que mes branchements ne sont pas corrects ?

J'ai vu qu'il y avait des lignes CLI à taper aussi notamment set serialrx_inverted = OFF et set serialrx_halfduplex = ON

 

Radio : Taranis QX7

 

Merci beaucoup

294914312_3268162763442192_3072992725291612901_n.jpg

294932898_5403298249748355_3829284315985471446_n.jpg

294956177_1100041747607310_2914646596023842015_n.jpg

295710238_924673902258694_4133068350456252504_n.jpg

296084550_365133375800364_7665793975286916740_n.jpg

Lien vers le commentaire
Partager sur d’autres sites

Salut, pas facile les R9 ..

Essaie l'un des deux ..
 

Citation

 

set serialrx_halfduplex = OFF
set serialrx_inverted = ON


set serialrx_halfduplex = OFF
set serialrx_inverted = OFF

 

Bizarre que le branchement sur le SBUS/UART1 n'ait pas fonctionné, c'est le plus simple ..

Es-tu certain d'avoir le bon firmware ? (led vert fixe si bindé)

Modifié (le) par spid99
Lien vers le commentaire
Partager sur d’autres sites

il y a 4 minutes, spid99 a dit :

Salut, pas facile les R9 ..

Essaie l'un des deux ..
 

Bizarre que le branchement sur le SBUS/UART1 n'ait pas fonctionné, c'est le plus simple ..

Es-tu certain d'avoir le bon firmware ? (led vert permanent si bindé)

aucun des deux n'a fonctionné..

 

oui j'ai le bon firmware car j'ai bien la led verte et je vois bien le signal sur ma radio...

tu aurais branché ça comment ? car il y a aussi les inverted port etc.. je suis perdu 😄 

Lien vers le commentaire
Partager sur d’autres sites

il y a 14 minutes, Nitneuq26 a dit :

Tu aurais branché ça comment ? car il y a aussi les inverted port etc.. je suis perdu 😄 

Le branchement est préférable sur le SBUS (UART1), puis choisir SBUS dans récepteur, ensuite jongle avec les deux lignes que je t'ai données (c'est pour inverser ou pas)

Tu peux aussi essayer (dans CLI):

serial 2 64 115200 57600 0 115200

&

set serialrx_halfduplex = ON
set serialrx_inverted = ON

 

N’oublie pas "save" 😉

 

A voir :

Modifié (le) par spid99
Lien vers le commentaire
Partager sur d’autres sites

il y a 16 minutes, spid99 a dit :

Le branchement est préférable sur le SBUS (UART1), puis choisir SBUS dans récepteur, ensuite jongle avec les deux lignes que je t'ai données (c'est pour inverser ou pas)

Tu peux aussi essayer (dans CLI):

serial 2 64 115200 57600 0 115200

&

set serialrx_halfduplex = ON
set serialrx_inverted = ON

 

N’oublie pas "save" 😉

 

A voir :

du coup tu branches le Sport/Fport du RX sur le SBUS (et non pas le TX1) de la FC ?

 

je vais réessayer tout ça..

 

j'ai déjà vu et revu ces vidéos oui.. toujours sans succès

Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV
  • Solution
il y a 15 minutes, Nitneuq26 a dit :

du coup tu branches le Sport/Fport du RX sur le SBUS

Non Oui,  pour le SBUS il faut souder sur le "SBUS out"

image.png.6acac5df01c617772e5a232d0faaa9c5.png

ET oui ne pas mettre sur le RX1, mais sur "SBUS" (Enfin tu peux tester les deux ..Avec Frsky c'est jamais très évident ^^)

Pour "l'inverted"

Seule la ligne "set serialrx_inverted = OFF (ou ON) compte ..

Modifié (le) par spid99
Lien vers le commentaire
Partager sur d’autres sites

il y a 26 minutes, spid99 a dit :

Non Oui,  pour le SBUS il faut souder sur le "SBUS out"

image.png.6acac5df01c617772e5a232d0faaa9c5.png

ET oui ne pas mettre sur le RX1, mais sur "SBUS" (Enfin tu peux tester les deux ..Avec Frsky c'est jamais très évident ^^)

Pour "l'inverted"

Seule la ligne "set serialrx_inverted = OFF (ou ON) compte ..

en mettant sur SBUS OUT et SBUS ça fonctionne ! la radio réagit sur Betaflight ! merci beaucoup !

il faut juste que je configure les sticks car ça ne correspond pas aux bons

un grand merci !! 

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

J’ai modifié mes branchements finalement 

pour ceux que ça intéresse et qui sont confrontés au même problème que moi, voici la procédure à suivre avec le R9MM-OTA et la FC Mamba F405 / Taranis QX7 :

- flash des deux composants en FLEX ACCESS

- soudures RX/ FC : 5V/5V, GND/GND, Inversed S.Port/ TX1 

- onglet Ports de BetaFlight : mettre Serial RX sur UART1

- dans l’onglet Récepteur : mettre la configuration UART et FrSky FPort 

- dans la radio, aller dans l’onglet où il y a le récepteur, cliquez dessus puis Options. Sélectionner F PORT (normalement c’est S PORT par défaut)

- dans CLI, tapez les commandes suivantes

set serialrx_halfduplex = ON
set serialrx_inverted = OFF

normalement les sticks devraient bouger sur BetaFlight 😉

pensez aussi à chercher les nouveaux capteurs dans l’onglet Récepteur de la radio

Et puis vous avez aussi RSII et télémétrie via ce F.Port. Chose qui n’était pas possible en SBUS uniquement étant donné qu’il fallait un TX libre me semble-t-il et je n’avais ai plus (RX, VTX, GPS)

j’ai pas mal galère à trouver la procédure exacte !

Modifié (le) par Nitneuq26
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
  • YouTube / WE are FPV

×
×
  • Créer...