Aller au contenu
DroneBuilds

[Novice] Config betaflight pour bumblebee


Messages recommandés

Bonjour,

 

Alors je suis un complet novice dans le monde du fpv et pour le coup, j'ai un peu de mal à débuter avec mon premier drone.

J'ai donc investi dans un Iflight Bumblebee avec le système DJI (un pack complet). Et maintenant il me faut passer par la case betaflight.  La version sur le drone est la 4.1.2, la version actuelle de betaflight on est a la 4.2.2.

J'ai trouvé un très bon tuto justement betaflight 4.2 qui explique pas mal de chose mais j'ai un soucis c'est que beaucoup de points dont il parle (bi-directionnal, rpm filtering, ...) qu'il débloque via une un firmware alternatif, etc... J'ai également trouvé une notice faite par "Oscar Liang " (je ne connais pas mais il semble être reconnu) sur ce modèle mais en une version antérieure.

Ici mon bumblebee est une version v2, toute récente ayant apparemment plusieurs différences dont le bi-directionnal et rpm filter déjà activé. Aussi dans BLheli, dans la vidéo tuto les moteurs apparaissent après avoir cliquer sur le "read setup", dans mon cas je n'ai pas réussi je ne sais pas pourquoi. Il affiche avoir lu avec succès mais rien n'apparait.

Au final de mon test j'ai en tout cas fini par régler très peu de choses (principalement tous les différents modes, armement, pre arm, beeper, etc...) sur les aux que je souhaitais. Je n'ai rien changé au PID ou aux rates. Je voulais faire un test sans intervenir la dessus. J'ai donc essayé de le faire décoller et là ça n'a pas du tout été.

Je l'ai fait décoller en intérieur et au décollage il avait tendance à se déporter et aussi et surtout j'avais l'impression que malgré que je descende mes gaz à zéro, les hélices continuaient à tourner.

J'ai également eu des bips continu lorsque le drone était branché sur betaflight après mon test de vol. Pour régler ça j'ai chargé le diff all que j'ai fait dans le CLI lors du premier branchement avant de changer quoique se soit et je suis donc revenu à un reset de tout betaflight.

 

Alors je suis pilote drone pro avec licence mais j'ai plutôt l'habitude de machines tel que dji phantom ou mavic pro. C'est tout un nouveau monde pour moi le fpv donc je ne sais pas si  ce que j'ai essayé de faire dans betaflight hier était bon. Je pense avoir oublier certainement beaucoup de réglages qui pour un utilisateur averti est évident.

 

J'ai un peu tout mis en vrac de ce que j'ai eu hier, désolé si cela manque de clarté. Si vous avez des conseils, des guides ou autres que je peux suivre les yeux fermés je suis preneur.

 

Merci à vous 🙂

Lien à poster
Partager sur d’autres sites

quelques indices:

Oscar Liang excellent !! (Ma bible) Mais d'autres aussi 😎

Pour tes moteurs qui tournent c'est l'airmode qui est activé en permanent et par défaut  (onglet configuration Betaflight) A décocher 😉

Pour les bips, toujours pareil (hormis une batterie vide) , onglet configuration et tu peux choisir tout types d'alertes, ou pas.

Et pour oublier certains réglages ( legitime quand on commence avec ce materiel et un configurateur) il y en a un qui doit être IMPERATIF: Le failsafe !

Déjà un inter "Armement" des moteurs pour la sécurité. Et evidement t'assurer que quand tu coupes (switch off) ta radio, le kwad s'arrete ! ( reglé par défaut à 4s sur le configurateur, je t'invite à le passer à 2s. Car deux secondes de plus,  avec la vitesse de ces engins il a le temps d'aller encore "loin" 😉

La suite, ben... Au suivant ! 

Lien à poster
Partager sur d’autres sites

En relisant la notice d'Oscar Liang ça m'a permit de refair le point sur effectivement quelques réglages.

Je ne pourrai regarder à tout ça ce soir mais je viendrai certainement donner des nouvelles (bonnes ou mauvaises ^^).

 

Une idée du pourquoi dans BLheli les moteurs ne se sont pas affichés ? J'ai vu qu'il existait BLheli et BLheli32, une différence particulière entre les deux ?

Lien à poster
Partager sur d’autres sites
il y a une heure, Alcor a dit :

Une idée du pourquoi dans BLheli les moteurs ne se sont pas affichés ? 

J'ai vu qu'il existait BLheli et BLheli32, une différence particulière entre les deux ?

 

Parce qu'il faut mettre sous tension ton kwad (Retirer les helices ! )

Quels sont tes ESC ?

Modifié (le) par CriTof
Lien à poster
Partager sur d’autres sites

Alors, j'ai resuivi la notice d'Oscar Liang et ça va nettement mieux. Du moins j'ai l'impression.

Dans un premier temps je remarque que mes moteurs sont nettement moins chaud que hier soir avec les quelques secondes successives de vol. Je ne l'ai pas vraiment fait voler, à peine quitter le sol mais hier pour un "vol" similaire les moteurs étaient assez chaud. Ici ils restent froid.

 

Ensuite dans betaflight j'ai activé le motor stop (les hélices ne doivent pas tourner si y a pas les gaz), j'ai désactivé l'airmode permanent mais malgrés tout les moteurs continuaient à tourner malgré que mes gaz soit à zéro.

Après je pense que j'étais en mode "airmode" via les auxiliaire (angle/airmode...). Question bête mais donc, si je suis en airmode actif, les moteurs tournent encore même si les gaz à zéro ?

 

J'ai également ajouté le failsafe. Maintenant il faut que je réfléchisse à ce que je mets sur chaque aux de la radio dji. Ici j'ai mis armement aux 1 (position 3), angle/airmode sur l'aux 2 (position 1 et 2 respectivement), failsafe et beeper sur aux 3 (position 2 et 3) et pre arm sur aux 4 (position 3).

Est-ce que cela vous semble cohérent ? Peut-être d'autres options indispensable à mettre, ou à enlever ?

 

@CriTof, j'ai oublié de prendre note des esc que j'ai. En tout cas, à nouveau avec BLheli rien n'est apparu, avec BLheli32 là par contre ça a fonctionné et j'ai pu changer ce qui était conseillé par Oscar Liang.

Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Juste une petite mise à jour,

Je pense être dans le bon, je n'ai toujours fait que des tests en vol intérieur donc je fais relativement que du surplace et des petits déplacement mais ça fonctionne. Les moteurs montent en température légèrement mais ne sont pas du tout brulants. Je ne sais pas trop quand cela est "trop chaud" mais ça me semble en tout cas modéré. Je prendrai la température la prochaine fois.

Pour ce qui est des moteurs qui tournent toujours, oui, j'ai donc bien compris avec l'airmode. C'était une bêtise mais c'est bon. 🙂

Faut que je m'habitue aussi aux différents modes sur les boutons auxiliaires pour que se soit confortable.

 

Maintenant la grosse prochaine partie va être les PID et les rates. J'ai commencé à regarder des tutos et lire de la doc. Ça reste très flou tant qu'on a pas vraiment fait des tests. Dans l'état actuel je trouve qu'il est assez vif malgré des petits mouvements et j'ai l'impression qu'il y a un certain délai quand je fais par exemple des gauche/droite. (Typiquement je fais des gauche/droite et j'ai l'impression que c'est compliqué de réellement l'arrêter, je sais pas si c'est assez clair :p).

 

Voilà voilà,

Bonne journée 🙂

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / WE are FPV

×
×
  • Créer...