Aller au contenu
DroneBuilds

[tango/crossfire: bind puis pb Télémetry lost..unbind] babyhawk 2 hd bnf crossfire


Messages recommandés

Bonjour,

J'ai suivi la video waf pour la mise en route tango2.

PROBLEME:

Je viens de binder la tango 2 v3 avec le crossfire du babyhawk 2 hd  via tbs agent lite (message d'update une seule fois uniquement validé avec le téléchargement) et aussitot fait, j'ai eu le message vocale télémetry lost et il n'y a plus eu de bind. La tango revient en orange.(= Remote powered on and no receiver is bound/ active)

Quand je réésaye le bind, Le crossfire clignote rouge 1 fois puis 2 fois vert.. Jamais de vert fixe (sauf la toute 1e fois après l'update)

La procédure de bind que j'ai refait est de cliquer sur bind dans tango, puis cliquer sur le btn crossfire du drone et j'ai bien le message bind  OK la plupart du temps mais pas de tango en vert.

J'ai mis à jour de le dernier firmware crossfire via agent tbs, c'est peut etre ça..

VERIFICATIONS:

J'ai vérifié les versions et je suis en tbs 1.2.9 avec le firmware 4.11 donc à priori c'est OK niveau compatibilité. (vu dans la doc tango)

La connexion en usb sous betaflight fonctionne sauf la radio, on voit bien que c'est déjà préconfiguré en crossfire(csrf). (Le drone bnf crossfire est arrivé préconfiguré betaflight)

Normalement avec ce bnf, je n'ai rien à touché, betaflight indique bien : 4.2.5 for STM32F411 Target  (comme indiqué dans la doc emax)

Aucune info sur le bind dans la doc emax babyhawk, normalement ca se fait tout seul avec la procédure de bind tango puis clic sur btn crossfire)

Je ferai surement un reset de la tango demain pour rééssayer. J'ai trouvé la doc crossfire  (doc crossfire nano), mais je crois pourtant que je suis ok au niveau de la procédure ?

Par contre, impossible de réavoir une nouvelle fois, le message rx update au niveau de la tango quand j'essaye de rebind.

Si quelqu'un peut m'aider, je suis preneur. Je suis à deux doigts de voler ...

IMG_20210528_015312.jpg

IMG_20210528_005626.jpg

IMG_20210528_005231.jpg

Modifié (le) par magiknono
Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

J'arrive à avoir du vert fixe sur la tango

Par contre, dans telemetry, j'ai une erreur FM:Err

 

A voir ce qu'il faut faire pour la prochaine étape ... car les moteurs ne tournent pas avec la radio. et les joysticks non détectés dans betaflight.

Modifié (le) par magiknono
Lien à poster
Partager sur d’autres sites
Il y a 3 heures, magiknono a dit :

A voir ce qu'il faut faire pour la prochaine étape

CRSF Shot, demande une version spéciale de betaflight !

Pour binder, pas besoin d’appuyer sur le bouton du RX !

Lien à poster
Partager sur d’autres sites

@Attafr Bon, je vais voir s'il faut que fasse cette procédure pour installer csrf sur la radio...

Pour betalight, j'utilise configurator 10.7, le dernier

Oui ok, j'ai vu qu'il n'y avait pas besoin d'appuyer sur le bouton du RX...

Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Bon,

1)j'ai branché la radio tango 2 v3 en mode bind (sur radio > tbs agent lite puis tango2 xf puis bind)

2)j'ai branché le drone en usb puis connecté la batterie (tango passe en vert fixe)

3) esc = 1 led fixe verte et une led rouge clignotante. rx crossfire = 2 clignotement rapides

4) lancement de betaflight configurator 10.7 :

Configurateur: 10.7.0
Microprogramme: BTFL 4.2.5
Cible: BHHD/EMAXF411(STM32F411

Le drone bouge, mais les joystick ne bougent pas.

Dans recepteur, je suis en TAER1234 puis aux5

Dans moteurs, si je clique sur arm, et monte les curseurs avec la souris, les moteurs tournent.

5) CLI, command "status", on voit sd card not configured, je ne peux pas utiliser le joystick ou armer

MCU F411 Clock=108MHz (PLLP-HSE), Vref=3.28V, Core temp=55degC
Stack size: 2048, Stack address: 0x2001fff0
Config size: 3924, Max available config: 16384
Gyros detected: gyro 1
GYRO=MPU6000, ACC=MPU6000
OSD: MAX7456
System Uptime: 271 seconds, Current Time: 2021-05-28T14:24:02.386+00:00
CPU:19%, cycle time: 125, GYRO rate: 8000, RX rate: 33, System rate: 9
Voltage: 1617 * 0.01V (4S battery - OK)
I2C Errors: 0
SD card: Not configured
Arming disable flags: RXLOSS CLI MSP

Lien à poster
Partager sur d’autres sites

J'ai le NANO RX qui est apparu dans agent X sur pc puis j'ai eu dans la tango>Agent Lite un menu "nano rx" et quand je cliquais rien à l'intérieur.

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

Bon, j'ai le menu NANORX dans la tango avec general map output map quand la tango est relié au pc avec tbs agent X allumé.

La led du NANO RX clignote toujours en vert. Rien ne se passe de plus dans betaflight, les joystick ne bougent pas etc

Bon, j'abandonne pour le moment ...

Je pense que j'essaierai d'installer le dernier opentx comme proposé, mais bon j'ai deja l'option CSRF donc pour moi c'est déjà OK (et freedom tx 1.29 avec les 4.11 ca semble compatible)

Modifié (le) par magiknono
Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

Après avoir fait un reset du NANORX avec une procédure, j'ai enfin reussi via TBS agent a faire une update du receiver.

J'ai bien eu une led verte fixe !!! et dans betaflight, mes joystick bougeaient !!!!

Par contre, pas de reboot de la radio.

Après tout ca, vu qu'il n'y pas plus de mise à jour ou autre, je reboot les deux et je suis revenu à une led verte et rouge clignotante...

 

- procedure de reset si ca interesse qqun:

Modifié (le) par magiknono
Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

J'ai enfin réussi à tout faire tourner les hélices et configurer les sticks, reste plus qu'à mettre les hélices !

J'ai du faire à nouveau un reset du nano puis vu que le nano, ne s'ajoutait pas dans TBS Agent, j'ai bind le "tango 2 xf".

Ensuite j'avais update via "xf nano rx", la led devenait verte fixe.

Après avoir vérifié dans betaflight que les joystick répondait et que les moteurs tournaient, j'ai modifié le "yaw deadband" à 3.

Une fois sauvegardé, j'ai eu le message sur la tango2", "exit receiver". A chaque fois que j'ai ce message, il faut réinitialiser le "nano rx" puis rebind via tbs agent.

Donc je refais le reset "nano rx", puis tbs agent ne me detecte pas "xf nano rx" donc je vais dans "xf tango2" puis je bind et update le micro receiver. Et la besoin d'aller dans "nano rx", la led devient verte fixe et tout fonctionne.

- Je mets la deuxième video, si ca peut aider quelqu'un :

Modifié (le) par magiknono
Lien à poster
Partager sur d’autres sites

Topic clos, maintenant à chaque fois que j'ai un unbind intempestif :

1) j'allume la radio tango et la branche sur TBS agent X

2) je branche le drone en usb et met la batterie

3) je fais le reset du nano rx et dès que la led clignote en vert lent. Je débranche et rebranche la batterie drone

5) je passe la radio tango en bind (sans appuyer sur le bouton)

6) je vais dans tbs agent X, si le nano rx n'est pas detecté, je vais dans tango 2 xf et clique sur bind puis j'update le micro receiver quand proposé.

7) normalement, la led du rx passe en vert fixe et c'est bon

Il n'y'a plus qu'à allumer la tango puis le drone et c'est pret à voler !

8 ) dans tbs agent X, le nano rx ne passe pas forcément en vert mais bon le bind précédent en général suffit.

J'ai réussi une seul fois à bind via l'icone nano rx mais en général via l'icone tango 2 xf ca suffit.

Y'a surement un point que je comprends pas pour que le nano rx passe en vert, desfois, j'ai bind 2 fois le xf tango2 pour que ca apparaisse.

Note1: si la tango fait exit receiver, le nano rx est unbind, il faudra refaire cette procédure du point 1 à 7 pour avoir la led verte fixe.

Note2: si l'update du micro receiver stagne trop, je clique sur cancel et je la refais et sinon le clic sur cancel suffit parfois à rebind

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...