Aller au contenu
acheter dji air unit o3
DroneBuilds

ESC, r-xsr, telemetrie, je regroupe toutes mes questions


elpigeondindo
Aller Ă  la solution RĂ©solu par elpigeondindo,

Messages recommandés

Salut les flyers !

Je vais essayer de regrouper toutes mes interrogations dans un seul sujet ca sera plus simple et moins le bordel 😁.

Pour info j'ai un mamba F40 qui est stacké avec un mamba F722 mk1, le tout relier par une petite nappe et je suis sous BF 4.3. Mon rx est un FrSky r-xsr

1/ L'ampérage dans betaflight

Voila j'aimerai avoir le retour de la tension dans betaflight mais avec l'ADC mais mesurer par l'ESC. Si j'ai bien compris les images que j'ai pu voir sur le net, la nappe est sur le RX6 donc dans BF j'ai mis ESC sur l'UART6. J'ai activé ESC_SENSOR dans la partie moteur. Mais ca me remonte rien du tout. J'ai l'ampérage uniquement quand je met ADC interne.

2/ Le récepteur R-XSR

Sur celui ci j'ai plusieurs questions.

- DĂ©jĂ  lorsque vous le flasher, ne devrait il pas perdre le bind avec la radio ? Moi il reste binder, j'ai l'impression que le flash ne fait rien, je reste en Fport. Peut on savoir dans quel mode est le rx, c'est a dire SBUS ou Fport?

- Il faut bien que la LED bleue soit allumé pour etre en SBUS sinon je suis en cppm n'est ce pas?

- Ensuite si je le flash avec ce firmware "RXSR_ACCST_2.1.0_LBT.frk" je suis bien en SBUS non? 

- Je branche mon +5 et mon GND normalement. Je soude mon sbus sur le RX1 et ensuite mon S.Port sur le point F.Port 3 comme sur la photo si dessous. En fait je suis le schĂ©ma du mamba. Apres je dĂ©clare mon RX sur l'UART 1, mais j'ai aucun retour des stick. (ce qui revient a ma 1ere question si mon flash est bien appliquer et que je reste pas en fport.). De plus si j'active le rx sur l'UART1, dans quel UART je dois mettre le smartport 😼 ?

1136494450_Capturedcran2022-06-03084109.thumb.png.59b021c749075872c537a53d27f6cc08.png

 

Voila pour l'instant, j'espĂšre ĂȘtre assez clair et pas me tromper dans les termes. Je suis un tout nouveau flyer alors soyez indulgents 😅. 

Lien vers le commentaire
Partager sur d’autres sites

Salut,

Je dĂ©place dans entraide 🙂

Le 03/06/2022 at 08:50, elpigeondindo a dit :

1/ L'ampérage dans betaflight

Voila j'aimerai avoir le retour de la tension dans betaflight mais avec l'ADC mais mesurer par l'ESC. Si j'ai bien compris les images que j'ai pu voir sur le net, la nappe est sur le RX6 donc dans BF j'ai mis ESC sur l'UART6. J'ai activé ESC_SENSOR dans la partie moteur. Mais ca me remonte rien du tout. J'ai l'ampérage uniquement quand je met ADC interne.

Ampérage et tension ce sont 2 choses différentes.

Perso jme suis jamais attardĂ© sur la conso avec BF, toujours une plaie Ă  mettre en Ɠuvre et pas toujours fiable... 

Pour les questions FrSky, je passe, ça fait trop longtemps que je pratique plus 😞 

Lien vers le commentaire
Partager sur d’autres sites

il y a 26 minutes, Motard Geek a dit :

Salut,

Je dĂ©place dans entraide 🙂

Ampérage et tension ce sont 2 choses différentes.

Perso jme suis jamais attardĂ© sur la conso avec BF, toujours une plaie Ă  mettre en Ɠuvre et pas toujours fiable... 

Pour les questions FrSky, je passe, ça fait trop longtemps que je pratique plus 😞 

Oui je comprends mais comme je suis nouveau, je n'ai pas encore le retour et l'experience qu tu as pu avoir avec tes centaines d'heures de vol 😁. Pour debuter ca peut etre sympa pour eviter que ca ne tourne mal

Lien vers le commentaire
Partager sur d’autres sites

Le 03/06/2022 at 08:50, elpigeondindo a dit :

 

1/ L'ampérage dans betaflight

Voila j'aimerai avoir le retour de la tension dans betaflight mais avec l'ADC mais mesurer par l'ESC. Si j'ai bien compris les images que j'ai pu voir sur le net, la nappe est sur le RX6 donc dans BF j'ai mis ESC sur l'UART6. J'ai activé ESC_SENSOR dans la partie moteur. Mais ca me remonte rien du tout. J'ai l'ampérage uniquement quand je met ADC interne.

 

 

Tu te casses un peu la tĂȘte. t'as juste besoin de la tension par cellule dans l'OSD, avec pourquoi pas des alertes vocales de la radio via la tĂ©lĂ©mĂ©trie. et a la limite si tu veux voir ce qu'il te reste en mah tu peux ajouter une barre dans l'OSD (a condition que tout soit bien calibrĂ©).



 

 

Le 03/06/2022 at 08:50, elpigeondindo a dit :

 

2/ Le récepteur R-XSR

Utilises la belle barre de recherche toute neuve du fofo qui a couté un bras a Motardgeek pour qu'on ai plus d'aisance , doit y avoir 500 topic sur le R-XSR

image.thumb.png.d80e8b1e409e6e28a67744b536ae7c16.png

Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV

Oui sur le r-xsr j'en ai lu pas mal en effet mais j'arrive pas toujours a pigĂ©. Vais continuer alors mes recherches. Je voulais juste les precisions sur les interrogations que j'avais 😅

Pour la tension justement je veux la tension des cellules, mais c'est pas possible d'avoir l'information de l'esc au lieu de celle de l'ADC interne?

Lien vers le commentaire
Partager sur d’autres sites

Je trouve bizarre qd meme que ma telemetrie sur ma QX7 deconne. J'ai tout bien fait, flash r-xsr en fport, soudé le fil sur un UART, configurer tout ds betafligt. J'ai bien ma radio bindé, les sticks fonctionnent dans betaflight. Par contre sur ma QX7 la telemetrie fonctionne des le debut, ca envoi une infos et apres il y a perte de telemetrie, comme si la FC n'envoyait qu'une seule fois et au debut l'infos de la telemetrie.

Y'a un reglages de frequence d'envoi a faire ds BF ou dans le CLI?

Lien vers le commentaire
Partager sur d’autres sites

F7 et R-XSR c'est un peu spécial,  il te faut utiliser le pad uninverted f-port de ton recepteur et pas celui de la prise

APrÚs, t'es des lignes a entrer dans le CLI, tu les retrouvera facilement 

Lien vers le commentaire
Partager sur d’autres sites

  • 2 weeks later...
  • Solution

Me re-voila.

Apres pas mal de recherche et de teste je reviens vous dire pourquoi j'avais des problÚme de remonter de télémétrie sur ma QX7 et comment j'ai résolu.

En fouinant ici et ailleurs j'ai trouvé qu'il y a pas mal de bug sur le firmware du r-xsr 2.1.1 Fport. Du coup pour éviter ce genre de souci il faut obligatoirement installer le firmware 2.1.0 Fport. 

Vous pourrez le trouver dans l'archive des firmware du 2020-08-03 chez OpenTX-Doc. 

Voila sujet clos pour moi, merci de votre aide.

Modifié (le) par elpigeondindo
  • Merci ! 2
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez ĂȘtre membre afin de pouvoir dĂ©poser un commentaire

Créer un compte

CrĂ©ez un compte sur notre communautĂ©. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • CrĂ©er...