Aller au contenu
bannière promotion betafpv elrs
DroneBuilds

Branchement Mamba f405 mk2 V2 + R9mm-ota


Kev42
Aller à la solution Résolu par Kev42,

Messages recommandés

Bonsoir,

j'ai recu ma fc Mamba f405 mk2 V2 et je voudrais branché mon récepteur qui est le R9mm-ota mais il y a plusieurs choses sur lesquelle je ne suis pas sur:

Premièrement j'aimerais savoir si je peux utiliser le F.port et si oui sur quel pin faut il branché les cables (même si je ne peux pas je voudrais bien une confirmation des pin du Sbus et S.port).

Deuxièmement j'aimerais savoir si je dois utiliser le inverted S.port ou le S.port car j'ai compris qu'il fallait que le signal soit invérser mais je ne sais pas comment savoir quel pin de la FC sont inversé.

PS:j'ai quelque doc sur la FC si il les faut

Merci beaucoup

Bonne soirée

Lien vers le commentaire
Partager sur d’autres sites

Salut,

Tu as une F4, donc aucun port n'est inversable sur ta FC, à part le RX prévu pour le SBUS.

Si tu passes en F.Port, il faut utiliser le Inverted S.Port du coup.

Je prends les devants : le plus grand service que tu puisses te rendre c'est de jeter ton R9 à la poubelle et passer sur du ELRS 😉 

  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

Salut 

Merci beaucoup pour ta réponse mais sa ne m'aide pas complètement mdrrr 

Donc si j'ai bien compris pour utiliser le f.port il faut que j'utilise le inverted s.port mais sur la FC je branche sur quel pin? Celui qui correspond à la télémétrie? D'après la Doc la télémétrie correspond à l'uart6

Lien vers le commentaire
Partager sur d’autres sites

il y a 21 minutes, Kev42 a dit :

Donc si j'ai bien compris pour utiliser le f.port il faut que j'utilise le inverted s.port mais sur la FC je branche sur quel pin? Celui qui correspond à la télémétrie? D'après la Doc la télémétrie correspond à l'uart6

Si t'es en F.Port, tu ne fais plus que la télémétrie, tu fais tout sur un seul fil : télémétrie, signal et RSSI. Tu te places sur n'importe quel pad TX dispo de la FC.

Lien vers le commentaire
Partager sur d’autres sites

il y a 5 minutes, Jerome a dit :

Si t'es en F.Port, tu ne fais plus que la télémétrie, tu fais tout sur un seul fil : télémétrie, signal et RSSI. Tu te places sur n'importe quel pad TX dispo de la FC.

Donc elle suffit que je flash le mm-ota avec le firmware f.port que je câble le 5v,gnd et le inverted s.port sur n'importe qu'elle TX et c'est bon? Si c'est sa c'était vraiment pas compliqué finalement 🤣 mais merci beaucoup 

Lien vers le commentaire
Partager sur d’autres sites

il y a une heure, Kev42 a dit :

Donc elle suffit que je flash le mm-ota avec le firmware f.port que je câble le 5v,gnd et le inverted s.port sur n'importe qu'elle TX et c'est bon? Si c'est sa c'était vraiment pas compliqué finalement 🤣 mais merci beaucoup 

Et que tu sois dans les bonnes versions de firmware, que ça soit pour EdgeTX, le RX et le TX. Et que la config soit bonne côté BF et radio.

Quand on fait tout bien, ca marche assez facilement. Mais la plupart du temps, les gens galèrent... FCC/LBT/Flex, ACCESS/ACCST, SBUS/F.Port... Inverted/UnInverted etc.

Bref, comparé à ELRS, c'est propriétaire, c'est plus cher, c'est moins performant, c'est pratiquement pas maintenu, c'est moins dispo et c'est plus compliqué 😉

Lien vers le commentaire
Partager sur d’autres sites

Il y a 5 heures, Jerome a dit :

Et que tu sois dans les bonnes versions de firmware, que ça soit pour EdgeTX, le RX et le TX. Et que la config soit bonne côté BF et radio.

Quand on fait tout bien, ca marche assez facilement. Mais la plupart du temps, les gens galèrent... FCC/LBT/Flex, ACCESS/ACCST, SBUS/F.Port... Inverted/UnInverted etc.

Bref, comparé à ELRS, c'est propriétaire, c'est plus cher, c'est moins performant, c'est pratiquement pas maintenu, c'est moins dispo et c'est plus compliqué 😉

Bon je vais essayer ce soir de brancher si j'ai le temps et je verrai pour les réglages sinon je reviendrai ici🤣

Bon bah si un jour le r9m rend l'âme je sais ce que j'ai a faire alors mais pour l'instant le r9m sa me suffit mdrrr

Lien vers le commentaire
Partager sur d’autres sites

  • Solution

Bon bah je viens d'essayer j'ai donc branché mon r9 mm-ota(le inverted s.port/f.port) sur le tx1 comme conseiller dans la doc ainsi que le 5v et gnd mais maintenant je ne peux pas bind les 2 led restent fixe durant la procédure de bind et lors de l'allumage normal seulement la led rouge s'allume 

Je viens de réessayer mais c'était que la procédure de bind n'est pas ma même en Access et accst j'ai donc regarder une vidéo j'ai fait de même et sa n'a pas marché du premier coup mais au bout de 3 essai le récepteur a été vu merci pour tout 

Lien vers le commentaire
Partager sur d’autres sites

Bon je reviens encore une fois ici en espérant que sa soit la dernière 😜 

Mais j'ai mon récepteur qui est bien bind mais dans betaflight je n'ai aucune réaction dans l'onglet récepteur je rappelle que j'ai branché le r9 mm-ota avec le f.port inversé sur le tx1  de la mamba

16926983570878127355532291008996.jpg

16926984067634055078237009548492.jpg

16926984381111310664995217796412.jpg

Lien vers le commentaire
Partager sur d’autres sites

Je t'avais prévenu 😄

T'as bien sélectionné le protocole radio dans les options du Cloud Build, avant de télécharger le firmware ?

Lien vers le commentaire
Partager sur d’autres sites

Oui, voilà, exactement ce qu'a monté @spid99. Par défaut, le protocole F.Port n'est plus intégré au firmware, faut bien l'avoir sélectionné dans les options de compilation.

Lien vers le commentaire
Partager sur d’autres sites

il y a 1 minute, Jerome a dit :

Oui, voilà, exactement ce qu'a monté @spid99. Par défaut, le protocole F.Port n'est plus intégré au firmware, faut bien l'avoir sélectionné dans les options de compilation.

Bon sa avance doucement j'ai changé pour mettre F.port et cela m'a permis de voir tout les aux contrairement à avant mais il ne se passe toujours rien(je vous met l'image avant/après)

recepteur.PNG

recepteur2.PNG

Lien vers le commentaire
Partager sur d’autres sites

il y a 1 minute, spid99 a dit :

Essaie un autre TX, en oubliant pas de changer l'UART ..

OK je vais essayer mais faut que je change tout car tout les uart sont pris mais dans la doc il conseillai le 1 pour le receveur c'est pour sa que je l'avais branché la.

Mais le problème ne peut pas venir du fait que j'ai branché sur f.port inverser sur le mm-ota?

Car sur la doc il y a ecrit tx1 avec un autre 1 a coté cela ne veut pas dire que c'est déja inversé sur la carte?

Lien vers le commentaire
Partager sur d’autres sites

il y a 7 minutes, Kev42 a dit :

Mais le problème ne peut pas venir du fait que j'ai branché sur f.port inverser sur le mm-ota?

Car sur la doc il y a ecrit tx1 avec un autre 1 a coté cela ne veut pas dire que c'est déja inversé sur la carte?

Si tu peux essayer, rien à perdre, mais comme déjà dit plus haut, FRSKY est une vrais galère ...L'ELRS semble bien plus simple, moins cher et plus performant 😉

Modifié (le) par spid99
Lien vers le commentaire
Partager sur d’autres sites

à l’instant, spid99 a dit :

Si tu peux essayer, rien à perdre, mais comme déjà dit plus haut, FRSKY est une vrais galère ...L4ELRS semble bien plus simple, moins cher et plus performant 😉

sa je l'ai bien compris je le retiendrais pour la prochaine fois mdrrr

mais je vais quand même essayer car sa fait trop longtemps que j'ai pas voler 🤣

Lien vers le commentaire
Partager sur d’autres sites

il y a 9 minutes, Kev42 a dit :

Car sur la doc il y a ecrit tx1 avec un autre 1 a coté cela ne veut pas dire que c'est déja inversé sur la carte?

Non, je ne pense pas qu'il soit inversé, c'est très rare que ça soit le cas et y a un trait au dessus en général. Le "1" c'est juste un raccourci sur le schéma pour pas croiser les lignes.

Essaie de passer cette commande : 

set serialrx_halfduplex = ON
save

(avant de le changer, vérifie sa valeur actuelle pour y revenir si ça ne marche pas).

Lien vers le commentaire
Partager sur d’autres sites

il y a 7 minutes, spid99 a dit :

Si tu peux essayer, rien à perdre, mais comme déjà dit plus haut, FRSKY est une vrais galère ...L'ELRS semble bien plus simple, moins cher et plus performant 😉

enfiiiin finalement c'était tout simple car avec le r9m il faut taper 2 lignes de commandes que j'avais tapé tiut a l'heure mais vu que j'avais pas choisi F.port j'ai du reflashé la carte mais j'avais oublié de les retaper mais maintenant c'est tout bon pour l'instant 

il y a 1 minute, Jerome a dit :

Non, je ne pense pas qu'il soit inversé, c'est très rare que ça soit le cas et y a un trait au dessus en général. Le "1" c'est juste un raccourci sur le schéma pour pas croiser les lignes.

Essaie de passer cette commande : 

set serialrx_halfduplex = ON
save

(avant de le changer, vérifie sa valeur actuelle pour y revenir si ça ne marche pas).

oui c'était bien cette commande avec en plus /

set serialrx_halfduplex = ON

set serialrx_inverted = OFF

save

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
  • YouTube / WE are FPV

×
×
  • Créer...