Jump to content
DroneBuilds
psixkho

Aucune réponse sticks et inters modes sur BF 3.5.1 SP Racing F3 / QX7 EULBT / R-XSR EULBT

Recommended Posts

Salut à tous, 

J'ai un gros problème avec ma SP Racing F3 de mon X220 (tout d'origine sauf la PDB que j'ai changé pour une Matek FCHUB-6S), j'ai une QX7 EULBT, bien bindée à mon R-XSR (EULBT aussi, acheté sur DFR), la télémétrie fonctionne parfaitement mais dans l'onglet receiver et au niveau des modes, je n'ai rien qui bouge au niveau des barres et des zones d'activation...

J'ai beau recherché sur internet, la seule piste qui revient à chaque fois serait un souci de firmware soit côté RX soit côté radio pour le XJT 😕 

J'avoue avoir un peu peur de devoir toucher au récepteur ou même au XJT pour les flasher à nouveau de peur de faire une connerie et devoir binder à nouveau, @FanZ a galéré à arriver à faire communiquer le rx et la radio ensemble après avoir changé la PDB et le récepteur (d'un D4R-II pour un R-XSR et la FCHUB-6S suite à l'arrachage de soudures après une chute et le bouton de bind qui a dégagé sans le vouloir)

J'ai tenté avec les menus de la radio en anglais (opentx-x7-ppmus-multimodule-noheli-nogvars-lua-sqt5font-en.bin actuellement et même opentx-x7-ppmus-multimodule-noheli-nogvars-lua-sqt5font-fr. bin mais sans succès - radio en mode 2 APGD et TAER pour les menus anglais).


Version firmware XJT : XJT_EU170317.frk

Config actuels inters :
SD bas : Aux1 (arm)
SC bas : Aux2 (modes)
S2         : Aux3 (buzzer)


Voici les screens de ma config betaflight et de ma radio :996927095_BF1.thumb.jpg.952370b43c69765abed4f61899f4d13b.jpg1156381701_BF2.thumb.jpg.3e438f7c13ac16a7ac2f3a8f3c6458aa.jpg157115881_BF3.thumb.jpg.6fe3e37fbd75c2d7c04e30fa3c7b61c4.jpg1449028176_BF4.thumb.jpg.9fce0a83661e06c8b463eeab6f610c7a.jpg1468291035_BF5.thumb.jpg.3be6b6b7cafc31d5968b1ff48f2a370f.jpg

screen-2018-11-24-180958.bmp
screen-2018-11-24-181357.bmp
screen-2018-11-24-181400.bmp


screen-2018-11-24-181441.bmp
screen-2018-11-24-181444.bmp
screen-2018-11-24-181618.bmp
J'ai également un problème avec le throttle qui ne se "plaque" pas correctement en bas depuis un moment, du coup, je dois jouer avec le min / max et subtrim de la radio pour cette entrée / sortie, si quelqu'un sait où aller pour corriger le problème, ça serait sympa aussi (ça ne change pas avec la calibration, ça a l'air d'être un problème interne au gimbal) 😕

Merci pour les solutions parce que je ne sais absolument pas comment réussir à avoir un drone fonctionnel à 100% 🙂 

Share this post


Link to post
Share on other sites

Depuis la 3.5, j'ai jamais réussi à faire fonctionner un R-XSR autrement qu'en F-Port... Me demande pas pourquoi 😅

Sur ma Omnibus F3 ou sur ma DALRC F405, même constat. Si Betaflight 3.5 et R-XSR ça n'a marché qu'en F-PORT. 

Share this post


Link to post
Share on other sites

Merci à toi de ta réponse Kestrel, vu que je ne sais pas comment passer en F.Port, je suis coincé et je ne me vois pas demander à FanZ de se taper tout ça, lui qui a limite horreur de BF et qui n'avait jamais eu besoin de flasher quoi que soit avant mon problème de firmwares et de soudures, je préfère éviter de lui faire faire ça (j'ai peur d'arracher le fil pour la télémétrie sur l'UART2 vu la finesse de la soudure 😕), j'ai peur qu'en touchant au drone à nouveau, quelque chose s'arrache même si je sais où faire le pont pour le bootloader sur la carte (j'avais fait l'update sur la 3.5.1 stable pour cette FC quand je lui ai racheté le drone)...

Share this post


Link to post
Share on other sites
Youtube WE are FPV
il y a 3 minutes, GodsWarrior a dit :

Je crois avoir vu le même problème récemment sur FB (ou alors c'est toi), une incompatibilité de la F3 avec le FW 3.5 du coup ?

Non, ce n'est pas moi qui a posté sur FB, je n'y suis quasiment jamais dessus, ce n'est que du survol on va dire pour le peu de temps que je m'en sers (quelques vidéos par-ci, par-là qui trainent et c'est tout).

On dirait bien une incompatibilité F3 et et BF 3.5+ à prioriri ou alors, un souci de firmware d'après ce que j'ai vu sur internet côté récepteur mais il me semble qu'il est à jour avec la dernière version dispo sur frsky-rc, ce qui me parait bizarre, c'est d'avoir la télémétrie uniquement à l'heure actuelle sur la radio, donc il y a bien des infos qui s'échangent d'un côté et de l'autre mais seulement en sens unique (rx ====> radio)

Edited by psixkho

Share this post


Link to post
Share on other sites

Bon, après avoir vérifié que le récepteur était en PPM ou S.Port, il s'avérait en fait que ce dernier était en PPM et c'était la raison du pourquoi il ne communiquait que partiellement avec la radio (sur BF 3.5.1 toujours) 😕 Les moteurs s'arment désormais correctement, modes ok (juste à revoir pour l'horizon et l'acro à définir correctement dans les plages dans l'onglet modes) 🙂 

Merci à vous en tout cas messieurs et j'espère pouvoir voler rapidement du coup, en espérant que je ne me soit pas planté dans le sens de rotation des hélices lol 😄 

@FanZ une petite session ce weekend pour vérifier tout ça, ça te dit ? 😄 

Share this post


Link to post
Share on other sites
Il y a 5 heures, psixkho a dit :

 

@FanZ une petite session ce weekend pour vérifier tout ça, ça te dit ? 😄 

Je te redis mais c'est pas gagné car la météo annoncée ne joue pas en notre faveur

++

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...