Jump to content
DroneBuilds
DingoFPV

betaflight 1 Moteur sur 4 ne répond pas

Recommended Posts

Bonjour,

 

Je suis en train d'établir mon premier build, j'avance étape par étape et aujourd'hui je bloque sur la calibration de mes ESC/Moteurs. Un de mes moteurs ne tourne pas.

Pour être plus précis sur les 5 vibrations du cycle de démarrage j'entends et sens les 3 premières sur mes 4 moteurs, en revanche les deux dernières n'en font bouger que 3 sur 4. J'ai des LED CLRacing à chaque moteur qui illustre bien mon ressenti, lors de la première phase les 4 s'allume lors de la seconde phase seulement 3 s'allume.

Sous BLHeliSuite32 Il ne détecte pas mon ESC4.J'ai essayé en DSHOT1200, ONESHOT125...

Si je résonne bien, ce n'est pas mes soudures ni l'ESC ni le moteur qui sont en cause, car le moteur réagit bien aux premières vibrations. J'ai pense à un problème sur la sortie Moteur 4 de ma FC qui déconne mais avant de casser mon connecteur et mettre de l'éteint partout pour passer par une autre sortie auriez vous des idées?

La FC et lESC sont reliés avec un connecteur JST mais j'ai le même problème si je les relis avec un connecteur FCC.

Merci 😉

Ma config matériel:

ESC 4in1 Typhoon 32 V2
FC OMNIBUS F4 V6
Moteurs EMAX RS2306

Betaflight 3.5.3

IMG_20181206_214013.jpg

IMG_20181207_235236.jpg

Edited by DingoFPV
Ajout Photo

Share this post


Link to post
Share on other sites

Jamais utilisé mais on dirait qu'on peut remapper les moteurs.

https://github.com/betaflight/betaflight/wiki/Remapping-Motors-with-Resource-Command-(3.1)

Peut être que si tu inverse 2 moteurs ça pourrait donner un indice supplémentaire...

Share this post


Link to post
Share on other sites

@DingoFPV ESC qui marche pas !

je viens d'avoir le même soucis sur un ESC 4en1 flycolors

j'ai bidouiller dans BLHELI_32 un peu toute les options puis quand j'ai essayer de faire tourner les moteurs avec bl_heli , le moteur N3 c'est mis a tourner , donc du coup j'ai fais les mise a jours de tous les ESC et maintenant tous roule !

Share this post


Link to post
Share on other sites

Bonjour,

@quazardousJe viens d'inverser deux moteurs le problème se situe sur l'autre maintenant. donc problème au niveau de la sortie ESC M4.

@biosuz je vais essayer de creuser un peu plus sur BLHELI_32 pour essayer de flasher cette ESC si j'arrive à prendre la main dessus

Share this post


Link to post
Share on other sites
Youtube WE are FPV

@DingoFPV

j'avais pareille que toi , je me suis amuser avec les options du menu " select BLheli_32 interface" j'ai choisis une option puis j'ai essayer de me connecter

, bien sur ça a planter , puis j'ai essayer une autre et même résultat, ensuite j'ai remis  la bonne option et la j'ai cliquer sur motor et j'ai réussis a faire tourner le moteur qui marchais pas.

je sais c'est empirique mais j'ais une sortie qui repondais pas comme toi , et c'etait impossible de la flasher

mais quand j'ai vus que le moteur se metait a tourner j'ai réussis à flasher mon ESC qui marchais pas et depuis tout roule !

  • Confus 1

Share this post


Link to post
Share on other sites

Salut Salut,

J'ai réussi à flasher mon ESC 4 en intervertissant les sorties 3 et 4 entre ma FC et mon ESC !!!!
Cette fois sans passer par les connecteur FST ou FCC de ma FC mais en soudant directement sur les pin de sorties moteur (S1, S2, S3, S4).

En remettant tout dans l'ordre, ma sortie ESC4 reste injoignable...

Chose bizzare c'est que lorsque j'avais mes sortie 3 et 4 d'inversé BLheli ne trouvait toujours rien sur la sortie ESC4 (En réalité mon ESC3), 

Je sais pas si je me suis fait comprendre.

Des Idées?

 

IMG_20181209_120752.jpg

  • J'aime 1

Share this post


Link to post
Share on other sites

donc si tu soudes ça marche ?

un faux contact dans ton connecteur ?

pour info mon ESC a refuser de fonctionner pour le maiden de mon XBEE ...

j'ai que 3 moteur sur 4 qui tourne !

Share this post


Link to post
Share on other sites
Le 09/12/2018 at 12:26, DingoFPV a dit :

Salut Salut,

J'ai réussi à flasher mon ESC 4 en intervertissant les sorties 3 et 4 entre ma FC et mon ESC !!!!
Cette fois sans passer par les connecteur FST ou FCC de ma FC mais en soudant directement sur les pin de sorties moteur (S1, S2, S3, S4).

En remettant tout dans l'ordre, ma sortie ESC4 reste injoignable...

Chose bizzare c'est que lorsque j'avais mes sortie 3 et 4 d'inversé BLheli ne trouvait toujours rien sur la sortie ESC4 (En réalité mon ESC3), 

Je sais pas si je me suis fait comprendre.

Des Idées?

 

IMG_20181209_120752.jpg

Faut retourner aux fondamentaux lol.

Teste la continuité des cables signaux entre FC et ESC (sur certaine FC tu as des pads signaux supplémentaires à souder en plus de ceux de la nappes avec le connecteur)

Teste la continuité du plus et moins.

Mais ça sent le sapin ton histoire... Pour ça que j'aime pas les 4 en 1. 4 fois plus de chances de casse.

Share this post


Link to post
Share on other sites

Salut les gars, c'est bon problème solutionné!!!

En regardant le plus prêt le mappage des sorties de ma FC, je me suis rendu compte que la sortie MOTOR 4 n'était pas correctement mappé.

En creusant un peu plus,je me suis rendu compte que je n'avais en faite pas flasher ma FC avec le bon firmware, "OMNIBUSF4" au lieu de "OMNIBUSF4FW"!!!!

Un grand merci pour votre Aide

  • J'aime 1

Share this post


Link to post
Share on other sites
il y a 31 minutes, DingoFPV a dit :

Salut les gars, c'est bon problème solutionné!!!

En regardant le plus prêt le mappage des sorties de ma FC, je me suis rendu compte que la sortie MOTOR 4 n'était pas correctement mappé.

En creusant un peu plus,je me suis rendu compte que je n'avais en faite pas flasher ma FC avec le bon firmware, "OMNIBUSF4" au lieu de "OMNIBUSF4FW"!!!!

Un grand merci pour votre Aide

bravo ! ça c'est utile comme petit CR ça peut arriver à d'autre :)))

  • Merci ! 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...