Aller au contenu
DroneBuilds

Erreur "syntax" avec le Lua betaflight sur x9d


phoeniixFPV
 Share

Messages recommandés

Bonjour à tous.

En général je dépatouille toujours tout seul mais là...🤔

J'ai mis à jour ma 9XD+ avec la version 2.2.4.

J'ai téléchargé le Lua de betaflight pour le parametrage des PID en version 1.3

Je me retrouve avec tout un tas de fichiers que j'ai essayer d'exploiter mais en vain. J'ai tout glissé posé sur ma carde SD, error! Puis j'ai essayé de mettre le contenu de chaque fichier dans les fichiers existant carteSD d'openTX, error!

Dès j'essaye d'activer le script BF, j'ai un message d'erreur: Error syntax script

Même le luac fait le même message.

 

J'ai raté quelque chose?

 

Merci à tous ceux qui pourront m'aider, mon 85 pro2 n'attend plus que vous !😉

Lien vers le commentaire
Partager sur d’autres sites

  • 6 months later...

Idée ?  Avez vous un FW open TX à jour sur vos RC par rapport à la version script LUA ?

Pour info/comparaison, ma X9D plus  est en Open TX 2.2.3 avec scrip LUA 1.0. tout fonctionne. Et justement je n'ose pas mettre à jour pour éviter cette prise de tête. (FRSky user)

Lien vers le commentaire
Partager sur d’autres sites

Sur ma Horus 10S Express, X9D+ et X9D+2019 OpenTX 2.3.7 et lua-betaflight 1.4.1 aucun problème !

Il faut recopier tout ce qui est(après, unzip) dans obj, sur la carte SD et lancer BF.lua du répertoire BF.

betaflight-tx-lua-scripts_1.4.1.zip

Modifié (le) par Attafr
Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV
Le 14/4/2020 at 16:39, Attafr a dit :

Sur ma Horus 10S Express, X9D+ et X9D+2019 OpenTX 2.3.7 et lua-betaflight 1.4.1 aucun problème !

Il faut recopier tout ce qui est(après, unzip) dans obj, sur la carte SD et lancer BF.lua du répertoire BF.

betaflight-tx-lua-scripts_1.4.1.zip 182 Ko · 0 downloads

Salut, la mise à jour de ta X9D+ (avant 2019) tu n'as pas eu de problème?, tu as ta radio en Français? comment tu as fais, je suis un peu newbee sur opentx, est ce que tes modèles ont été correctement sauvegardés?, 

Encore une petite question, je vais recevoir la X9D+2019, je peux copier mes modèles de ma X9D+ d'avant 2019, tout fonctionne bien?

Merci pour ton aide

Lien vers le commentaire
Partager sur d’autres sites

  • 1 year later...

Pour ceux qui ont un message d'erreur "Syntaxt error ... device.lua:422" le problème vient simplement d'un problème d'encodage du fichier.

J'ai été ouvrir le fichier et j'ai trouvé çà à la ligne 422

 
      local field = geT�i���1A�����:���  "  fieleTImuOut 9 getTyme() + 200`<� 2s
 

A un moment donnée, le fichier à été mal réencodé (peut être lors de la mise à jour, ou au passage EN/FR).

J'ai donc retéléchargé les fichiers depuis le site d'openTX Index of /2.3/release/sdcard/opentx-x9d+/ (open-tx.org)

Remis ces fichiers sur la carte SD et maintenant ça passe.

En espérant en aider certains.

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
 Share

×
×
  • Créer...