Jump to content
DroneBuilds
Ketsh2

HELP R-XSR Tyro69

Recommended Posts

Bonjour, 

je recommence mon post ce n’était pas clair. 
 

Je n’arrive pas à récupérer le RSSI de la FC sur ma taranis QX7.

Je n’ai que les infos du rx. J’ai l’impression que le rx et la FC ne communique pas alors que tous les branchements sont bons (vérifier avec multimètre) 

J’ai bien fait le pont pour le SBUS. Ma radio et mon rx (acheté sur studiosport) sont bien en LBT. 
 

Je sèche complètement. Dois-je flasher mon rx? 
 

Merci d’avance 

 

 

 

6F553C0E-CD20-46CA-8905-A183A513F678.jpeg

FA963C79-6B14-4D6B-A4B6-A885A38B2E37.jpeg

Share this post


Link to post
Share on other sites

Il te faut hacker ton rxsr en connectant le port uninverted smartport sur un pad TX de ta FC et l'assigner à la télémétrie dans l'onglet port de betaflight

https://forum.wearefpv.fr/uploads/monthly_2017_10/frsky_r-xsr_rx_receiver_smartport_sbus_inverted_uninverted_pin.jpg.6b5c839e275fdfe253f37d9a94a2e2ea.jpg

Edited by Joelamoule

Share this post


Link to post
Share on other sites

Bon après avoir suivi ton conseil en soudant un fil que le port uninverted smartport du rx vers un pad tx libre de ma FC. 
Ma soudure n’a malheureusement pas tenu et j’ai abîmé le pad du rx... 

‘Je suis parti pour un achat d’un nouvel r-xsr..

J’allais entamer la phase de flash du rx pour le Fport (si j’ai bien suivi la manip 🤔) et activer le serial rx sur l’uart 1 sur betaflight ainsi que la telemetry.
‘En cas d’échec je comptais suivre les conseils d’oscar liang en passant par le CLI (halfduplex OFF et inverted ON) 

Suis-je sur la bonne voie ou je mélange tout? 
 


 

BF0C776A-CC23-4517-8125-0E45C15A7C78.jpeg

Share this post


Link to post
Share on other sites

Aie désolé pour ça ! 

J'ai pas mentionné le fait d'y aller mollo avec le fer sur ce pad mais il est tellement petit que c'est vrai que c'est pas simple.

Je te conseille en effet de passer en protocole fport https://www.wearefpv.fr/tuto-frsky-fport-betaflight-20180706/ très bon tuto ici pour flasher ton r xsr https://www.wearefpv.fr/tutoriel-taranis-flasher-x4r-xsr-lbt-20170221/ attention il faudra utiliser le connecteur ici et bien vérifier câblage de l'alimentation et de la masse pour pas le griller. 

Et aussi comme tu dis, bien taper les cmd du cli suivant ta fc. Oscar Liang est une bible pour moi tu peut aussi t'en servir ! 

 

Bon courage 

Edited by Joelamoule
  • +1 1

Share this post


Link to post
Share on other sites
Youtube WE are FPV

Ah merde, ca m'est arrivé une fois aussi, il est fragile ce petit pad, faut pas rester trop longtemps dessus ni le gratter avec le fer 😅

Le 18/01/2020 at 13:22, Ketsh2 a dit :

Je n’arrive pas à récupérer le RSSI de la FC sur ma taranis QX7.

Pourtant tu as bien le RSSI sur la ta radio. J'imagine que tu veux dire l'inverse : comment faire en sorte que la FC récupère le RSSI pour l'afficher dans l'OSD ? Si c'est le cas, c'est normal que tu ne l'aies pas : il faut le remonter de la radio à la FC via une voie (au même titre qu'un switch). Si le RSSI te suffit, tu n'as pas besoin de racheter un R-XSR.

Sinon, comme l'a indiqué @Joelamoule, le plus clean, c'est de passer le R-XSR en F.Port pour avoir le signal + la télémétrie + le RSSI comme par magie par un seul fil 😉 

Il y a 3 heures, Ketsh2 a dit :

J’allais entamer la phase de flash du rx pour le Fport (si j’ai bien suivi la manip 🤔) et activer le serial rx sur l’uart 1 sur betaflight ainsi que la telemetry.

Non, il faut juste activer le serial RX. Dans l'onglet Config il faut choisir F.Port, normalement tu auras direct la télémétrie et le RSSI (à condition d'avoir activé la fonctionnalité "telemetry").

Share this post


Link to post
Share on other sites

Merci beaucoup pour tout ces précieux conseils 😁

Je m’y colle dès ce week end et je ferais un retour sur le résultat. 

La télémétrie est déjà activée ainsi que le serial rx sur l’UART1 donc je souderais sur le pad TX1 de ma fc. 

J’ai flasher mon rx (firmware Fport) avec ma taranis en faisant gaffe à la polarité et tout s’est bien passé. 
 

Il y a 20 heures, Jerome a dit :

Pourtant tu as bien le RSSI sur la ta radio. J'imagine que tu veux dire l'inverse : comment faire en sorte que la FC récupère le RSSI pour l'afficher dans l'OSD ? Si c'est le cas, c'est normal que tu ne l'aies pas : il faut le remonter de la radio à la FC via une voie (au même titre qu'un switch). Si le RSSI te suffit, tu n'as pas besoin de racheter un R-XSR

Oui je voulais dire l’inverse. Si je comprend bien je dédie un AUX de ma taranis au RSSI puis je l’assigne sur betaflight?

Share this post


Link to post
Share on other sites
il y a 38 minutes, Ketsh2 a dit :

Oui je voulais dire l’inverse. Si je comprend bien je dédie un AUX de ma taranis au RSSI puis je l’assigne sur betaflight?

C'est exactement ça, tu as des tutos pour la config de la radio pour remonter la bonne valeur. Dans BF, ensuite ça se déclare dans l'onglet "Récepteur" :

image.png.60b30e2d783a4d9128abfcf9ef73aaf1.png

  • J'aime 1

Share this post


Link to post
Share on other sites

Salut à tous, 

J’ai réussi à câblé sans trop de problème et sans rien cramé cette fois mais maintenant impossible de binder...

Le RXSR est en bien SBUS, et je l’ai bien flashé avec pour le Fport version LBT avec le soft sur le site de FrSky. 

En suivant la procédure classique (appuie sur la touche et branchement LiPo) que ce soit en D16 1-8 ou D16 -9-16, rien... la led rouge clignote toujours... 

J’ai envoyées les commandes inverted OFF et halduplex ON.

Ma fc est flashe en betaflight 4.1.3

J’ai bien dédié un AUX sur la taranis et assigné sur betaflight 

J’ai bien sélectionné Fport sur betaflight... 

C’est à se tirer les cheveux (que j’ai plus 😂

D860E1F4-8208-4A83-BE2A-27D87E1CD849.jpeg

D18EB244-D6CF-4BBE-8AAB-5CC7A20BCC98.jpeg

Share this post


Link to post
Share on other sites

Le bind n'a rien à voir avec la FC et la configuration de BF. Tu peux même bind sans être connecté à la FC, faut juste que le RX soit alimenté.

Le souci est vraiment entre ta radio et le RX je pense. Tu as bien flashé avec le firmware ACCST et non avec l'ACCESS ? (ou réciproquement si tu as une Q X7 en ACCESS).

Share this post


Link to post
Share on other sites

Bonjour, 

Je reviens après quelques temps d'absence... J'ai pu me remettre sur la bidouille de mon petit quad. 

Toujours impossible de binder mon r-xsr flashé en Fport.... J'ai

- Dédier le RSSI à un AUX sur ma Taranis (en selectionnant RSSI comme source) puis je l'ai assigné sur BF, 

- Souder un fil sur l'uninverted smartport et sur le pad TX1 de ma FC, 

- Activer la télémetrie sur BF

Toujours rien.... Que ce soit en ACCESS ou ACCST... Je perd espoir et me dis que j'aurais dû acheter un quad BNF 😞 

Share this post


Link to post
Share on other sites

kevin dillon win GIF

Bord...... de m.... j'ai reussi!! je vous raconte pas ma joie!!! 

Je n'avais pas utilisé la bonne version de firmware... 

J'ai utilisé la version ACCST v191112 trouvée sur le site de frsky (https://www.frsky-rc.com/wp-content/uploads/Downloads/Firmware/R-XSR/FW-RXSR-ACCST_v191128.zip)

Merci beaucoup pour votre aide Jerôme et Joe. 

 

   
  • J'aime 1

Share this post


Link to post
Share on other sites

Champagne ! 😉 Il y a toujours une bonne explication 😛 

Share this post


Link to post
Share on other sites

Je me demande comment ils n'ont pas sorti une version avec un pad uninverted comme le r9mm... bizarre

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...