Aller au contenu
DroneBuilds

Télémétrie sur Mamba F411 AIO ???


Lioneldg

Messages recommandés

Salut,

J'ai tenté d'obtenir la télémétrie sur mon GTB-229.

Il s'agit dune FC Mamba F411 Nano AIO.

Je suppose que le paramétrage de la version AIO est identique à la version stack.

Voici un extrait de cet article de Oscar Liang qui parle de récupérer la télémétrie sur la FC Mamba F411 Nano:

Receiver Setup

Frsky

There are only 2 UART ports, which is limited. But this is kind of normal on 16x16mm stacks. It just means if you are using SBUS and SmartAudio to control your VTX, you won’t have SmartPort Telemetry. The best solution is probably to use FPort so you can get both SBUS and Telemetry through the same wire 🙂

Alternatively you can also remap the PPM pad to a Softserial Port, and connect SmartPort to it. Here is a tutorial to give you an example how it works.

Simply go to Betaflight CLI and enter:

resource PPM 1 NONE
resource ESCSERIAL 1 NONE
resource SERIAL_TX 11 B09
resource SERIAL_RX 11 B09
save

Setting ESCSERIAL 1 to NONE because it also occupies the pin B09. Setting it to none shouldn’t be an issue.

 

1) J'ai tenté de récupérer la télémétrie en FPort mais c'est impossible car apparemment la FC n'accepte pas le serialrx_halfduplex =ON.

J'ai vu sur la notice que le FPort n'est pas mentionné dans la liste des protocoles acceptés.

J'ai réussi à le faire fonctionner en inversant le signal mais sans halfduplex ça revient à avoir du SBus.

2) J'ai alors tenté de remaper un port inutilisé grâce au softsérial mais le soft sérial ne fonctionne qu'avec "set tlm_halfduplex = ON" donc, de même que le "serialrx_halfduplex" je suppose que la carte ne l'accepte pas 😐

De toute façon ça n'a pas marché.

3) J'ai tenté de connecter le rx en SBus et le pad smartport de la FC au pad smartport de mon récepteur.

J'ai activé le smartaudio de l'UART1 qui est le RX dans l'onglet port et il refuse de conserver le réglage. 

 

Bref, j'ai plus trop d'idée pour récupérer la télémétrie.

Je voudrai bien votre aide.

Lien vers le commentaire
Partager sur d’autres sites

J'ai la version stack Et pas de problème de télémétrie via un r xsr en fport avec bien sûr le câble du hack du r xsr soude sur le RX cf mon drone build du tadpole....

Lien vers le commentaire
Partager sur d’autres sites

J'ai compré les notices du aio et du stack. 

Le aio note la liste des protocoles rx (le fport n'en fait pas partie). Il ne parle pas du smartaudio

Le stack : ne note pas la liste des protocoles rx, ça laisse supposer q'ils sont tous acceptés. Il note aussi smartaudio =oui

@Joelamoule

1) C'est quoi le cable du hack? 

2) Sur quel pad est tu connecté ? SBUS ? 

3) Que donne get serialrx dans le CLI ? 

4) Que donne get tlm dans le CLI ? 

5) Dans l'onglet port, dans la colone télémétrie, qu'as tu sélectionné ? 

Merci de ton aide

Lien vers le commentaire
Partager sur d’autres sites

Pour hacker ton r xsr, juste un câble a soude sur le petit pad du uninverted smartport, attention pas très petit et si tu chauffe trop, il va s'arracher alors vas y mollo, ça se fait bien

frsky_r-xsr_rx_receiver_smartport_sbus_inverted_uninverted_pin.jpg

Je suis connecté en protocole fport, celui est forcément valide sur cette carte même en Aio, il te faut flasher ton RX au préalable. J'ai le tx2 pour le Smart audio et le serial RX en uart 1.

 

Tuto Fport de motard geek

https://www.google.com/amp/s/www.wearefpv.fr/tuto-frsky-fport-betaflight-20180706/amp/ tu aura toutes les commande a taper

Lien vers le commentaire
Partager sur d’autres sites

J'ai regardé le tuto. 

J'utilise le R9MM donc je n'ai pas besoin du hack car j'ei les ports inversés et non inversés d'origine. 

J'ai essayé tout les branchements possibles et je n'arrive toujours pas à avoir un retour de télémétrie 😔

Au moment ou motard geek a fait le tuto, il precise les recepteurs compatibles et le R9MM n'en fait pas partie. 

Peut être que c'est ça le problème. 

Lien vers le commentaire
Partager sur d’autres sites

J'ai contacté DFR,  ils ont étudié le problème. 

Ils m'ont proposé une configuration qui n'a malheureusement pas fonctionnée. 

J'ai contacté Diatone par mail. 

Ils m'ont repondu en m'expliquant précisément les branchements à effectuer. 

Ils m'ont transmit une version de Betaflight à flasher et un diff à injecter. 

Le résultat est le même, toujours pas de télémétrie. 

J'ai fait un retour à Diatone et j'attends de voir si ils ont une autre solution. 

Je les félicites vraiment pour leur professionnalisme et leur disponibilité 👍

Je recheterai leurs produits sans hésiter. 

Lien vers le commentaire
Partager sur d’autres sites

  • 3 weeks later...

Je viens clôturer mon post. 

J'ai finalement réussi à récupérer la télémétrie sur ma f411 aio. 

Le problème était que le récepteur R9MM n'est pas compatible avec la télémétrie sur cette FC. 

Mais vraisemblablement Diatone n'est pas au courant et ils m'ont même indiqué commnt me brancher 😕

J'avais vu dans une ancienne vidéo de motardgeek que le R9MM n'était pas compatible et que ça serait certainement corrigé par la suite. (ce que je pensais être fait ) 

J'ai installé un récepteur R XSR et tout fonctionne parfaitement 😄

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

  • 1 year later...
Le 19/02/2020 at 18:20, Lioneldg a dit :

Je viens clôturer mon post. 

J'ai finalement réussi à récupérer la télémétrie sur ma f411 aio. 

Le problème était que le récepteur R9MM n'est pas compatible avec la télémétrie sur cette FC. 

Mais vraisemblablement Diatone n'est pas au courant et ils m'ont même indiqué commnt me brancher 😕

J'avais vu dans une ancienne vidéo de motardgeek que le R9MM n'était pas compatible et que ça serait certainement corrigé par la suite. (ce que je pensais être fait ) 

J'ai installé un récepteur R XSR et tout fonctionne parfaitement 😄

Bonjour désolé de déterrer ton post mais je n arrive pas avec le r xsr et la carte mamba f411 peux tu me dire comment tu as fait exactement 

merci d avance 

Lien vers le commentaire
Partager sur d’autres sites

Il y a 1 heure, Dim44 a dit :

Bonjour désolé de déterrer ton post mais je n arrive pas avec le r xsr et la carte mamba f411 peux tu me dire comment tu as fait exactement 

merci d avance 

merci de faire une photo de ton cablage stp

Lien vers le commentaire
Partager sur d’autres sites

Je l ai soudé comme dit plus haut et j ai modifié dans betaflight comme dans ce tuto https://www.google.com/amp/s/www.wearefpv.fr/tuto-frsky-fport-betaflight-20180706/amp/

et quand je flash le récepteur en Fport et que je modifie dans betaflight le drone bip tout le temps et les voies ne répondent pas le voyant du récepteur est bien vert .

 

A6D8F8BD-1FB8-4FA7-8DFE-4094C7D9B9C8.jpeg

Lien vers le commentaire
Partager sur d’autres sites

il y a 2 minutes, Dim44 a dit :

Oui vert et bleu si je le flash sans fport le drone fonctionne très bien sauf que je n ai pas les capteurs de tension de la batterie dans la radio 

Tu fais bien une recherche des capteurs (dernière page MDL)
 

Tu as changé ça!

Si SmartPort non inversé (hacked)

set serialrx_halfduplex = ON
set serialrx_inverted = OFF

Comme d’habitude en CLI, il ne faut pas oublier de sauvegarder la configuration :

save


  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

Oui j ai même essayé avec off et on inversé tj pareil et j ai fait à chaque fois une recherche des capteurs dans la radio 

Ça fonctionne très bien sur mon autre drone tyro 109 

maintenant je pense que déjà si je n arrive pas à binder correctement le récepteur en fport je ne risque pas d avoir les capteurs ? 

Modifié (le) par Dim44
Lien vers le commentaire
Partager sur d’autres sites

il y a 10 minutes, Dim44 a dit :

je n arrive pas à binder correctement le récepteur en fport

Le bind n’a rien à voir avec ton problème...

Si tu n’´arrives pas à binder, c’est un problème de version (v1.x/v2.x) ou LBT/FCC

Lien vers le commentaire
Partager sur d’autres sites

J'ai l'impression que ton fil blanc du sport est soudé sur la FC au pad TX uninverted je me trompé mais faut le faire sur l'autre du coup ça doit être pour cela que ça ne fonctionne pas

Lien vers le commentaire
Partager sur d’autres sites

il y a 24 minutes, Joelamoule a dit :

J'ai l'impression que ton fil blanc du sport est soudé sur la FC au pad TX uninverted je me trompé mais faut le faire sur l'autre du coup ça doit être pour cela que ça ne fonctionne pas

Oui il est bien soudé sur le uninverted tx1 je vais le souder sur l autre à côté et de l autre côté je le raccorde bien sur le fil que j ai soudé sur le récepteur ?

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...