Aller au contenu
DroneBuilds

Probleme oscillations 1er vol !


Matthias

Messages recommandés

Bonjour, je viens de nouveau solliciter votre aide par rapport a mon drone. Voila apres toutes les galères que j'ai eu ( Jérome et Motar geek pourront le confirmer.. 😄 ) j'ai enfin réussi à faire voler mon drone !

Du coup nouveau probleme mon drone oscille vachement en vol ( J'ai failli vomir au bout de 10 min x) ) et apres avoir regarder pas mal de vidéos à ce sujet je pense que c'est un probleme de PID ou de filtres. J'ai regardé la vidéo de culture fps sur les 8 points à vérifier quand on a un drone qui vibre mais j'ai l'impression que tout est bon dans tout ce qu'il décrit à vérifier. Quand j'ai flashé ma FC, BF m'a proposé d'installer automatiquement des paramètres prédéfinis qui sont sensé aller bien avec ma FC, et c'est ce que j'ai fait. Du coup tout est stock à part ca, je n'ai encore touché à rien ! Je me dit alors que peut etre mon P serait trop élevé ou que peut etre cela viendrai du fait du noise du gyro et qu'il n'y aurait pas assez de filter ce qui ferait que les pid essayeraient de corriger ca d'ou les oscillations constantes. Du coup je ne sais pas s'il faut que je touche les PID ou les Filter ou bien autre chose.. 🤔

Autre chose , en air mode et en accro c'est ca qui se passe (oscillations) vous pouvez voir ca dans cette vidéo :  https://youtu.be/bglyr6oq70o mais bizarrement à la fin de la vidéo quand je suis passé en mode angle pour tester, le quad s'est directement retourné et a du coup chuté.. La FC est dans le bon sens, le schéma tourne comme le quad qui est dans ma main, les moteurs sont dans le bon sens, l'esc a été calibré et flashé avec le bon firmware du coup je bloque un peu.. C'est vrai que quand je test les moteur ssur BF, en mode angle quand j'augmente le throttle les moteurs 3 et 4 tournent plus vite, ce qui expliquerait pourquoi il s'est retourné, mais pourquoi... 🤔

Merci d'avance !

config.jpg

PID.jpg

filtre.jpg

Lien vers le commentaire
Partager sur d’autres sites

Je pense que oui, dans l'onglet "installation" de BF le model 3D tourne comme le quad quand je le tourne avec ma main. A la base, le Gyro 1 etait sur 0 et le deuxieme sur CW 90 mais ca n'allait pas (décalage de 90° par rapport au model 3D) j'avais du coup fait tourner la FC en yaw de -90°, le model 3D collait mais en vol ca n'allait pas. Puis j'ai trouvé un mec qui avait posé un avis sur banggood à propos du iflight DC3 (c'est le drone que j'ai)  

"Great value, comes with latest, high-value electronics, good motors and betaflight 4.1.0 out of the box. Flies like a champ. Just make sure you need to set up the gyros like preconfigured when updating to betaflight 4.1.1 (CLI: set gyro_1_sensor_align = CW270, set gyro_2_sensor_align = DEFAULT)"
 
Du coup j'ai testé, le quad suivait bien le model 3D et en l'air ca fonctionne bien en mode acro et en airmode mais quand je suis passé en mode angle pour tester le quad s'est retourné.. 
Lien vers le commentaire
Partager sur d’autres sites

Apparemment les dc3 ont des problèmes avec leur FC, 

« These quads have massive quality issues and I can not recommend it.  For such an expensive quad I would have expected a high quality product.  They have issues with the FC  Board (which they know about) however it will be up to you to determine the issue, request a new one and fix the quad yourself.  They have an updated board to fix the issue but do you really want to buy a quad you will have to repair? »

« super machine , juste la FC qui a un problème ,il faut désactiver un des 2 gyro pour enlever les accoups sur le yaw .
un fois ça fait c'est un bombasse 
je vole en 4 650 mah ,mais je me demande si des 850mah ne serai pas mieux 
vol de 4min en mode freestyle 2min30 en mode race 5m30 en mode de filet de gaz 
par contre les moteurs pompe dur 
faut pas avoir le main trop lourde sur les gaz sinon la Lipo s'effondre direct 
les full gaz c'est 1/2 seconde max même en début de Lipo »

Et d’après ta vidéo ta FC est concernée,  on dirait des accoups sur le yaw comme le dit un heureux propriétaire,

maintenant à toi de tuner ton quad, c’est un 3 pouces, cela ne se paramètre pas comme un 5 pouces 😉

De mémoire  Betaflight stock est tuné pour un cinq pouces, 

Lien vers le commentaire
Partager sur d’autres sites

Aaaah ca me rassure alors ! J’etais quasi sur que ca venait d’un probleme de gyro car j’ai vu sur des videos que les PID peuvent creer des vibrations si on les poussent trop mais des vibrations continues et a la meme frequence, pas du tout ce que j’ai, qui sont plus aleatoires. 
 

Du coup pour désactiver un des gyros il suffit de la mettre sur CW 0 ? Default ? Ou alors on le désactive dans un autre endroit de BF ? 🤔 

Ce sont des commentaires que tu as trouvé sur banggood ?

Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV

Oui sur Banggood,

les gyro se désactivent dans l’onglet sens de la carte et du capteur, désactive entièrement ton deuxième gyro en utilisant les menus déroulants, ensuite faut faire des essais, en mode angle 👍

Lien vers le commentaire
Partager sur d’autres sites

Tes P sont assez bas et tu as pas mal de filtrage, je ne suis pas certain que ça vienne de là.

Tu as le RPM filter activé, normalement il est recommandé de se mettre en DShot300. J'ai déjà eu des soucis avec le RPM filter en DShot 600.

Les accoups sur le Yaw sont assez caractéristiques d'un problème de configuration des ESCs : dans BLHeli_32, passe le PWM frequency à 48kHz et le Motor Timing en Auto sur chaque ESCs.

Ca c'est pour le vol crado en acro 😉 

Pour le prbl du mode stabilisé, tu peux essayer de recalibrer ton accéléromètre avec ton quad bien à plat (le modèle 3D bouge grâce au gyro, qui lui est calibré automatiquement au branchement de ta lipo).

Lien vers le commentaire
Partager sur d’autres sites

Rololooooo !!!! J'ai mis tout ce que tu m'as dit Dshot 300, le PWM et le Motor timing en auto et c'etait juste parfait ! Dommage que j'avais pas mis de micro SD pour te montrer mais c'etait lisse c'etait fluide c'etait juste... beau 😍 Et le mode stab est exactement comme il doit etre 👌 Merci beaucoup Jérome je suis tellement mais tellement heureux de pouvoir enfin voler sans galeres ! 

Lien vers le commentaire
Partager sur d’autres sites

il y a 3 minutes, Matthias a dit :

Rololooooo !!!! J'ai mis tout ce que tu m'as dit Dshot 300, le PWM et le Motor timing en auto et c'etait juste parfait ! Dommage que j'avais pas mis de micro SD pour te montrer mais c'etait lisse c'etait fluide c'etait juste... beau 😍 Et le mode stab est exactement comme il doit etre 👌 Merci beaucoup Jérome je suis tellement mais tellement heureux de pouvoir enfin voler sans galeres ! 

Ca fait plaisir à lire ! Profite bien 🙂 

  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...