Aller au contenu
DroneBuilds

R-XSR OK (S-Bus ou F-Port) pas de voies....


Messages recommandés

Bonjour à tous,

 

j'ai commandé ma FC (56€ chez DFR), tout allait bien jusqu'à, que l'antenne d'origine passe dans une hélice, résultat: bout de l'antenne éfiloché et portée reduite à 30 m max.

 

Donc, j'ai acheté un R-XSR, j'ai fait du montage suivant:

En S-Bus:

- inv Sport RX --> TX1  FC

- S-Bus RX     --> S-Bus FC

- 5V RX         --> 5V     FC

- GND RX      --> GND  FC

-> Betaflight: Rx configuré en S-Bus dans "Configuration" et et UART TX1 sur RX dans "Port"

 

En F-Port:

- inv Sport RX --> TX1  FC

- 5V RX         --> 5V     FC

- GND RX      --> GND  FC

-> Betaflight: Rx configuré en F-Port dans "Configuration" et et UART TX1 sur RX dans "Port"

 

Et dans Bétaflight rajouter dans CLI :

 

set serialrx_halfduplex = ON

set serialrx_inverted = OFF

save

 

Dans les deux cas, j'ai la télémétrie (RSSI, BxTx), mais quand je vais dans "Récepteur", je n"ais aucun mouvement de ma radio (toutes les channels sont fixes).

 

Est-ce que quelqu'un c'est d'où cela ça vient ?

 

Merci d'avance

 

Bonne journée et bon vols à tous

 

Lionel

Lien à poster
Partager sur d’autres sites

Oups, SORRY !!!

C'est un EMAX Tinyhawk 2 (Firmware MATEKF411RX).

J'avais déjà un autre R-XSR de branché en F-Port, mais en voulant fixé le R-XSR sur le TH2, j'ai du arraché la platine du s-Port inversé, où j'avais soudé le fil, du coup R-XSR HS, suite à une mauvaise soudure, j'avais déjà arraché celui du S-Bus aussi (j'avais viré la prise molex...).

Je dois commandé un R-XSR pour un avion, a voir....

 

Oui, la LED bleu est allumée (je suis bien en S-Bus) ainsi que la LED verte (connectée à la radio)

Merci pour l'info de la soudure sur le R-XSR, mais mon niveau et mon materiel ne me permette pas de fair de soudure aussi microscopique...

Il me reste ce TX2, mais c'est celui où ect connecté le SmartAudio

PS: ci-joint, le dernier Dump ALL de mon TH2

BTFL_cli_TinyHawk_II_20200718_161151.txt

Modifié (le) par yoyodec
Lien à poster
Partager sur d’autres sites

Par contre, je ne sais plus ce que je dois souder sur le TX1 du Tinyhawk 2 pour si je soude le S-Bus du R-XSR:
- le S-Pport du de la prise molex R-XSR
ou
- le S-Port inversé de la platine du R-XSR

Ainsi qu'au niveau "PORTs" dans bétaflight:
- En F-Port -> "Serial RX" coché pour "UART1"
- En S-Bus ->  "Serial RX" coché ou "SmartPort" sur "Sortie télémétrie" pour "UART1"

Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

J'ai un plot (à souder) S-Bus sur la FC de mon TH2, je peut prendre celui-là, non ?

mini_200720115836258138.jpg

 

Si oui, je dois souder le fil vert (S-Bus out) du R-XSR ou le plot (B) du R-XSR....

Lien à poster
Partager sur d’autres sites

OK, mon cerveau à enfin compris....

mais l'autre et unique TX que j'ai, c'est le TX2, qui est pris par le SmartAudio.

Je vais juste souder le fil vert sur le plot S-Bus du TH2, je verrai après pour le S-Port....

Modifié (le) par yoyodec
Lien à poster
Partager sur d’autres sites

Bon, en fin de compte, je pense que c'est du à mes soudure, car je suis obliger de rester au moins 5 à 10 secondes pour que l'étain que j'ai fonde.

L'étain que j'utilise est 100% d'étain pour l’électronique, théoriquement.

J'ai commandé du 63% d'étain et 37% de plomb de chez TBS....

A savoir que, quand je mets le TH2 avec son récepteur d'origine intégré (SPI RX en ACCST v1.0 FCC), tout fonctionne normalement au niveau récepteur dans bétaflight.....

Lien à poster
Partager sur d’autres sites

J'ai soudé comme cela:

- S-Bus RX --> S-Bus FC

- 5V RX      -->; 5V     FC

- GND RX   --> GND  FC

- S-Port RX --> TX2  FC

Dans Bétaflight:

- TX1 -> Serial RX

- TX2 -> S-port

Ensuite:

- 1° Branchement au PC: -> OK

- 2° Branchement de la LIPO: -> petite fumée avec une odeur de cramée

-3° je débranche tout, je rebranche que la LIPO, les LEDs du TH2 s"allume, mais pas celles du R-XSR.

-4°  Je branche le R-XSR sur une LIPO 2S, le R-XSR binde avec la radio

-5° Je branche un autre R-XSR, idem que le 1°

Donc, sortie S-BUS du TH2 HS

Finalement, j'ai opté pour la méthode simple, c'est à dire , j'ai passé le TH2 en D8, ainsi, plis besoin du module supplémentaire.

Modifié (le) par yoyodec
Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / WE are FPV

×
×
  • Créer...