Aller au contenu
acheter lipo ovonic pas chère
DroneBuilds

Question Noob GPS


Phenix2984
Aller à la solution Résolu par Gui51,

Messages recommandés

Hello,

Je pense équiper mon Nazgul d'un GPS, le Walksnail WS-M181 me parait pas mal (il a une boussole et une batterie intégrée)

Est-ce que quelqu'un l'a testé?

Techniquement j'ai l'impression qu'il est mieux que le BN220

L'idée est d'avoir le retour du GPS dans WTF OS et si possible dans la Taranis.

Si j'ai bien compris avec le dernier BF, on peut ajouter un "presque" RTH? Si ça fonctionne correctement c'est génial.

Le souci c'est la place pour l'installation, je pensais le mettre à l'emplacement de la Go-Pro (je n'en ai pas pour l'instant), c'est ce qui me parait le mieux, les fils seront un peut long mais à l'arrière a coté du vista, de l'antenne et du XT60, ça me parait vraiment pas top.

Lien vers le commentaire
Partager sur d’autres sites

Je passe mon tour sur les modèles, trop peu d'expérience.

Pour la fixation l'idéal je pense serait un support en TPU un peu éloigné à l'arrière du kwad comme on en voit souvent 🙂 

Lien vers le commentaire
Partager sur d’autres sites

Bonjour, oui en effet, avec un gps tu pourras utiliser le RTH qui vient même poser le quad assez précisément.

Je te conseille de faire plusieurs tests de config RTH pour bien le comprendre et donc qu'il soit optimal.

Pour le retour gps dans l'osd et la radio aucun problème non plus (je te conseille même d'enregistrer les logs gps sur la carte sd de ta radio en cas de besoin)

Concernant ta référence, je ne connais pas mais en tout cas, le bn 220 est en puce m8 et les be 220 sont en puce M10 donc bien plus rapide en accroche gps

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

  • 2 weeks later...

Bon, après 1/2 journée de perdue, j'aurais besoin de vos lumière.

J'ai installé le GPS en suivant le schéma de la FC: sur l'UART4. Impossible de le faire reconnaitre avec ou sans lipo, en inversant RX/TX ou pas, rien a faire.

Gros pétage de câble hier, j'ai repris toutes les soudures, vérifié les continuités, sans succès.

Aujourd'hui je reprend tout depuis le départ.

A priori sur le Nazgul que j'ai acheté, d'origine le Caddx Vista est branché avec une prise sous la FC sur l'UART4 (normalement prévu pour le GPS).

J'ai donc installé le GPS sur l'UART5, et là bingo, il est reconnu (uniquement si la lipo est branchée mais je pense que c'est normal).

Ma question c'est: le schéma de la FC indique le GPS sur l'UART4, mais ce n'est qu'une recommandation, si je le met sur l'UART5, cela ne pose pas de problème?

 

Je me retrouve donc dans la config suivante:

UART1: rien touché, activé d'origine.

UART2: TBS crossfire (Donc serial RX ON)

UART4: CADDX Vista, donc j'ai activé le MSP et indiqué que c'était le port du VTX (dans l'espoir que l'OSD fonctionne grâce à WTF OS)

UART5: GPS (lui il fonctionne maintenant donc j'ai pas trop de doute)

Vous en pensez quoi les spécialistes?

Je n'ai plus que la boussole à brancher, mais a priori, cela ne servirais à rien, vous confirmez?

 

01.jpg

Sans titre 1.jpg

Modifié (le) par Phenix2984
  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

Non aucun problème tu mets ce que tu veux sur l uart du moment qu il n est pas utilisé. 

Sur cette fc, c'est l uart 1 pour le vtx car tu as un vcc dessus pour l alimentation. Un caddx est alimenté en VCC et pas en 5v. 

Le gps serait mieux en uart 4 car 5v et gnd. 

Modifié (le) par Gui51
Lien vers le commentaire
Partager sur d’autres sites

Je me suis posé la question, mais d'origine il est sur le 5V et il fonctionne.

Comme j'ai un doute sur le voltage du Vbat en 6S, je préfère le laisse en 5V s'il fonctionne que de le mettre sur Vbat et le cramer.

S'il faut le mettre sur Vbat, ça veux dire qu'il faut que je dégage la prise d'origine et que je ressoude tout sur la FC en direct (maintenant je commence à avoir la technique).

Si je fait ça, autant le souder sur l'UART1 comme préconisé par le fabricant de la FC et mettre le GPS sur l'UART4?

EDIT: le Vbat est de l'autre coté de la FC, le fil du vista est pas asses long, il faudrait que je rallonge le + et le -.

Modifié (le) par Phenix2984
Lien vers le commentaire
Partager sur d’autres sites

Merci de votre aide.

Je suis en train d'imprimer le support de GPS en partant pour tout laisser comme ça, vue que ça marche.

Par contre, impossible d'avoir l'OSD Betaflight dans les FPV Google v2.

J'ai suivi à la lettre le tuto WAF, j'ai tout recommencé à zéro avec le tuto de Oscar Liang, dans les deux cas, c'est un échec.

Aucun OSD (juste les batteries des Google, j'ai reflashé les extensions WTF OS mais aucune amélioration.

Sans ça le GPS perd une partie de son utilité...

  • Confus 1
Lien vers le commentaire
Partager sur d’autres sites

  • Solution

Avec ton vista en 5v il est clairement sous alimenté. C'est pas normal comme montage. Vérifies que rx et TX du vista sont bien inversés.

Pas besoin de soudé quoi que ce soit, il te faut juste des câbles plus long et l avantage des connecteurs blancs c'est qu il suffit de soulever la languette pour changer le câble. 

Donc vista fil rouge Bat fil noir gnd tx1 et rx1. Et gps sur l uart 4. J ai la même fc que toi et aucun problème. 

Tu refais ensuite les réglages sous bf pour le gps et uart 1 msp displayport. 

Modifié (le) par Gui51
  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

Merci

Sur le principe je suis d'accord, mais l'ayant acheté d'occasion, je n'ai pas cette prise (en rouge)

Donc la seule option pour moi c'est rallonger les câbles d'alim et souder.

Ce que je trouve improbable c'est que l'ancien proprio s'en est servi comme ça sans problème.

20231210_101912.jpg

Modifié (le) par Phenix2984
Lien vers le commentaire
Partager sur d’autres sites

Tu as juste à déplacer le connecteur, on se fiche du pad vtx. Donc avec le connecteur 4 broches c'est bon. 

Et vérifies au passage que le tx du FC est bien sur le rx du caddx et idem tx. 

Modifié (le) par Gui51
Lien vers le commentaire
Partager sur d’autres sites

En fait j'ai regardé, si je suis ton conseil (je trouve ça un peut bourrin mais bon...), ça inverse aussi le TX et le RX, du coup, je tente et je re soude le GPS sur l'UART4, et là...

 

Bingo!!! Tout fonctionne, c'est génial.

Je n'arrive toujours pas à croire qu'il y ai un triple mauvais branchement d'origine (mauvais UART, inversion TX/RX, mauvaise alimentation).

En tout cas tout fonctionne GPS / OSD / VTX.

Trop content.

Il est prêt pour voler!

(même si je n'ai aucun doute qu'il va finir dans un arbre)

1000 mercis!

  • J'aime 1
  • Bouillant ! 1
Lien vers le commentaire
Partager sur d’autres sites

Il n était pas normal ton câblage à l origine. 

Ce n est pas bourrin, comme c est un connecteur 4 pins ça force sur la broche du 5 pin vtx du FC. À l occaz mets un connecteur 5 pins même si en face de vtx tu laisseras l emplacement vide. 

Bon vol. Et avec un gps, penses à configurer ton RTH c est une belle sécurité pour nos quads. 

Modifié (le) par Gui51
  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

Si tu veux nous partager ta config RTH?

Je crois que Jérôme a fais une vidéo sur le RTH de mémoire mais je sais plus si c'est une méthode qu'une review 

Lien vers le commentaire
Partager sur d’autres sites

  • 2 months later...

Hello, j'ai oublié de répondre.

Tout fonctionne bien maintenant, le RTH ne fonctionnais à cause d'un réglage, j'avais coché "autoriser l'armement sans fix GPS".

Donc je démarrais systématiquement sans avoir fixé asses de GPS et le RTH ne fonctionnais jamais.

 

J'ai une nouvelle question, est-ce que c'est normal qu'avec un ciel très nuageux, il n'arrive pas à accrocher de GPS?

Aujourd'hui sur mon terrain de jeu: 0 GPS, je n'ai pas pu voler.

Je reteste au boulot il voit vaguement un GPS, mais celui-ci disparait, il n'arrive pas à le fixer.

J'en déduit que le GPS est bien connecté (détecté par BF) et fonctionne (il arrive à en voir au moins 1 dans BF) mais qu'il n'arrive pas à accrocher (l'OSD n'affiche que les GPS accrochés).

Hier j'ai réussi à en accrocher 7 sans problèmes, c'est monté jusqu'à 11 en vol exactement au même endroit.

La seule différence que je vois c'est les nuages, je pensais pas que ça avais autant d'influence.

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

Je trouve que 11 gps en conditions de vol avec ciel normal est leger, avec un bn 220 je monte a 25-26 sans probleme, mais ca baisse quand le temps devient nuageux, donc c'est logique que le tiens ne capte pas top.

 

Il faudrai avoir le lien du tiens pour voir si il est possible de le mettre a jour comme le bn 220 par exemple avec ublox

Lien vers le commentaire
Partager sur d’autres sites

C'est le Walksnail WS-M181 que j'avais indiqué au 1er post que j'ai pris.

Il ne se met pas à jour selon ce que j'ai compris mais il est compatible Galileo par défaut.

https://caddxfpv.com/products/walksnail-ws-m181gps

La puce me paraissait bien plus récente que le BN220.

Je vais remettre le "autoriser l'armement sans fix GPS", si je sais que je vais à plus de 500m, j'attendrais d'avoir les GPS avant d'armer, sinon ça m'évitera le genre de désagrément d'aujourd'hui.

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...