Aller au contenu
DroneBuilds
naviluminor

betaflight PID/rates switchable

Messages recommandés

Hi

Cela fait deux trois jours, et avec l'aide d'un droniste fort patient comme mentor que j’essaie en vain de configurer betaflight : au secours messieurs les érudits :$

Alors voila:

Ma taranis (X9D+) a bien un inter 3 positions d'assigné (et reconnu par betaflight) à la rubrique "adjustements" (via AUX 4) ça c'est OK et fonctionne, mais je ne sais pas quoi marquer en bout de ligne, "slot 1" 2e lignes "slot 2" ??? pis le cartouche au bout il faut y mettre quoi ???

Dans rates profile j'ai cafouillé les valeurs des trois tableaux, idem pour les pid (test statique à la con)

Seulement voila, changer la position de l'inter ne modifie en rien l'affichage des tableaux des rates, même après avoir fait  "refresh" 

Pour changer les pids, cela se fait avec les sticks semble-t-il, idem je n'y arrive pas :/

Où je merde ? (j'ai bien peur qu'il y est beaucoup d'endroit)

Où trouver un tutoriel pas trop incompréhensible pour une tanche ? (ou une huitre)

 

Merci tous

 

Kcnarf le molusque.

Modifié (le) par naviluminor

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour les nombreux avis, le un forum il n'y a pas dire, c'est quand même top :x

 

Franck.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je change de profils avec mes sticks pour ma part et je n est rien eus a régler ou paramétrer nul part .

RxZwFvi.png.fec0069ffe22433870f2e4c529b5c926.png

Modifié (le) par mobiman

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour les réglages dans ajustement , les slot je ne change rien , je laisse ( slot 1) ca fonctionne tres bien comme ca .

Sur ma taranis , je me sert des 2 potentiomètres S1 / S2 et des trimes ail/prof/gaz/direc qui ne m avait jamais servi et que j ai donc détourner .

Je peut donc avec les auxiliaires 5 a10 , regler le P le I et le D du roll et du pitch .

Au cas ou tu ne le saurais pas , lorsque tu débranche ta lipo les réglages effectué partent . Il faux connecter a beta et save , lipo branché , ce qui est dangereux sauf si tu bride les hélices par paire avec deux morceau de durite . Ou alors tu compte les bips . ( ce sont des double bips quand tu monte et des simple bip quand tu décent )

dfgdfgdfgd.thumb.PNG.a2b790575c9c4d3db896f9f2bb1d15e7.PNG

Modifié (le) par mobiman

Partager ce message


Lien à poster
Partager sur d’autres sites

Je me sert du script pour deux de mes quads , c est vraiment pas mal et pas difficile a mettre en œuvre !

https://multi-voltige.fr/viewtopic.php?f=15&t=3547&mobile=on

Modifié (le) par mobiman

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 16 heures, Motard Geek a dit :

J'ai pas tout capté à la problématique mais moi je change de profil via l'OSD 9_9

Voila très exactement ce que je voulais dire : (je n'arrive pas à ce résultat et ne pige pas pourquoi !) 

----> 

Partager ce message


Lien à poster
Partager sur d’autres sites

Pis pour les PID, comment vérifier visuellement que les profiles sont "actés" et que le passage de l'un à l'autre se fait ?

 

Kcnarf.

 

Ps: ah oui :  merci "tous" ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

A oui les rateprofile donc , je viens de tester comme sur la vidéo et pour moi ca fonctionne .

Je n avais jamais testé ,,, on peut régler 3 type de rateprofile pour chaque profile ( ca fait 9 rateprofile en tout ) ,,, on change de rateprofile tout en volant c est pas mal .

Pour changer de profil c est toujours au sol avec les sticks moteur désarmé !

Si tu a fais comme dans la vidéo ca devrait fonctionné , a moins que tu est un souci de réglage de ta radio mais si tu dis :

Le 09/09/2017 at 10:46, naviluminor a dit :

Ma taranis (X9D+) a bien un inter 3 positions d'assigné (et reconnu par betaflight) à la rubrique "adjustements" (via AUX 4)

Pour m assuré du bon fonctionnement , j ais mis dans chaque profile un rateprofile très bas ( RP1 pour P1 / RP2 pour P2 / RP3 pour P3 ) et constater le flagrant changement de comportement . 

Modifié (le) par mobiman

Partager ce message


Lien à poster
Partager sur d’autres sites

Je lis ça et là que la dernière version de betaflight est instable et vérolée (3.2) et comme les mises à jour sont automatique :/

 

Kcnarf.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure, naviluminor a dit :

Je lis ça et là que la dernière version de betaflight est instable et vérolée (3.2) et comme les mises à jour sont automatique :/

 

Kcnarf.

Pour l instant tout mes model son en 3.1.7 ,, pas testé la version 3.2 ,, il vaux peut être mieux attendre , effectivement o.O

Partager ce message


Lien à poster
Partager sur d’autres sites

Après moult essais, c'est mon vortex 150 qui refuse les ordres de betaflight, avec mon moby x2 cela "marchouille" , il faut cependant faire "refresh" pour effectivement voir bouger les tableaux, l'inter assigné ne fait pas varier "directement" les valeurs comme la vidéo plus haut

Kcnarf.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×