Aller au contenu
DroneBuilds
Christopher

RESOLU - Problème récupération télémétrie sur Taranis avec X4R SD et F4 v3

Messages recommandés

Salut la comm,

Après avoir fait pas mal de recherches sur les forums, après avoir exécuté plusieurs tutos, je pose mon problème. En effet, je n’arrive pas à récupérer la télémétrie sur ma Taranis. J’ai bien les commandes avec la télémétrie de base (4) mais rien de plus. J’ai branché le fil Smart Port (jaune) sur l’UART 3. Je lance la recherche (avec Lipo) sur ma Taranis de nouveaux capteurs et RIEN. Dans BF, j’ai bien mis SMARTPORT sur l’UART 3 et j’ai bien activé la télémétrie.
J’ai bien de la télémétrie en OSD dans mon masque.

Ai-je oublié de faire quelque chose ? Je ne comprends vraiment pas d’où vient le problème. Ça a l’air bien plus simple dans les tutos.

Ma config :

·         Commande : Taranis x9d plus SE – non EU (neuve)

·         Récepteur : FrSky X4R SB (bindé sans problème)

·         FC : Omnibus F4 v3 montée sur un Wizard x220s

Et voici les photos.

2013097980_carteF4-recep.thumb.jpg.f3ea8bb64a58256a18183db1fb293ff7.jpg

Beta1.thumb.jpg.5d4b30b912449846c5c58779e5685dc7.jpg

Beta2.thumb.jpg.a50a08d760bf0462b5b8371078f35288.jpg

radio.thumb.jpg.234f1c6df2010ae80154a004e637e78b.jpg

D’avance merci pour vos suggestions de résolutions du problème.

Modifié (le) par Christopher
RESOLU

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon voilà, j'ai trouvé. https://oscarliang.com/betaflight-soft-serial/#invert-smartport

J'ai soudé sur l'UART TX 1

J'ai assigné le port SOFTSERIAL à mon SERIAL_TX 1

Activé le smartport sur le softsérial

Et voilà, ça marche.

Désolé pour le dérangement

Partager ce message


Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Il manque la désinversion du signal. Regarde du côté softserial.
Edit : c'est ça

Modifié (le) par goony

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 43 minutes, goony a dit :

Il manque la désinversion du signal. Regarde du côté softserial.
Edit : c'est ça

Si je reçois toute la télémétrie, je suppose que c'est bon?

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui, c'est bon.
Tu peux même passer au protocole F-Port et n'utiliser qu'un câble. Comme ça tu pourras retirer les gros pins qui dépassent et n'utiliser que la petite prise blanche.

Modifié (le) par goony

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×