Jump to content
DroneBuilds
Tinouleffe

PB firmware R9M

Recommended Posts

salut a tous,

je viens a vous car j'ai un soucis avec mon module R9M, ce dernier est lbt en flex firmware et Opentx 2.2.3.

j'ai voulu changé le mode de bind tout a l'heure, et quand je suis revenu sous le R9m ce dernier n'était plus en lbt mais en fcc, et impossible de le refaire revenir en lbt.

je peux choisir la fréquence et la puissance de 10mw a 1W contre 25mw a 500mw avant.

j'ai reflash la taranis, reflash le R9M en fex, non flex lbt, nada.

et en plus ce dernier me met le message quand je change de frequence :

requires no certified r9m firm

ça m'emmerde bcp cette histoire et de l'aide serai la bienvenue.

apparemment c'est un pb de firmware mais je n'ai pas plus d'infos.

 

merci d'avance les amis

Edited by Tinouleffe

Share this post


Link to post
Share on other sites

Salut,

J'ai aussi ce message à chaque fois que je passe de EU à FCC ou vis versa, mais il suffit de presser d'appuyer sur le bouton exit comme c'est indiqué et le changement s'applique bien, je pense que c'est juste un message d'avertissement.

Share this post


Link to post
Share on other sites

OK, mais normalement en lbt, tu es de 25mw à 500mw, pk la même sinon est sensé être en lbt à 868mz on a de 10mw à 1w comme en Fcc ? 

  • Confus 1

Share this post


Link to post
Share on other sites

Justement, tu n'as pas le firmware EU, tu es en Flex, je ne comprends pas ce qui te perturbe ?

Citation

● 4 Optional RF power (Non-EU Version)

● Telemetry mode(25mW)/non-telemetry mode(200mW / 500mW) (EU Version)

RF Power (Flex): 10mW/100mW/500mW/1W (telemetry supported for all levels)

Share this post


Link to post
Share on other sites

En fait ce qui me perturbe c'est que j'ai tjs été en flex et que je n'avais pas ça ^^ et que même en officiel lbt il met fais la même chose. 

Share this post


Link to post
Share on other sites
Youtube WE are FPV

Tu m'as perdu 😅

Tu veux dire qu'avec le firmware EU tu pouvais choisir la fréquence et mettre une puissance supérieure à 25 mW avec la télémétrie ? Parce que c'est justement ça qu'apporte le firmware Flex 😉 

Share this post


Link to post
Share on other sites

Ahhh si, je crois que j'ai compris : quand tu as reflashé avec le firmware EU, tu as dû laisser l'option de compilation "flexr9m" (à moins d'avoir remis à jour OpenTX), tu te retrouves alors dans une situations bancale : la Taranis te laisse le choix des fréquences vu que OpenTX a été compilé avec cette option, mais si le firmware du module externe ne le gère pas, ça risque de poser prbl 😉 

Edited by Jerome

Share this post


Link to post
Share on other sites

Heu bah quand j'ai reflash ma taranis je l'avais flash avec l'option R9m. 

Du coup je fais quoi je fais un remise à zéro d'usine ? Reflash la Taranis avec l'option R9m et reflash le module du R9m en flex ? 

Share this post


Link to post
Share on other sites

Il faut être homogène :

  • soit firmware flex sur le R9M et Open TX 2.2.3 avec l'option flexr9m (et firmware flex pour le RX)
  • soit firmware EU sur le R9M et Open TX sans l'option flexr9m (et firmware EU pour le RX)

Maintenant, si la version flex fonctionne bien chez toi, je ne vois pas de raison valable de rester en EU, c'est l'option la plus flex...ible et t'affranchit de toutes les contraintes des firmwares classiques.

Share this post


Link to post
Share on other sites

Mmmh OK je vais voir ça, mais ce qui est chelou c'est que à la base je n'ai rien changé j'avais flash le R9m en flex et lbt, enfin bref je check ça et te redis

Share this post


Link to post
Share on other sites

Bon c'était bien le fw open tx qui faisais de la me***, déjà d'une je fonctionne sur 2 opentx différent 1 linux et 1 Windows, je pense que la version Linux fais de la bouze.

Apres c'est bien le mode flex R9m qui faisait ça, J'etait en flex sur émetteur et récepteur mais pas sur l'open tx. 

Merci ! 

Je vais test du coup la version flex cet aprèm ^^

Share this post


Link to post
Share on other sites

Que ce soit la version Windows, Linux ou Mac de Companion, elles ne font que récupérer en ligne une version précompilée de OpenTX qui correspond aux paramètres que tu as cochés, ce n'est pas compilé en local sur ta machine. Donc c'est étonnant que tu observes des comportements différents.

Quoiqu'il en soit, tu touches au but, ça devrait bientôt voler cette affaire 😉 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...