Jump to content
DroneBuilds
Atlas

Problème R-XSR, Taranis X9D+ et BF

Recommended Posts

Bonjour, 
Cela fait plusieurs heures que je suis face à un problème j'ai donc décidé de demandé de l'aide!
Voilà j'ai mon drone équipé de: FC kakute F4 AIO V2, et d'un R-XSR, et j'ai une Taranis X9D+.
j'ai bind ma radiocommande à mon récepteur, pas de soucis le R-XSR s'allume vert et pour vérifier quand j'éteins ma radiocommande ça passe au rouge (je suis bien en sbus dans BF et sur le R-XSR (led verte et bleu fixe)).
Cependant dans Betaflight aucune commande ne semble répondre que se soit dans l'onglet récepteur ou l'onglet mode et je ne peux pas non plus désarmer...
En espérant que vous puissiez m'aider. 

 

PS: j'ai fais les MAJ du xjt et du R-XSR.

Share this post


Link to post
Share on other sites

Salut,

Je ne connais pas cette FC mais parfois il est nécessaire d’alimenter le drone avec la batterie pour que BF détecte la radio...

Slts


Envoyé de mon iTruc en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Le câble est il bien sûr le pas sbus de ta fc?

Le smartport ne marchera pas avec une F4 il te faut souder le signal en version uninverted

Envoie des photos des onglet mixer en entrée sur ta radio pour checker si tout est ok

https://images.app.goo.gl/7bwasu5Dyrc1NfjZ7

Edited by Joelamoule

Share this post


Link to post
Share on other sites

Ok après vérif sur la manuel de la carte, ton cablage du r xsr a l'air bon, le smartport du RX  doit être sur le pas SP de ta FC et le sbus sur le pas R3.

 

Donc sur betaflight le sérial RX doit être sur uart 3

Share this post


Link to post
Share on other sites
Youtube WE are FPV

Et activer le SmartPort Télémétrie en UART1


Envoyé de mon iTruc en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Par contre es-tu sûr de l’emplacement du SA de ton Vtx? Il semblerait qu’il soit sur un pad Rx de la Fc... or il faut le coller sur un Tx vers le Vtx...

en l’occurrence Tx6 avec activation du TBS SA en UART6 sous BF

A vérifier avec la doc...

 

 

Envoyé de mon iTruc en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Alors après vérif je suis bien régler comme vous dite et pour le VTX j'ais regarder le manuel pour moi c'est bon mais vous pouvez me le confirmer?! : (cf les photos).

IMG_0361.jpg

Capture.PNG

Share this post


Link to post
Share on other sites

Salut,

Côté radio semble ok, mais ma question concerne le fil bleu de la prise du Vtx qui doit être soudé sur un pad Tx sur la FC ... or sur la photo il semble soudé sur un Rx ... juste à coté du SP du R-XSR ( le fil vert)


Envoyé de mon iTruc en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Ah! je ne savais pas que le Rx ou Tx avait une importance... D’ailleurs l’un ou l’autre qu’elle est la signification


Envoyé de mon iPhone en utilisant Tapatalk

Share this post


Link to post
Share on other sites

C’est une liaison UART, et ces liens se font entre un canal émetteur Tx et un canal récepteur Rx
Par conséquent pour chaque liaison UART entre deux modules ( FC , Vtx, FPVCam etc) en fonction de qui commande qui, il faut que chaque Rx soit relié avec un Tx...
d’ailleurs parfois, il y a 1 Rx et 1 Tx connecter ou parfois seulement 1 Tx ou 1 Rx..
Ce deuxième cas étant pour ton Vtx, le fil bleu est relié au Rx donc en face il faut qu’il soit soudé sur un Tx... ce qui est logique puisque tu va pouvoir changer les paramètres du Vtx ( band / channel) avec les sticks de la radio en passant par la FC...


Envoyé de mon iTruc en utilisant Tapatalk

Share this post


Link to post
Share on other sites

D’accord je comprend mieux! Donc une liaison Tx suffit c’est ça?

Bon par contre je suis toujours emmerder avec mon R-XSR ^^


Envoyé de mon iPhone en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Déjà si ton installation HW est correcte , tu peux passer à la config et au paramétrage de la radio puis sous BF


Envoyé de mon iTruc en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Pour la radio commence par déclarer tes entrées et il faut qu’elles soient en relation avec les mixers...

Une fois que c’est propre de ce côté là tu peux passer sous BF pour déclarer tes ports puis tes divers réglages sans oublier de sauvegarder avant de changer d’onglet !

Pour ces deux phases, il y a plein de tutos en français sur Utube ( WaF / CultureFPV etc...) c’est très bien expliqué, même si ce n’est pas pile poil ta version de BF... n’hésites pas à en consulter plusieurs car je pense qu’il ne te manque pas grand chose pour que la liaison fonctionne...
Et si après ça ce n’est toujours pas bon et que tu es sûr de tes réglages, comme l’a suggéré Joelamoule, assures-toi que ta FC n’ait pas un s-bus inversé en cherchant les builds avec cette FC...
Aller courage


Envoyé de mon iTruc en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Étant novice j’ai regarder pas mal de Tuto en particulier celui là (

).

Mais malgrer ça toujours se même problème.

Dès que je rentre je change ce fameux câble en le mettant sur le rx. Mais on est d’accord rx ou tx la fc le gère seul ? Hormis le serial rx qu’il faut cocher pour le R-XSR.

 

 

Envoyé de mon iPhone en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Le Serial que tu déclares dans BF concerne le protocole sbus du R-XSR

En rentrant ressoudes le fil bleu du Vtx sur le pad Tx6 de ta FC ( puisque c’est celui que tu as déclaré sous BF)


Envoyé de mon iTruc en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Pour les tutoriels cherches un tuto de Dad sur CultureFPV à propos de BF ...
C’est moins brouillon que Gtech


Envoyé de mon iTruc en utilisant Tapatalk

  • J'aime 1

Share this post


Link to post
Share on other sites

Ça marche je vais faire ça. Pour le tuto c’est sur la page YouTube ou sur le fofo ?


Envoyé de mon iPhone en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Regarde dans onglet configuration de betaflight si tu es bien en RX série et protocole sbus dans la zone récepteur.

Share this post


Link to post
Share on other sites

Oui coter BF tous est ok. Il me reste à ressouder le fil du vtx sur le pas tx et c’est bon côté fils.

Share this post


Link to post
Share on other sites

Ok  check bien si tu es bien en fcc ou eu lbt de partout, mais si ça bind, déjà ça doit pas être ça.

 

Je te conseille de te créer un nouveau modèle avec un tuto.

 

Si ça fonctionne toujours pas, va falloir nous envoyer ton diff ou dump pour en savoir plus

Share this post


Link to post
Share on other sites

Je vais essayer ce que tu dis. Par contre truc bizarre je bind avec se R-xsr mais avec celui d’un pote impossible les 3 led (bleu, rouge vert) reste allumer.


Envoyé de mon iPhone en utilisant Tapatalk

Share this post


Link to post
Share on other sites
Il y a 2 heures, Atlas a dit :

Je vais essayer ce que tu dis. Par contre truc bizarre je bind avec se R-xsr mais avec celui d’un pote impossible les 3 led (bleu, rouge vert) reste allumer.


Envoyé de mon iPhone en utilisant Tapatalk

Justement a cause du firmware de la radio qui doit être différent du r xsr de ton collègue

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...