Aller au contenu
DroneBuilds

Omnibus F4 V3 + recepteur R9MX S.port/Fport


Messages recommandés

Salut a tous ,

Actuelllement j'ai un recepteur Frsky XSR sur ma carte soudé au niveau UART 6 qui fonctionnait en Sbus sasn soucis a cet endroit . J'ai voulu installer ce nouveau recepteur qui fonctionne avec du Sport/Fport a la meme place mais il semblerait que cela ne soit pas son bon emplacement  vu que je n'arrive pas a binder ..

Pensait vous que je dois souder ailleurs ces 3 fils sur un autre UART ?

OQUJ1314.JPG

 

u31MmRMl.jpg

4upiuD7l.jpg

Modifié (le) par KoKoboy
Lien à poster
Partager sur d’autres sites
  • 2 months later...

Salut,

 

Je déterre un peut le poste car étant un bleubite en électronique je savoir si quelqu'un un schéma pour savoir comment branche mon FrSky R9MX  à  mon Omnibus F4 Pro V3 ?

Je comprend pas grand chose au sbus et tout ces trucs.

Mille merci par avance.

Lien à poster
Partager sur d’autres sites
  • 4 weeks later...
il y a 32 minutes, banban a dit :

Personne pour m'aider? Et au final c'est la F4 V3 que j'ai et non la F4 pro.

Bonsoir,

Coté R9MX, le plus simple est de connecter les 3 cables VIN, GND et le pad "F-Port" qui fait tout passer sur un seul fil (signal + télémétrie).

image.png.587e1ae8471e5ef6621e8f688b05f575.png

Coté FC, tu connectes le VIN à un +5v, le GND sur un GND et le F-Port sur TX1...

Tu programmes le R9MX en F-Port.

Voila

Modifié (le) par CC06
  • Merci ! 1
Lien à poster
Partager sur d’autres sites
Youtube WE are FPV
il y a 3 minutes, CC06 a dit :

Bonsoir,

Coté R9MX, le plus simple est de connecter les 3 cables VIN, GND et le pad "F-Port" qui fait tout passer sur un seul fil (signal + telemetrie).

image.png.9ee54584119e0466b8a77f0c52450493.png

Coté FC, tu connecte le VIN à un +5v, le GND sur un GND et le F-Port sur TX1...

Tu programme le R9MX en F-Port.

Voila

Super je te remercie, j’espaçai ça au plus vite. 
et quand tu dit « tu programme le R9MX en F-Port » c’est sur la radio commande?

Lien à poster
Partager sur d’autres sites

Je pense car le R9MX est en ACCESS uniquement. Tu dois pouvoir le flasher et le programmer par la radiocommande (fonction OTA).

J'espere pour toi que ta radiocommande et ton module R9M sont en ACCESS aussi (pas ACCST). 

Modifié (le) par CC06
  • Merci ! 1
Lien à poster
Partager sur d’autres sites

Au fait, quand tu vas configurer Betafligh ou Emuflight, tu devras rentrer ceci en ligne de commande pour configurer le R9MX:

serial 0 64 115200 57600 0 115200
set serialrx_provider = FPORT
set serialrx_halfduplex = ON
set serialrx_inverted = OFF 
set rssi_scale = 200

Pour la dernière ligne, je suis pas sur que le R9MX ait le même problème d'affichage dans l'OSD que le R9MM pour le niveau de RSSI (il affiche de 0 à 50 uniquement par défaut). Cela permet de remettre l'echelle de 0 à 100 pour le RSSI.

  • Merci ! 1
Lien à poster
Partager sur d’autres sites

Alle je m'attaque au montage et je te tien au courant, 

Le 05/01/2021 at 20:18, CC06 a dit :

Au fait, quand tu vas configurer Betafligh ou Emuflight, tu devras rentrer ceci en ligne de commande pour configurer le R9MX:

serial 0 64 115200 57600 0 115200
set serialrx_provider = FPORT
set serialrx_halfduplex = ON
set serialrx_inverted = OFF 
set rssi_scale = 200

Pour la dernière ligne, je suis pas sur que le R9MX ait le même problème d'affichage dans l'OSD que le R9MM pour le niveau de RSSI (il affiche de 0 à 50 uniquement par défaut). Cela permet de remettre l'echelle de 0 à 100 pour le RSSI.

Aller je m'attaque au remontage, je te tien au courant.

Lien à poster
Partager sur d’autres sites

Alors, La télémétrie fonctionne bien mais mes sticks ne sont pas reconnu dans betaflight.

Vous avez une idée?

Lien à poster
Partager sur d’autres sites
il y a 4 minutes, Attafr a dit :

Inverted SBUS =ON ?

C'est à dire?

J'ai branché comme de ceci 833001747_Essai3.thumb.png.3d55934703321225961092ac42ea156c.png

Modifié (le) par banban
Lien à poster
Partager sur d’autres sites

Fais un get serialrx tu verras les valeurs 

serialrx_halduplex=ON/OFF, il doit être sur ON

serialrx_inverted=ON/OFF, il doit aussi être sur ON

A toi de tester entre ces paramètres 

n’oublie pas save !

Lien à poster
Partager sur d’autres sites
il y a 6 minutes, Attafr a dit :

Fais un get serialrx tu verras les valeurs 

serialrx_halduplex=ON/OFF, il doit être sur ON

serialrx_inverted=ON/OFF, il doit aussi être sur ON

A toi de tester entre ces paramètres 

n’oublie pas save !

Voila ce que j’obtiens:

serialrx_provider = FPORT
Allowed values: SPEK1024, SPEK2048, SBUS, SUMD, SUMH, XB-B, XB-B-RJ01, IBUS, JETIEXBUS, CRSF, SRXL, CUSTOM, FPORT, SRXL2
Default value: SPEK1024

serialrx_inverted = OFF
Allowed values: OFF, ON

serialrx_halfduplex = ON
Allowed values: OFF, ON
Default value: OFF

comment je met "serialrx_inverted=ON"

 

Désolé je suis vraiment pas doué.

Modifié (le) par banban
Lien à poster
Partager sur d’autres sites

A présent j'ai bien

 

# get serialrx
serialrx_provider = FPORT
Allowed values: SPEK1024, SPEK2048, SBUS, SUMD, SUMH, XB-B, XB-B-RJ01, IBUS, JETIEXBUS, CRSF, SRXL, CUSTOM, FPORT, SRXL2
Default value: SPEK1024

serialrx_inverted = ON
Allowed values: OFF, ON
Default value: OFF

serialrx_halfduplex = ON
Allowed values: OFF, ON
Default value: OFF

 

Mais je ne vois toujours pas les sticks bouger dans betaflight.

Lien à poster
Partager sur d’autres sites

Bon j'ai branché sur RX6 et UART6 dans BETAFLIGHT et toujours rien. Sachant que sur ma radio je vois bien les sticks bouger. 

Lien à poster
Partager sur d’autres sites
il y a 22 minutes, banban a dit :

Bon j'ai branché sur RX6 et UART6 dans BETAFLIGHT et toujours rien. Sachant que sur ma radio je vois bien les sticks bouger. 

Tu as bien définis les inputs et mixer sur ta radio ?

essaye de remettre set serialrx_inverted=OFF et save !

tu peux aussi sur le RX utiliser inverted SPort et mettre set serialrx_inverted=ON (c’est avec ces paramètres, qu’il faut jouer)

Ne pas oublier aussi d’effacer les capteurs sur ton modèle et re faire une recherche...

Modifié (le) par Attafr
Lien à poster
Partager sur d’autres sites
Il y a 13 heures, banban a dit :

Bon j'ai branché sur RX6 et UART6 dans BETAFLIGHT et toujours rien. Sachant que sur ma radio je vois bien les sticks bouger. 

Banban,

C'est un TX, pas un RX qu'il faut ! Branche sur TX6 pas RX6, sinon, ça ne peux pas marcher... le TX fait TX/RX, le RX ne fait que RX... et le FPort nécessite le TX et le RX (le FPort est bi-directionnel, il véhicule dans un sens les valeurs des sticks et des interrupteurs, et la télémetrie dans l'autre sens). 

Lien à poster
Partager sur d’autres sites

Désolé je me suis trompé de touche. J’ai bien branché sur TX6, je vois bien le RSSI sur ma radio donc je suppose que les branchements sont bon. Après sur ma radio je vois bien les sticks bouger mais après je sais pas trop. 

Lien à poster
Partager sur d’autres sites

La télémetrie et notament le RSSI ne sont pas envoyés par la FC, mais par le récepteur. Du coup, dès que t'es "bindé", tu le reçois. Cela confirme que le récepteur est alimenté, donc que les branchements du + et - sont bon, pas celui du FPort. Si maintenant, en faisant une découverte des capteurs de télémetrie sur ta radiocommande, tu tombes sur du GPS ou autre envoyés par la FC, alors la, ou le branchement serait correct.

Changer l'UART (de 1 à 6) était un choix très judicieux, effectivement j'ai rencontré des FC avec un port fonctionnant mal.

Après, je reste très mitigé sur le RX avec un microcontrolleur F4 et serialrx_inverted=ON. Tout est plus simple avec les F3 et F7 qui inversent automatiquement, mais les cartes à base de F4 sont capricieuses. La config que je t'ai passé est pour du R9MM-OTA et des F4, ça marche à chaque coup sur les configs que je monte.

Est-tu sur que tu as bien sélectionné F-PORT dans la configuration du module sur la Radiocommande ?

"F.port / S.Port can be switched in the radio menu."

Modifié (le) par CC06
Lien à poster
Partager sur d’autres sites
  • 2 weeks later...

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...