Aller au contenu
DroneBuilds

Reception de mon Eachine EB185


Messages recommandés

Bonjour à tous,

Voulant commencer le drone fpv (J'ai volé avec un parrot mambo et je voulais passer à la gamme au dessus), je me suis donc acheté un Eachine EB185 d'occasion. 
A la réception je tente de brancher le drone à mon ordinateur et d'aller sur cleanflight. Ca me dit qu'une mise à jour du firmware doit  être faite. Sur internet j'ai trouvé cette vidéo : https://www.youtube.com/watch?v=0c5r3cxqFHI&feature=emb_logo  où la personne installe un firmware Naze. Je suis donc son exemple. 

L'installation se déroule normalement. Mais le drone ne veut toujours pas se connecter à cleanflight et ne bip plus. Je tente donc d'installer les différents drivers que Cleanflight propose mais toujours le même soucis. 

Je ne peux même plus mettre à jour le firmware. Je vous joint 2 screen. 

Pourriez-vous m'aider s'il vous plait ? :D. 

Merci d'avance. 

Cleanflight.png

Cleanflight 2.png

Lien à poster
Partager sur d’autres sites

Bonjour, passe te présenter toi et ton matériel ici https://forum.wearefpv.fr/15-présentation/

Tu nous dis ce que tu as comme matos, radio, fc etc...

C’est du matos un peu (très) obsolète...

https://fr-m.banggood.com/Eachine-EB185-FPV-Racing-Drone-with-Mini-NZ-GPS-OSD-5_8G-40CH-HD-Camera-RTF-p-1052503.html

Modifié (le) par Attafr
  • +1 1
Lien à poster
Partager sur d’autres sites
Il y a 11 heures, Oni a dit :

 mais n'est-il pas possible de faire quelque chose pour m'aider malgré cela ?.

Ben si, en suivant le premier lien que t'a posté attafr 😉

Il y a 18 heures, Attafr a dit :

Bonjour, passe te présenter toi et ton matériel ici https://forum.wearefpv.fr/15-présentation/

C’est du matos un peu (très) obsolète...

Je rajouterai : Un peu (beaucoup)

Lien à poster
Partager sur d’autres sites
il y a une heure, CriTof a dit :

Ben si, en suivant le premier lien que t'a posté attafr 😉

Je rajouterai : Un peu (beaucoup)

Beaucoup c’est pire que trop ? 🤭

  • Haha 1
Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Et bonjour à vous 2. 

Je viens à l'instant de terminer ma présentation, j'espère qu'elle convient. Je suis vraiment novice en la matière, alors je m'excuse d'avance pour mon manque de connaissance. Hormis avoir regardé beaucoup de vidéos je n'ai pas encore démonté de Quad et ne sait vraiment pas encore comment cette petite bête fonctionne. 

Lien à poster
Partager sur d’autres sites

Ta carte est une naze32 V3 me semble t’il.

Tu peux essayer un autre câble, c’est un câble DATA qu’il te faut, pas trop long de préférence, un câble qui va bien, c’est celui livré avec les GoPro 3.

Tu peux essayer ImpulceRC driver fixer pour passer ta carte en DFU, ça résoud souvent le problème.

https://impulserc.com/pages/downloads

Quand tu connecté ta carte au PC, tu as le « ding dong » typique de windaube?

Lien à poster
Partager sur d’autres sites
il y a 24 minutes, Attafr a dit :

Ta carte est une naze32 V3 me semble t’il.

Tu peux essayer un autre câble, c’est un câble DATA qu’il te faut, pas trop long de préférence, un câble qui va bien, c’est celui livré avec les GoPro 3.

Tu peux essayer ImpulceRC driver fixer pour passer ta carte en DFU, ça résoud souvent le problème.

https://impulserc.com/pages/downloads

Quand tu connecté ta carte au PC, tu as le « ding dong » typique de windaube?

D'accord génial. Naze32 rev 6 d'après ce que j'ai vu sur le site du quad. 

J'ai déjà testé différents câbles et j'ai prit le câble DATA le plus court que j'ai actuellement.
J'ai déjà testé ImpulceRC et ça reste bloqué sur Searching for flight controller (J'ai re-testé à l'instant ça me fait pareil).
Et oui mon pc fait bien le son typique d'un branchement de périphérique. 

Modifié (le) par Oni
Lien à poster
Partager sur d’autres sites

J'ai déjà installé le driver CP210x. Le pilote STM USB VCP également. Et j'ai essayé via Zadig comme conseillé sur le net. 

Dans mon gestionnaire de périphérique le drone apparait sous le nom de CP2104 USB to UART Bridge Controller. 

Et si maintenant quand j'essai de flasher ça me dit Echec d'ouverture du port série. Ou Aucune données reçue depuis 10 sec, échec de communication. Voir Aucune réponse du bootloader, programmation ECHEC.

Modifié (le) par Oni
Lien à poster
Partager sur d’autres sites
il y a 3 minutes, Attafr a dit :

Je sais pas si tu « ponte » le bootloader pad avant/pendant que tu connectes ta carte au PC ?

Pour utiliser impulceRC il ne faut pas le ponter.

J'ai peur de ne pas avoir compris mais je me lance. Vous parlez du petit bouton sur la FC sur lequel il faut appuyer pour agir sur la FC c'est bien ça ?. 

Lien à poster
Partager sur d’autres sites
il y a 45 minutes, Oni a dit :

J'ai peur de ne pas avoir compris mais je me lance. Vous parlez du petit bouton sur la FC sur lequel il faut appuyer pour agir sur la FC c'est bien ça ?. 

Oui, tout à fait. Tant mieux si tu disposes de ce petit "switch", plus pratique pour rentrer en mode Bootloader. 

Maintenir appuyé de préférence avec un outil non métalique (Cure-dent par exemple) et pluguer ta li-po. Normalement dans le port Com de la page d'accueil de ton configurateur apparait alors la mention DFU.

Tu peux donc à l'issue (Li-Po plus nécessaire) ré-injecter un nouveau firmware (Targuet) dans ta FC. 

Modifié (le) par CriTof
Lien à poster
Partager sur d’autres sites
il y a 45 minutes, Oni a dit :

J'ai peur de ne pas avoir compris mais je me lance. Vous parlez du petit bouton sur la FC sur lequel il faut appuyer pour agir sur la FC c'est bien ça ?. 

Oui, c’est ça... mais tu as un bouton?

C3081283-4A47-4A8C-B647-C19142C43A8A.thumb.jpeg.5306fca2385deba208ee4116f861aa2c.jpeg

Lien à poster
Partager sur d’autres sites

Je vous avoue que je n'en sais rien. Je n'ai encore jamais ouvert de Quad, ça va être une première ahah avec mon 1er Quad qui n'a encore jamais volé. 
Je vais tenter d'ouvrir ça et je reviens vers vous.

Edit : je ne vois pas le fameux bouton. Si vous le trouvez... . 

IMG_20201115_151839.jpg

IMG_20201115_151902.jpg

Modifié (le) par Oni
Lien à poster
Partager sur d’autres sites
il y a une heure, Oni a dit :

J'ai peur de ne pas avoir compris mais je me lance. Vous parlez du petit bouton sur la FC sur lequel il faut appuyer pour agir sur la FC c'est bien ça ?. 

Et donc non je ne pontais pas. J'ai simplement branché le drone au pc et lancé le programme. J'ai également essayé de d'abord lancer le programme puis brancher le drone mais aucune résultat. Ca tourne en boucle sur une recherche de drone.

Lien à poster
Partager sur d’autres sites

Tu as un bouton sur ta FC ? car ça ressemble pas à une carte « standard » naze32 !

Peut être en bas à gauche à côté de 5V ? 
Si jamais tu appuies sur ce bouton et tu branches ton câble au PC , tu peux tester avec cleanflight chargé, si ça marche pas tu lance cleanflight après.

Modifié (le) par Attafr
Lien à poster
Partager sur d’autres sites
il y a 10 minutes, Oni a dit :

Et donc non je ne pontais pas. J'ai simplement branché le drone au pc et lancé le programme. J'ai également essayé de d'abord lancer le programme puis brancher le drone mais aucune résultat. Ca tourne en boucle sur une recherche de drone.

Ouhlaaaa.... Merci pour tes photos ! J'avais completement oublié qu'ils ont osé créer un tres court moment, ce type de FC /chassis 😁

 Alors pour être obsolète, c'est... Obsolète !

Désolé, je passe mon tour. 

Modifié (le) par CriTof
  • Haha 1
Lien à poster
Partager sur d’autres sites
il y a 5 minutes, Attafr a dit :

Tu as un bouton sur ta FC ? car ça ressemble pas à une carte « standard » naze32 !

Peut être en bas à gauche à côté de 5V ? 
Si jamais tu appuies sur ce bouton et tu branches ton câble au PC , tu peux tester avec cleanflight chargé, si ça marche pas tu lance cleanflight après.

Je n'ai trouvé aucun bouton, même en ayant regardé en bas à gauche de 5V.  

Lien à poster
Partager sur d’autres sites
il y a 6 minutes, CriTof a dit :

Ouhlaaaa.... Merci pour tes photos ! J'avais completement oublié qu'ils ont osé créer un tres court moment, ce type de FC /chassis 😁

 Alors pour être obsolète, c'est... Obsolète !

Désolé, je passe mon tour. 

Ahahah au moins il aura servi à quelque chose. Merci beaucoup à toi d'avoir essayé de m'aider :D.

Modifié (le) par Oni
Lien à poster
Partager sur d’autres sites
il y a 1 minute, Oni a dit :

Ahahah au moins il aura servi à quelque chose. Merci beaucoup à toi d'avoir essayé de m'aider :D.

Plus de... 4 ans !! 

Bonne lecture 😁 https://www.helicomicro.com/2016/06/03/eachine-blade-185-le-test/

Modifié (le) par CriTof
  • Haha 1
Lien à poster
Partager sur d’autres sites
il y a 22 minutes, CriTof a dit :

Ouhlaaaa.... Merci pour tes photos ! J'avais completement oublié qu'ils ont osé créer un tres court moment, ce type de FC /chassis 😁

 Alors pour être obsolète, c'est... Obsolète !

Désolé, je passe mon tour. 

C’est pas pire que les machines immersionRC 🤣🤪😜

Lien à poster
Partager sur d’autres sites
il y a 25 minutes, Oni a dit :

Ahahah au moins il aura servi à quelque chose. Merci beaucoup à toi d'avoir essayé de m'aider :D.

Eachine Blade 185 Recover Bootload boot Naze32 unbrick EB185

 
Cela s'est produit peu de temps après avoir connecté mon EB185 à l'ordinateur portable pour la première fois. Un des principaux contributeurs du forum m'a demandé de le documenter. Je venais d'installer CleanFlight et je l'exécutais pour la première fois. Je n'étais pas familier avec cela (étant ma première exposition à Naze32 et CF) mais le quad semblait être calibré et fonctionnant. Le modèle 3D dans CF répondait sur l'écran de l'ordinateur portable lorsque je déplaçais le quad sur le bureau. 

Je pensais que j'avais besoin de changer les ports uart pour qu'ils ressemblent davantage au manuel EB185. Eh bien, vous le faites ... mais j'ai mal interprété ce dont ils parlaient. Après avoir changé par inadvertance les données UART-1 du MSP / 115200 (en changeant autre chose sur cette ligne) ... je ne pouvais plus me connecter au quad. Fondamentalement, il semblait être en brique.

En fin de compte, le Naze32 est censé être incassable. Tout ce que vous avez à faire est de court-circuiter soigneusement le point de test Boot / Boot0 à 3,3 volts, et de le brancher en même temps. Le problème est que sur l'EB185, le signal de démarrage n'est pas transmis à un plot de point de test facile d'accès. Donc, dans ce cas, vous devez utiliser la broche n ° 5 sur la puce STM32F elle-même. 

Comprenant ce qui doit être fait, il semblait assez difficile de tenir une sonde sur une seule broche STM32F sans qu'elle ne glisse et ne court-circuite sur une broche voisine ... sans parler de tenir un court instant pendant la connexion de l'alimentation. Heureusement, j'ai ohmed-out la broche n ° 5 et j'ai trouvé qu'elle allait directement à la jambe de soudure supérieure de la résistance juste à côté sur le PCB.
 
boot4.png
 


Par conséquent, j'ai soigneusement court-circuité ces 2 points (indiqués sur la photo ci-dessus en couleur violette) avec une paire de pinces pointues, tout en connectant simultanément le câble USB provenant d'un ordinateur portable. L'ordinateur portable Windows détecte le périphérique Naze32 dans "Périphériques et imprimantes", mais aucun son du quad. Soulevez et retirez délicatement la pince à épiler en court-circuitant les 2 points. À ce stade, vous devriez avoir terminé. Il devrait se connecter maintenant ou la prochaine fois que vous réinitialisez l'alimentation (ou reconnectez l'USB). 

J'ai commencé CleanFlight et flashé vers: 1.12.1 NAZE 2016-4-10 (Stable). Recalibré et reprogrammé. Bon comme neuf et de retour sur la bonne voie. Note à moi-même: ne recommencez jamais! J'espère que cela t'aides.
Lien à poster
Partager sur d’autres sites
il y a 4 minutes, Attafr a dit :

Woaw merci pour toutes ces infos. 

Je vais tâcher de trouver une pince pointue et de faire la manip comme décrit. 
Concernant la vidéo je l'ai déjà regardé plusieurs fois mais elle ne me sert pas étant donné que je n'arrive pas à flasher la FC à cause d'une erreur "Aucune réponse du bootloader, programmation ECHEC. 

Lien à poster
Partager sur d’autres sites
Le 15/11/2020 at 16:15, Attafr a dit :

Edit : Après une bonne heure à essayer j'ai finalement réussi. Merci énormément !. 
Par contre j'ai quelques nouvelles : Apparemment mon drone ne fonctionne pas sous cleanflight 2.4 (Dernière version). Je me retrouve avec le message de mise à jour que j'ai eu la toute 1ère fois où j'ai branché mon drone je joint un screen. J'avais tenté le flashage depuis ce moment là, et c'est là que j'avais du bloquer ma FC.
Sous cleanflight 1.4 ça fonctionne par contre. Je n'arrive juste pas à enlever le bip incessant du drone quand il est connecté à l'ordinateur, car sur mon cleanflight je n'ai pas l'option "Receiver RX PPM" comme montré sur les vidéos. 

Est-ce que cela veut dire que je ne dois pas mettre à jour ma FC ?. 

Cleanflight bug 2.4.png

Modifié (le) par Oni
Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...