Aller au contenu
DroneBuilds

Problème Capteurs Télémétrie sur Taranis QX7 avec R-XSR et FC Mamba F405


Messages recommandés

Bonjour, 

Après plusieurs jours de galères, je m'en remets à vous pour trouver la solution à mon problème. En effet, j'ai un GPS BN 880 sur mon Quad, avec Rescue Mode bien paramétré et tout est Ok sur Betaflight. Je veux simplement récupérer via la télémétrie les logs GPS sur ma radio en cas de crash pour pouvoir le retrouver.

J'ai donc essayer de mettre un SmartPort sur un UART disponible, avec et sans le SmartPort inversé. J'ai également essayé de brancher le SmartPort sur le PPM du FC et en rentrant ces commandes CLI :

image.png.15fb4b96e5a292fa48bf4edb2a6dd540.png

Rien à faire, je ne détecte que le RSSI et le RxBat sur les capteurs en télémétrie sur ma Taranis QX7.

Est-ce que vous avez des idées de solutions ? Faut-il que je mette en place le F-Port ? 

 

Merci d'avance

Lien à poster
Partager sur d’autres sites

En fport ça devrait être plus rapide, mais pas sur que cela fonctionne sur ta radio.

As tu essayé de découvrir de nouveaux capteurs sur ta radio ? Sinon essayé de suivre le tuto d'Oscar Luang a ce sujet

Modifié (le) par Joelamoule
Lien à poster
Partager sur d’autres sites

Oui oui je lance bien la recherche de nouveaux capteurs et j'ai toujours que le RSSI et le RxBat, mais pas de GPS ni de Vbat etc.. 

Si je passe en F-Port, il faut que je reflash le XJR de la Qx7 et le R-XSR en Fport c'est ça ? 

Lien à poster
Partager sur d’autres sites
il y a 2 minutes, Eluxas120 a dit :

Oui oui je lance bien la recherche de nouveaux capteurs et j'ai toujours que le RSSI et le RxBat, mais pas de GPS ni de Vbat etc.. 

Si je passe en F-Port, il faut que je reflash le XJR de la Qx7 et le R-XSR en Fport c'est ça ? 

Juste le R-XSR, normalement pas ton RF (tu as une radio ACCESS ou ACCST ?)

le lien pour Oscar Liang https://oscarliang.com/setup-frsky-fport/

Pour le R-XSR, il faut utiliser S.Port(uninverted)

B60BC97C-EF3B-473E-8376-F4DEE5C92197.jpeg.60b647dfb9a4db2793c283125ead0fe2.jpeg

Lien à poster
Partager sur d’autres sites

en fait si tu n'as que le rssi et le vbat tu n'as pas la télémétrie donc impossible de recevoir les infos gps.

Pour la maj, tout dépend de la version de ta QX7, mais logiquement c'est juste le r xsr a flashé en utilisant un fil a soudé sur le pad uninverted smartport ( cf photo ) attention a pas trop chauffer le pad au risque de le décoller

uninverted-r-xsr-hack.png

 

d'abord pense a flasher le rxsr via le tuto de @Motard Geek

 

 

lien vers tuto fport

https://www.wearefpv.fr/tuto-frsky-fport-betaflight-20180706/

  • J'aime 1
Lien à poster
Partager sur d’autres sites
Youtube WE are FPV
il y a 27 minutes, Attafr a dit :

Juste le R-XSR, normalement pas ton RF (tu as une radio ACCESS ou ACCST ?)

C'est une ACCST !

Lien à poster
Partager sur d’autres sites
il y a une heure, Eluxas120 a dit :

Et donc vous pensez que le passage en F-Port va tout résoudre ?

Déjà avec cela tu aura la vrai télémétrie et donc moulte capteurs supplémentaires.

Si tu règle bien le tout tu aura aussi les retour gps sur la radio en temps que capteurs

Lien à poster
Partager sur d’autres sites

C'est bon j'ai pu passer en F-Port, et j'ai bien Betaflight qui affiche les commandes effectuées sur le récepteur, mais par contre toujours pas de télémétrie, encore RSSI et RxBat...

 

Quels sont les paramètres à rentrer dans l'onglet Ports ? J'ai branché l'un-inverted S-Port sur le TX3 du FC.

Merci d'avance

Lien à poster
Partager sur d’autres sites
il y a une heure, Eluxas120 a dit :

C'est bon j'ai pu passer en F-Port, et j'ai bien Betaflight qui affiche les commandes effectuées sur le récepteur, mais par contre toujours pas de télémétrie, encore RSSI et RxBat...

 

Quels sont les paramètres à rentrer dans l'onglet Ports ? J'ai branché l'un-inverted S-Port sur le TX3 du FC.

Merci d'avance

Désolé Bonhomme, mais les j’ai fait ce que je pense que peut-être vous m’avez expliqué, donnes en général rien de bon....

As tu bien suivit l’ensemble de/des Tutos ?

Alors OUI le passage en F.Port peut TOUT résoudre ou pas...

As tu bien suivi le lien que je  t’ai donné de Oscar Liang?

à savoir pour une F4 !

If your F4 FC has built-in inverter for SmartPort pin, and you are using the original inverted S.Port signal, you should enter these instead:

set serialrx_halfduplex = OFF
set serialrx_inverted = ON
save

la connection via uninverted S.Port ?

et enfin un TX free ?

Lien à poster
Partager sur d’autres sites

Tout simplement, as tu chargé le bon script Lua Betaflight sur la micro SD de ta Taranis... ? 

De mon coté, les infos GPS apparaissent bien sur ma RC (Betaflight ou Emuflight)

Modifié (le) par CriTof
Lien à poster
Partager sur d’autres sites
il y a une heure, Joelamoule a dit :

as tu relancer la recherche de nouveaux capteurs sur ta radio aussi ?

Oui et toujours les deux mêmes....

il y a une heure, CriTof a dit :

Tout simplement, as tu chargé le bon script Lua Betaflight sur la micro SD de ta Taranis... ? 

Euh non cette manip ne me dit rien, mais je n'ai pas d'alerte SD sur la Taranis

Lien à poster
Partager sur d’autres sites
Il y a 1 heure, Attafr a dit :

Désolé Bonhomme, mais les j’ai fait ce que je pense que peut-être vous m’avez expliqué, donnes en général rien de bon....

As tu bien suivit l’ensemble de/des Tutos ?

Alors OUI le passage en F.Port peut TOUT résoudre ou pas...

As tu bien suivi le lien que je  t’ai donné de Oscar Liang?

à savoir pour une F4 !

If your F4 FC has built-in inverter for SmartPort pin, and you are using the original inverted S.Port signal, you should enter these instead:


set serialrx_halfduplex = OFF
set serialrx_inverted = ON
save

la connection via uninverted S.Port ?

et enfin un TX free ?

Oui j'ai suivi à la lettre, j'ai soudé sur le SmartPort Un-inverted sur le R-XSR, et rentré les commandes dans le CLI. Mais rien à faire, toujours pas plus de télémétrie. Sur quel port dois-je activer la télémétrie dans BF ? Sur l'UART où j'ai mon Fport ? Ou sur un autre ? 

Lien à poster
Partager sur d’autres sites
Il y a 16 heures, Eluxas120 a dit :

Sur quel port dois-je activer la télémétrie dans BF

Tu ne définis que serialrx (uart3) et c’est bon ! Pas besoin de définir smartport...

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...