Jump to content
DroneBuilds
Juju66

betaflight F3 SP racing non reconnue

Recommended Posts

Bonjour,

j'ai un soucis avec ma fc. Je n'arrive pas à la faire reconnaître dans betaflight. Il me fait un échec d'ouverture du port série.

J'ai téléchargé les drivers avec Zadig, je la vois dans le gestionnaire de périphériques mais je ne sais pas comment la faire passer sur un port COM.

Je n'y entend pas énormément mais mon qx 65 eachine a été reconnu sans problèmes, mais cette F3, ni sur mon pc fixe, ni portable....

Ne me tapez pas dessus, je sais que la question a été abordée mais je ne trouve rien qui me sorte de là.

Merci  ✌️

Share this post


Link to post
Share on other sites

Heu salut à toi ! 

À tu télécharger les autres driver, sur l'interface de betaflight il t'explique les étapes et se que tu dois installer il y a Zadig, CP210x drivers et STM USB driver.

Il suffit que tu cliques sur les noms des drivers au niveau de l'interface et il te renvoie sur les sites pour les télécharger.

20180531_202426.jpg

Edited by Toinou

Share this post


Link to post
Share on other sites

Salut télécharge impulse RC tu le lance et seulement apres tu branche ta FC en bootloarder ! Tu sais comment on fait pour la mettre en bootloarder ? 

Share this post


Link to post
Share on other sites

Salut, c'est toujours pareil, avec plusieurs cables.

Zadig me dit que les derniers drivers ont bien étés installés, mais lorsque je lance impulse rc, il cherche la carte...et ça tourne , que ce soit en mode boot ou normal.

Share this post


Link to post
Share on other sites
Youtube WE are FPV

Alors les soucis de drivers ça peut être complexe avec windaube et les différents états.
Avec zadig il faut test 'USB Serial (CDC)' et 'WinUSB', ça va dépendre, et si tu es en mode boot (DFU) il se peut qu'il soit nécessaire de mettre un coup de zadig puis ensuite via le gestionnaire de périphériques que tu force le bon pilote (cas typique pour les STM32...).
En mode DFU avec du STM32 tu n'auras pas forcément de port COM à proprement parlé, mais le configurator le verra bien lui.

Bon courage, il faut ratisser et tester un max de possibilités.

Share this post


Link to post
Share on other sites
Salut, c'est toujours pareil, avec plusieurs cables.
Zadig me dit que les derniers drivers ont bien étés installés, mais lorsque je lance impulse rc, il cherche la carte...et ça tourne , que ce soit en mode boot ou normal.
Pour que cela fonctionne lance impRC et après qq seconde connecte ton drone

Share this post


Link to post
Share on other sites

Un petit peu de nouveau. A présent sur le pc fixe, j'ai installé le driver  'USB Serial (CDC)' .

lorsque je branche la carte, BF affiche COM4 (alors qu'avant ça réagissait pas) mais échec d'ouverture du port série, et je ne peux pas flasher le nouveau programme.

J'ai lancé impulse rc, après quelques secondes, j'ai branché ma carte....beh "searching for flight controller"

Edited by Juju66

Share this post


Link to post
Share on other sites

Quand tu veux flasher la board est reboot en mode `boot` vérifie à ce moment là que le driver est bien installé et reconnu.
Si tu as mis en mode `boot` manuellement alors sélectionne l'option indiquant de ne pas reboot en mode `boot`.

Share this post


Link to post
Share on other sites

Hello, en réinstallant les différents drivers pour la 20eme fois, la carte fonctionne bien sur le pc portable en USB serial.... Je saurais pas trop expliquer comment ça se fait.J'ai installé le dernier firmware, ça me permet de poursuivre le montage.

Merci à tous pour votre aide.

Share this post


Link to post
Share on other sites

Dommage car moi je suis bloqué là...12h que je suis là dessus impossible de trouver une solution. J'ai tout essayé, j'ai flashé, j'ai fait toutes les procédures zadig, impulse RC, rien ne me donne un com 6 avec une connection. Ma Matek f405 est bien reconnue mais dans l'onglet tablette graphique...??? avec Zadig je l'ai donc déplacé en port com et ma matek arrive bien en com 6, reconnue par betaflight mais echec de connection et dans l'explorateur windows rencontre bien le driver mais à un problème pour l'installer (car il y a un petit triangle jaune cette fois), betaflight rencontre donc le meme probleme sur le com 6 et la connection ne se fait pas. 

J'ai bien sûr mis à jour les firmwares en mode boot, mais rien ne change.

Quelqu'un peut-il me sortir de cette impasse infranchissable?

J'ajouterai aussi que j'ai une led bleu clignotante et une rouge en fixe sur ma carte si quelqu'un connait la signification je prends aussi.

Merci.

Share this post


Link to post
Share on other sites

La solution est que c'est un problème d'installation de pilote windows le pilote STM usb ne prend pas le pas sur ce qu'a décidé windows, pareil pour celui d'origine Matek. Du coup il est bien reconnu mais ne s'installe pas correctement. J'ai donc sorti mon vieux portable et là...Le STM fonctionne à merveille et betaflight se connecte. Alors si un jour quelqu'un à ce problème, après avoir fait toutes les procédures de dépannage, reboot, installation désinstallation, réinstallation de pilotes pas la peine de perdre 4 jours à chercher la bête, mieux vaut passer par un autre ordinateur.

Bon vol. 

Edited by JMD
Ortho

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...