Aller au contenu
DroneBuilds
Samy459

betaflight Matek F405 / Piste arrachée

Messages recommandés

Bonjour, voilà ma mésaventure ... le WE dernier je soude ma PDB Matek F405CTR, je fais mes premiers réglages sur BF et remarque que je n'ai pas la ligne SOFTSERIAL1 ! Bon je suis débutant et ne m'alarme pas plus que cela. Je fais un premier essai au terrain du club aéro en visuel, armement , décollage à 2m du sol bon ok! au deuxième essai, erreur du débutant ... je me plante.... bon...

Antenne mal placée arrachée par une hélice. Donc failsafe je pense et au tapis.

La semaine de boulot passe et ce samedi je me penche sur la bestiole. Après examen je m’aperçois que le pin TX2 est décollé ............. Dommage pour moi.

Le site (en france) d'achat est fermé le samedi donc je verrai lundi.

Question 1. cela est il déjà arrivé à l'un d'entre vous ? Piste arrachée alors que ma soudure n'est pas trop dégueulasse à mon avis, en plus j'utilise des pannes de différentes grosseurs en fonction du plot à souder

Question 2 ; je pense que le TX2 va sur le pin de droite de la puce ARM quelqu'un peut il vérifier sur une PDB identique (testeur car shéma pas trouvé), ET selon la réponse SAV du site lundi je pense tenter une soudure directe sur l'ARM?

Merci de vos retours.

Je suis débutant mais pas trouvé l'info avec la recherche ....

Sam

F405CTR Soudure.jpg

Modifié (le) par Samy459

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui plusieurs fois ! dernièrement c'était sur le + lipo des esc hobbywing 4en1 45A...

Chauffé trop longtemps et/ou trop fort (trop de fois dans mon cas), d'ailleurs tu n'a pas assez d'étain !

Commence par étamer le pad, généreusement sans que çà déborde, tu dois avoir une presque demi-sphère, tu étame rapidement le bout de ton fil juste histoire d'avoir l'étain sur toute sa surface et encore plus vite si les fils ne sont pas en silicone car sinon la gaine fond.

Je conseil 330 350° pas plus (sauf pour les grosses puissance comme sur parties lipo, alimentation et câbles moteurs car il y d'épaisses et grandes pistes de cuivre qui suivent derrière et qui absorbe énormément la chaleur)

Tu n'as plus qu'as posé ton fil sur la soudure déjà prête, tu pose le fer dessus et quand tu aura le coup de main, çà prendra moins d'une demi-seconde !

Et de cette manière tu répartie la chaleur sur 2 intervalles de temps et donc çà chauffe moins et c'est bien plus facile ! Et joli !

a.JPG

Partager ce message


Lien à poster
Partager sur d’autres sites
Youtube WE are FPV
il y a une heure, Cc La Fleche a dit :

Oui plusieurs fois ! dernièrement c'était sur le + lipo des esc hobbywing 4en1 45A...

Chauffé trop longtemps et/ou trop fort (trop de fois dans mon cas), d'ailleurs tu n'a pas assez d'étain !

Commence par étamer le pad, généreusement sans que çà déborde, tu dois avoir une presque demi-sphère, tu étame rapidement le bout de ton fil juste histoire d'avoir l'étain sur toute sa surface et encore plus vite si les fils ne sont pas en silicone car sinon la gaine fond.

Je conseil 330 350° pas plus (sauf pour les grosses puissance comme sur parties lipo, alimentation et câbles moteurs car il y d'épaisses et grandes pistes de cuivre qui suivent derrière et qui absorbe énormément la chaleur)

Tu n'as plus qu'as posé ton fil sur la soudure déjà prête, tu pose le fer dessus et quand tu aura le coup de main, çà prendra moins d'une demi-seconde !

Et de cette manière tu répartie la chaleur sur 2 intervalles de temps et donc çà chauffe moins et c'est bien plus facile ! Et joli !

 

Oui pas évident de souder sur de petit PAD, et dans ce cas j'utilise une panne en pointe fine et t° réglée sur 400°... peut être trop fine et trop chaud alors.

Merci de ta réponse.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 20 heures, Samy459 a dit :

je pense que le TX2 va sur le pin de droite de la puce ARM quelqu'un peut il vérifier sur une PDB identique (testeur car shéma pas trouvé), ET selon la réponse SAV du site lundi je pense tenter une soudure directe sur l'ARM?

Huuummm toi t'es chaud !!!!!

Bon, si jamais tu tentes l'aventure (à tes risques et périls...), je préconise de trouver un fil vraiment très très fin (fil émaillé par exemple), de le fixer sur le 'corp' du CPU pour qu'il tienne naturellement en place le temps de le souder, puis enfin, de ressouder ta connexion à l'autre bout du fil émaillé et d'abuser d'un peu de 'pistocolle' pour faire la tenue mécanique.

 

Sinon, dans https://github.com/betaflight/betaflight/blob/master/src/main/target/MATEKF405/target.h...

#define USE_UART2
#define UART2_RX_PIN            PA3
#define UART2_TX_PIN            PA2

et ailleurs sur le web http://waijung.aimagin.com/package_footprint.htm 

hmfile_hash_0f62a7f9.jpg

ou
hmfile_hash_b8763f66.jpg

je sais pas si c'est un 64 ou 100 pins.. ou même 144

PA2 semble toujours au même endroit, sur le coté, une chance pour toi 😛 

Mais bon, si ta piste arrachée est liée à une soudure pas optimale, retenter de mapper ce TX2 sur un autre UART est peut-être un peu moins casse gueule 😄 (Ceci dit, j'adhère totalement à l'idée de faire 'une greffe' !! )

  • Haha 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui je suis chaud pour une opération de ce type ! et j'adore et reconnait après coup le fait de ma soudure pas optimale.

Après recherches je confirme que c'est un 64 pins et j'avais vu le PDF avec le LQFP64, maintenant tu me conforte avec cette histoire de PA2. Mais avant d'arriver à la programmation

#define USE_UART2 #define UART2_RX_PIN PA3 #define UART2_TX_PIN PA2

j'ai déjà du mal à finir ma config et surtout que je n'ai pas encore mis à jour le microprogramme ...

je vais tenter le coup de fer sur le PA2                      MOUAHAHAH

Je vous tiens au courant .....

Merci de votre implication ce site est surper !

Partager ce message


Lien à poster
Partager sur d’autres sites

Soudure faite sur le PA2 et  Yes cela fonctionne...

..... Rien n'y change ..... toujours pas de SOFTSERIAL 1 ???

 

image.png

Modifié (le) par Samy459

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 6 heures, Samy459 a dit :

Mais avant d'arriver à la programmation

#define USE_UART2 #define UART2_RX_PIN PA3 #define UART2_TX_PIN PA2

j'ai déjà du mal à finir ma config et surtout que je n'ai pas encore mis à jour le microprogramme ...

Ça, c'est le code source de Betaflight, tu n'as pas à y toucher, c'est juste la déclaration qui est faite 'd'origine' 😉

 

 

Une p'tite photo de la micro chirurgie...?

Partager ce message


Lien à poster
Partager sur d’autres sites

Bien propre, joli !!!

Là, clairement, un peu de pistocolle par dessus pour garantir une tenue mécanique, et en avant 😉

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour, question con : pourquoi ne pas avoir mis sur un autre TX? Et remapper celui-ci.

Envoyé de mon Nexus 9 en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×