Aller au contenu
drone débutant pas cher
dim62800

problème récepteur / télécommande sous BF

Messages recommandés

bonjour à tous je construis actuellement drone tout premier drone FPV, 

je me permets de créer un topic car je suis arrivé à la configuration du drone sous BF cependant le problème intervient lorsque je vais dans l'onglet "recepteur" de BF puisque ma Taranis qx7 ne fait bouger en aucun cas les différents segments alors que mon RXSR est bien bindé puisqu'une lumière jaune reste allumé lorsque j'allume ma télécommande. 

je suis équipé d'une FC Matek F405 CTR 

 

alors je ne sais pas si ca provient de ma telecommande ou de mon paramétrage, pleasse help me 

 

voici quelques captures 

 

 

Capture.PNG

Capture1.PNG

Capture3.PNG

Partager ce message


Lien à poster
Partager sur d’autres sites

salut

il me semble que si tu n'as pas de lumière bleue, tu n'es pas en sbus. modif à faire de memoire: appui long sur rx quand allumé, puis re bind. Ou changer parametre dans l onglet config

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

merci de votre aide à tous, d'après le schéma de la FC je suis sur les bonnes connectiques (je précise que mon fil blanc n'est pas soudé donc seuls les vert, jaune, rouge et noir le sont) 

comment verifier si je ne suis pas en cppm ? 

d'après matek je suis en UART 2 donc oui et oui j'ai essayé en branchant la lipo, ca ne viendrait pas de la telecommande avec les mixer etc ? 

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 14 heures, dim62800 a dit :

comment vérifier si je ne suis pas en cppm ?

Récepteur allumé, appuie (ou reste appuyé 1sec je sais plus) sur le bouton de bind

Le branchement R-xsr + la manip softserial pour faire fonctionner le smartport sont expliqués ici

Modifié (le) par toper

Partager ce message


Lien à poster
Partager sur d’autres sites

De ce que j'ai lu, selon si ton recepteur est "inverted", le pin sur quoi tu es soudé doit, lui, être "uninverted" et vice versa

 pour sbus out, c est le bon, mais tu pourrais avoir inversé les soudures de s-port et sbus? car s-port ne commande pas les voies de pilotage

Modifié (le) par Doug

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 17 heures, dim62800 a dit :

quand j'appuis sur le bouton du Bind seul le bouton vert clignote puis une led rouge cligonte pour revenir à une led verte et bleue constante

led fixe verte + bleue,tu es en sbus, et bindé.

pour ma part, au moment de binder en d16 j'ai dû réduire le nombre de voies à 8 (sur la ligne "ch1-16"). La notice du rxsr montre page 2 l'écran de la taranis avec 8 voies seulement.

je ne sais pas si ça venait du tx ou du rx(je pense que la fc ne joue pas là dessus?!).Et bizarrement ma radio affiche ch1-16 maintenant. La notice du rxsr montre 8 voies sur l'écran de la taranis. 

As-tu bien créé tes entrées? normalement elles s'installent a la création du modèle,mais bon.. 

Et même bindé, si tu n'as pas créé de mixage(attribution entrée/manche) la taranis n'envoie rien.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir à tous,

J'ai le même problême que dim62800, avec un r-xsr, et une Matek F405-STD.

Je suis bien bindé avec ma Qx7 (led vert et bleue sur le r-xsr).

le bon UART 2 dans Betaflight et choix du SBUS.

Moi j'ai utilisé la méthode du SoftSerial.

Si vous avez une solution.

Merci d'avance.

Pat 

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 8 heures, Doug a dit :

led fixe verte + bleue,tu es en sbus, et bindé.

pour ma part, au moment de binder en d16 j'ai dû réduire le nombre de voies à 8 (sur la ligne "ch1-16"). La notice du rxsr montre page 2 l'écran de la taranis avec 8 voies seulement.

je ne sais pas si ça venait du tx ou du rx(je pense que la fc ne joue pas là dessus?!).Et bizarrement ma radio affiche ch1-16 maintenant. La notice du rxsr montre 8 voies sur l'écran de la taranis. 

As-tu bien créé tes entrées? normalement elles s'installent a la création du modèle,mais bon.. 

Et même bindé, si tu n'as pas créé de mixage(attribution entrée/manche) la taranis n'envoie rien.

alors non justement je n'ai pas créé mes entrés/manche etc et je ne sais pas comment procéder, peux tu m'expliquer ? 

je viens egalement de réduire le nombre de voies et rien ne se passe.. 

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 23 heures, Joelamoule a dit :

Mon conseil : flash ton RX avec dernier firmware voir passer même en protocole Fport au lieu du sbus, et une fois fait reprend la notice rx

le problème c'est que je ne dispose pas du cable pour relier le RXSR avec la taranis 

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 22 heures, Doug a dit :

De ce que j'ai lu, selon si ton recepteur est "inverted", le pin sur quoi tu es soudé doit, lui, être "uninverted" et vice versa

 pour sbus out, c est le bon, mais tu pourrais avoir inversé les soudures de s-port et sbus? car s-port ne commande pas les voies de pilotage

oui j'avais vu un post à ce sujet, mais sans réelles explication, comment les inverser ? 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 55 minutes, dim62800 a dit :

oui j'avais vu un post à ce sujet, mais sans réelles explication, comment les inverser ? 

je dirais deja,savoir dans quel mode ils sont. tu lis l'anglais?

 

il y a une heure, dim62800 a dit :

 créé mes entrés/manche

pour creer un mixage entrée/manche, il faut d'abord être attentif a l'ordre des voies,car risque de demarrage imprévu,et tailladage de doigts. Retire tes hélices,si pas deja fait, c'est pas, ou - dangereux.

Reste branché sur betaflight pendant tes tests, normalement ça désarme tes moteurs.

Ensuite, Il faut aller dans la page mixage, et ligne par ligne: 

 en commençant par ch1

click long sur entree, descendre sur source (c'est le manche ou inter que tu veux attribuer a la voie qui sort de la radio vers le récepteur), entrée court, bouger le manche a mettre dessus(commence par choisir le meme ordre que celui dans la page entrées). puis sortir et faire de meme pour ch2 ch3 ch4,pour avoir gaz aileron profondeur et direction dans le bon ordre,qui est fonction de ton affichage dans l onglet recepteur de betaflight. si l'ordre est pas le bon regarde dans ce meme onglet, y a ordre des voies et modifie en fonction de ce que tu vois sur les curseurs. attention au sens de correction,risques pour toi et pr le drone. regarde aussi dans betaflight pour attribuer une voie et un mixage a un inter pour l armement desarmement, et un autre pour activer le mode stable,si tu n'as pas la pratique. 

Je te conseille de bien lire la doc opentx /taranis, ainsi que le site github/betaflight, c'est mieux que mon roman! et y a tout

Modifié (le) par Doug

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 12 heures, dim62800 a dit :

le problème c'est que je ne dispose pas du cable pour relier le RXSR avec la taranis 

Normalement le rxsr est livré avec un cable pour faire des MAJ.

 

En gros sur les FC en F4 il n'y a qu'un seul inverseur, donc il faut soudé le petit pad sur le r xsr attention c'est tout petit !

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 3 heures, Joelamoule a dit :

Normalement le rxsr est livré avec un cable pour faire des MAJ.

 

En gros sur les FC en F4 il n'y a qu'un seul inverseur, donc il faut soudé le petit pad sur le r xsr attention c'est tout petit ! 

Bonjour Joelamoule,

Sinon on peut utiliser le softserial sans soudure sur le petit pad ? c'est d’ailleurs ce que j'ai fais, mais j'ai aussi le même souci.

Pour la MAJ du firmware du r-xsr, il faut prendre juste le F.port firmware et le flasher ?

J'ai aussi suivi le tuto https://youtu.be/gGG-Z2OgNv0  pour assigner les channels et le mixeur sur la qx7

Merci.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 50 minutes, redragon47 a dit :

Bonjour Joelamoule,

Sinon on peut utiliser le softserial sans soudure sur le petit pad ? c'est d’ailleurs ce que j'ai fais, mais j'ai aussi le même souci.

Pour la MAJ du firmware du r-xsr, il faut prendre juste le F.port firmware et le flasher ?

J'ai aussi suivi le tuto https://youtu.be/gGG-Z2OgNv0  pour assigner les channels et le mixeur sur la qx7

Merci.

J'avais essayé avec le softserial mais ça n'avait pas fonctionné, je m'étais donc résigné a souder le pad.

 

Pour la maj oui il faut une maj avec FPort mais attention si vous utilisez les scripts lua pour configurer le drone sur la taranis car j'ai un bug en bf 3.5.1 ils faut prendre la version bêta du Fport datant de septembre 2018 du firmware qui résout mon bug apparemment mais j'ai pas testé

Partager ce message


Lien à poster
Partager sur d’autres sites

@dim62800

commence déjà par le plus basique, les mixages, c'est le plus facile à faire et defaire

Modifié (le) par Doug

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...