Aller au contenu
DroneBuilds
geekmps

Betafligth sous Linux ubuntu

Messages recommandés

Hello 

Est-ce que quelqu'un a réussi à faire fonctionner betaflight via Chrome sous Ubuntu 16.10 ? Mon problème est de connecter le Furibee F90 (oui de Gearbest)

Que faut-il installer (drivers, lib )? 

Quel est le port à configurer sur l'interface betaflight ? 

Merci d'avance 

Jérôme 

Partager ce message


Lien à poster
Partager sur d’autres sites

Je le fait fonctionner sous Solus mais je ne sais pas si j'avais testé sur mon Ubuntu. Dès que j'ai fini de remettre sur pied mon ordi je test ça sur un live CD.

Partager ce message


Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Si je trouve un peu de temps et de motivation je ferai aussi l'essai en live CD, d'autant plus que j'ai aussi le FuriBee (enfin, pour ce qu'il en reste :D).

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci beaucoup, j'attends vos retours. J'ai bien l'impression que ce n'est qu'une question de drivers. Faut dire aussi le Furibee m'a l'air assez orignal. Cela dit, tant que je ne le configure pas bien, je ne peux pas débloquer les moteurs ... 

Partager ce message


Lien à poster
Partager sur d’autres sites

La blague du câble USB vous connaissez ? 

Après un bon moment, je me résous à passer sous Windows, Linux doit être le fautif. J'installe des drivers, redémarre, m'énerve contre les mises à jour de Windows etc... Mais rien de change, impossible de connecter la bête. Pourtant, lorsque je branche le câble USB, il y a une série de Beep. Parlant mal le beep, je pense que la connexion est OK. Après 1h d'effort, quelques heures de lectures de tutoriaux divers et varié. Je fini par me dire, je change le câble USB !!! Je prends un autre cable USB qui traîne sur le bureau, et là miracle, la carte SP RACING F3 EVO se connecte !!! Betaflight trouve le drone sans problème, je balance une mise à jour sur firmware en 3.1.1.

Maintenant, le problème vient du fait que je n'arrive pas à voir la la DEVO 7E sous Déviation 5.00. Le Bind avec le drone semble se faire correctement (y a plus de led qui clignote sur le drone). J'ai beau bouger les manettes, rien ne se passe ... une idée ? (après je repasse sous Linux :D ) 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon tant mieux pour ton câble, j'ai pas trouvé le temps de booter Linux sur une clef ^^

Le FuriBee est en SBus et normalement BF était bien configuré de base chez moi.

Par contre faut pas oublier de bind à chaque démarrage du Furi...

Et vérifier qu'Open TX est bien paramétré.

Partager ce message


Lien à poster
Partager sur d’autres sites

@DaDHoulà, aucune idée. Je vais étudier cela dès que j'ai un moment. Pour le moment, je connecte, c'est marqué COM3, lorsque je fais bouger le drone à la main, on le voit bouger à l'écran. Ensuite je vais sur receiver (je crois), lorsque je bouge les gaz rien de se passe. Sur le Devo, PPM est à None, pour le reste je n'ai rien fait.

@Motard Geek Il faut bind avant de connecter le USB ? (je crois que j'ai essayé les 2), Je vais donc regarder cette histoire de SBus

Merci pour vos précieux conseils (désolé d'être un noob en RC) 

Partager ce message


Lien à poster
Partager sur d’autres sites

hier soir j'ai essayé plusieurs trucs

Tout d'abord, j'ai changé le firmware avec betaflight, il me proposait le SP Racing F3 Evo (trouvé le nom dans la doc du Furibee)  puis version 3.xxx. Le firmware semble bien flashé.

En fait, je me demande si ce n'est pas une version modifié du SP RAcing F3 Evo, il se nomme SP Racing F3 EVO Brushed Flight Controller (si quelqu'un à une sauvegarde de l'original je suis preneur)

En revanche, j'ai beau faire me bind entre le transmetteur et le furibee F90, dans l'onglet receiver de betaflight, il ne se passe toujours rien. Dois je jouer avec le mixer ? 

Partager ce message


Lien à poster
Partager sur d’autres sites

Si la conf du Rx est bien faite sous BF tu devrais voir les canaux bouger. Si ça n'est pas le cas c'est que la radio est mal configurée.

J'ai laissé le firmware d'origine sur mon Furi, juste tuné les options :P Je mate ce soir de quelle version il s'agit.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

ayant voulu virer Windows de mon pc, j'essaie de faire tout se que je peux pour configurer nos drones sous linux (Ubuntu).

Alors pour la méthode qui a marcher de mon côté.

- installer chromium : sudo apt-get install chromium-browser

- dans chromium installer betaflight (les drivers sont inclus apparement) 

- Quelques lignes de code sous terminal plus loin et ca marche...

je détail : ( copier-coller du wiki de betaflight) ca fonctionne nickel ;-)

Linux requires udev rules to allow write access to USB devices for users. The command bellow will create a template rule for you.

(echo '# DFU (Internal bootloader for STM32 MCUs)'
 echo 'ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="0483", ATTRS{idProduct}=="df11", MODE="0664", GROUP="plugdev"') | sudo tee /etc/udev/rules.d/45-stdfu-permissions.rules > /dev/null

Now you need to find the real product id of your FC. Type in the command bellow and plug your FC in and out. It should print a line with the product id out.

udevadm monitor --environment --udev | grep ID_MODEL_ID

Now update the entry in "/etc/udev/rules.d/45-stdfu-permissions.rules" accordingly. You can add more than one rule in the file. The default product id is the FC in bootloader mode. Then reload rules using:

sudo udevadm control --reload-rules && udevadm trigger

You can then test the rule using when your FC is plugged in:

udevadm test $(udevadm info -q path -n /dev/ttyACM0)

Ensure line "MODE 0664 /etc/udev/rules.d/45-stdfu-permissions.rules" is present

This assigns the device to the plugdev group(a standard group in Ubuntu). To check that your account is in the plugdev group type groups in the shell and ensure plugdev is listed. If not you can add yourself as shown (replacing with your username):

sudo usermod -a -G plugdev <username>

If you see your ttyUSB device disappear right after the board is connected, chances are that the ModemManager service (that handles network connectivity for you) thinks it is a GSM modem. If this happens, you can issue the following command to disable the service:

sudo systemctl stop ModemManager.service

If your system lacks the systemctl command, use any equivalent command that works on your system to disable services. You can likely add your device ID to a blacklist configuration file to stop ModemManager from touching the device, if you need it for cellural networking, but that is beyond the scope of cleanflight documentation.

If you see the ttyUSB device appear and immediately disappear from the list in Cleanflight Configurator when you plug in your flight controller via USB, chances are that NetworkManager thinks your board is a GSM modem and hands it off to the ModemManager daemon as the flight controllers are not known to the blacklisted

Bonne journée Yves

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×