Aller au contenu
DroneBuilds

Roll qui se décale tout seul


Bll06
 Share

Messages recommandés

Bonjour,

Sur mon iflight Megabee tout neuf, j'ai le roll qui se décale tout seul petit à petit dés que j'arme les moteurs (sans les faire tourner).

En vol c'est comme si le trim se modifiait. Il s'incline tout seul doucement et de plus en plus.

Dans les lunettes, en laissant le quad posé à plat,  l'horizon artificiel va s'incliner de la même manière petit à petit. Si je désarme les moteurs il revient à l'horizontale.

Sur la copie d'écran (blackbox) on peut voir les courbes PID p (roll) et pid error qui s'écartent. Le drone est posé à plat, je ne touche pas les commandes et les courbes gyro ne bougent pas, les accéléromètre non plus.

Je ne comprends pas ce qui se passe. Si quelqu'un à une idée...

D'avance merci.

 

log Megabee.jpg

Lien vers le commentaire
Partager sur d’autres sites

J'avais pas vu mais sur la photo du graph que tu as posté ton axe du roll est à -3 au lieu de 0.

C'est ça qui te fait pivoter lentement. 

Ta radio envoie un ordre sur le roll. 

Puisque les trims sont à 0, regarde le réglage des subtrims. 

Si c'est pas ça je te conseille de chercher d'où peut venir ce décalage en fouillant les réglages de ta radio. 

Lien vers le commentaire
Partager sur d’autres sites

J'ai mis tous les trims et subtrim à 0. Ma radio est une QX7 et j'ai les mêmes paramètres que sur mes autres modèles.

Le problème est toujours là...

J'ai refais un log, je pense que c'est le gyro qui se décale. Sur le graph il passe à 4deg/s à l'armement et augmente doucement jusqu'a 8 alors que le drone est à l’arrêt posé à plat. Mais alors pourquoi ne se décale t'il que lorsque les moteurs sont armés ?

Les esc qui parasitent le gyro ? 

 

video https://youtu.be/B9woBoXmeXM

Modifié (le) par Bll06
video
Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV

Là je voudrais bien t'aider mais je sèche... 

Si j'ai une idée je reviendrai vers toi. 

Si tu t'y connais en filtre vérifie qu'ils ne laissent pas trop passer de parasites. 

Si tu as des pics de parasites, je sur quelles fréquences sont ils ? 

Avec les fréquences on pourra peut être avancer un peu 😉

Modifié (le) par Lioneldg
Lien vers le commentaire
Partager sur d’autres sites

Oui. 

En regardant tes logs on voit que le RC command du roll reste à 1500 et que c'est le gyro qui se decale tout seul. 

Donc effectivement le problème est dans la FC.

Je dirais aussi que le gyro est mort mais il serait bon de vérifier les filtres avant de se prononcer. 

Sauf si ça marchait avant et que la panne est arrivée soudainement sans modification matérielle ou logicielle. Car dans ce cas c'est sûr que ce serait le gyro. 

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
 Share

×
×
  • Créer...