Aller au contenu
acheter lipo ovonic pas chère
DroneBuilds

montage led avec buzzer et GPS BN-220 sur Nazgul5 6s


Chanmard

Messages recommandés

Bonjour,

Je viens vers vous afin d'être sûr de ne pas me tromper sur le soudage de ma carte Matek WS2812B LED avec Buzzer ainsi que du GPS BN-220.

J'ai trouvé une fiche technique pour le buzzer mais je ne sais pas si je suis en TX, FC ou TX FC...

J'ai la version du Nazgul5 6S avec le R-XSR

Je met des photos des articles ainsi que de ma carte afin de facilité l'explication ^_^

Merci d'avance

20200309_170909.thumb.jpg.92b49b292077a01f49ae5f9f101a588a.jpg20200309_171023.thumb.jpg.d1bd6f65ea8e4d28c9738c10bc84fa94.jpg20200309_170918.thumb.jpg.9c333383dad4a7fb7818fb61b3e75a7c.jpg2812-BH_Manual_EN.pdf

Lien vers le commentaire
Partager sur d’autres sites

Merci beaucoup pour ta réponse tu m'enlèves un grosse épine du pied pour moi, c'est la 1ère fois que je vais souder sur mon drone et avant de souder j'ai préféré être sûr ayant vu plusieurs possibilitées sur leur fiche 😃

Par contre pour le gps sais tu ou je dois le brancher ? pourrais je le mettre en doublon sur un 5V n'ayant plus de 5V dispo après ?

Bon week end à toi 😉

Lien vers le commentaire
Partager sur d’autres sites

Pour le gps, tu peux le mettre en T1 et R1 en inversant : tx sur R1 et Rx sur T1. Ensuite sur BF, tu notes en UART1 le gps.  Normalement ça doit fonctionner 👍. N’hésites pas si ça fonctionne pas 😉. Pour le 5v, pas de soucis 😇
Hervé 😎

Modifié (le) par Rv83600
  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

J'ai enfin fini la soudure c'est pas top mais cela fait le taf... Je me souvenais pas que cela était aussi compliqué surtout seul !!! bon ok cela fait 20 ans que j'avais pas soudé 😁

tout s'allume correctement c'est déjà une bonne chose par contre le gps ne fonctionne pas.

j'ai été dans betaflight pour l'activé mais cela ne fonctionne toujours pas voici ce que j'ai ( sachant que le vtx était déjà positionné en uart1 mais même en le positionnant sur le uart3 cela fonctionne)😅

j'ai aussi test les 2 protocoles gps sans succes.

20200318_122530.thumb.jpg.dca84e5bd73dbfc4c6321e1ac39b5562.jpgconfig.thumb.jpg.f0bf33089bbfff7aab3f80fe1acc2311.jpg20200318_130639.thumb.jpg.46a5002712c4fda92078ac7705052405.jpgport.thumb.jpg.df2f1afac27c69ceb9a7f05c5a696b01.jpg

Lien vers le commentaire
Partager sur d’autres sites

Le GPS est il déjà sous tension (led) quand tu alimentes ton kwad ? (Un + 5v et une masse -)

As tu bien mis le fil RX du GPS sur le pad TX de ta FC ? (UART 1 semble t'il) 

As tu bien mis le fil TX du GPS sur le pad RX de ta FC (toujours su le même UART 1 )

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

oui j'ai une petite led rouge qui clignote en "pps" mais pas celle du "tx" mais je sais pas si c'est normal...

Je pense qu'il le reconnait sous betaflight car c'est lui qui le met directement en 57600 lorsque je met automatique.

J'ai entouré mes branchements sur la fc lorsqu'elle était encore belle 🤣 en me basant sur cette photo. J'ai juste mis sur le GND d'en face car je n'arrivais pas à le faire tenir en le mettant en double avec celui du buzzer/ led

769646941_codecouleurgps.thumb.jpg.1367a1f92d263b54903bde50f62a6c21.jpg134078155_branchementgps.thumb.jpg.b8dffc36d268543dbd18d0ffdd64745d.jpg

Lien vers le commentaire
Partager sur d’autres sites

et cela me met ca lorsque je fais get gps :

# Building AutoComplete Cache ... Done!
#
# get gps
gps_provider = UBLOX
Allowed values: NMEA, UBLOX, MSP
Default value: NMEA

gps_sbas_mode = AUTO
Allowed values: AUTO, EGNOS, WAAS, MSAS, GAGAN

gps_auto_config = ON
Allowed values: OFF, ON

gps_auto_baud = ON
Allowed values: OFF, ON
Default value: OFF

gps_ublox_use_galileo = OFF
Allowed values: OFF, ON

gps_set_home_point_once = OFF
Allowed values: OFF, ON

gps_rescue_angle = 32
Allowed range: 0 - 200

gps_rescue_initial_alt = 50
Allowed range: 20 - 100

gps_rescue_descent_dist = 200
Allowed range: 30 - 500

gps_rescue_ground_speed = 2000
Allowed range: 30 - 3000

gps_rescue_throttle_p = 150
Allowed range: 0 - 500

gps_rescue_throttle_i = 20
Allowed range: 0 - 500

gps_rescue_throttle_d = 50
Allowed range: 0 - 500

gps_rescue_velocity_p = 80
Allowed range: 0 - 500

gps_rescue_velocity_i = 20
Allowed range: 0 - 500

gps_rescue_velocity_d = 15
Allowed range: 0 - 500

gps_rescue_yaw_p = 40
Allowed range: 0 - 500

gps_rescue_throttle_min = 1200
Allowed range: 1000 - 2000

gps_rescue_throttle_max = 1600
Allowed range: 1000 - 2000

gps_rescue_throttle_hover = 1280
Allowed range: 1000 - 2000

gps_rescue_sanity_checks = RESCUE_SANITY_ON
Allowed values: RESCUE_SANITY_OFF, RESCUE_SANITY_ON, RESCUE_SANITY_FS_ONLY

gps_rescue_min_sats = 8
Allowed range: 5 - 50

gps_rescue_min_dth = 100
Allowed range: 50 - 1000

gps_rescue_allow_arming_without_fix = OFF
Allowed values: OFF, ON

gps_rescue_use_mag = ON
Allowed values: OFF, ON

frsky_gps_format = 0
Allowed range: 0 - 1

osd_warn_no_gps_rescue = ON
Allowed values: OFF, ON

osd_warn_gps_rescue_disabled = ON
Allowed values: OFF, ON

osd_gps_speed_pos = 14425
Allowed range: 0 - 15359
Default value: 234

osd_gps_lon_pos = 234
Allowed range: 0 - 15359

osd_gps_lat_pos = 2282
Allowed range: 0 - 15359
Default value: 234

osd_gps_sats_pos = 14336
Allowed range: 0 - 15359
Default value: 234

Lien vers le commentaire
Partager sur d’autres sites

enfin tt fonctionne !!!!🤩

Avant toute chose un GRAND GRAND merci à CriTof pour son aide via message pour toute son aide afin de resoudre mon problème car cela n'a pas été facile pour moi mais je pense pour lui aussi 🤣

j'ai isolé le branchement du gps aussi bien pour le 5V que le G et regroupé le 5v buzzer/led et G du buzzer/led.

J'ai aussi refait tte mes soudures sur le buzzer/led car elles étaient vraiment pas belle non plus...😅

J'ai été voir sur betaflight en effet je peux pas changer la couleur des LED mais bon cela me l'affiche en orange ca change aussi !!!! et tout le reste fonctionne et j'ai enfin le gps d'affiché sous betaflight....

Donc a retenir pour le GPS ( si lors du branchement il y a que la led du pps qui clignote en rouge (de facon non régulière d'ailleurs) c'est le voltage (soit le 5V ou le G) qui pose problème car les seul soudures que je n'ai pas touché c'est celle du TX et RX 😉

Voila les amis encore merci à tous et bon vol (lorsqu'on pourra bien sur 😔 )

Pour le moment je m'entraine chez moi avec mon beta85X HD j'ouvre toute les fenêtre et rentre et sort en faisant le tour de la maison !!! 😍

Voici une photo de ma FC finale

20200325_140134.thumb.jpg.e902cb9dbf0e631605079ca3c920995b.jpg20200325_140144.thumb.jpg.40e7d68d0bf6e2a0149639bb70ccb058.jpg

20200325_152738.thumb.jpg.3bef325e23f411fc91c4c828078499cc.jpg

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

  • 10 months later...

Bonjour !

Je me pose que question en lien avec cette discussion. Est-il possible de regrouper différents pad ? Par exemple mettre deux GND ensemble ou deux 5V ensemble ? Et le faite de mettre une soudure sur l'un ou l'autre des pad GND et le 5V sur un pad de l'autre côté de la carte ne change rien ?

Merci d'avance !

Lien vers le commentaire
Partager sur d’autres sites

  • 2 weeks later...
Le 01/02/2021 at 21:11, MAPL a dit :

Bonjour !

Je me pose que question en lien avec cette discussion. Est-il possible de regrouper différents pad ? Par exemple mettre deux GND ensemble ou deux 5V ensemble ? Et le faite de mettre une soudure sur l'un ou l'autre des pad GND et le 5V sur un pad de l'autre côté de la carte ne change rien ?

Merci d'avance !

Oui tu peux regrouper differents pads... Pour les masses (Ground) sans problème. Masse que tu peux aussi aller chercher directement sur le - du pad d'alimentation général.

. Pour les alimentations (+), tu respecteras ce à quoi ils sont dédiés (question d'ampérage). Le + 5V par exemple pour la Cam est par principe mieux filtré. Si tu n'as pas de leds installées le 5V de ce dernier pourra te servir pour un autre peripherique (GPS par exemple). Mais dans le principe un seul + par pad .

Et évidement, tu pourras aller chercher le + et - à l'autre bout de ta FC. Pour disposer surtout d'un regroupement propre de ton câblage  là ou ils seront affectés sur ta FC (Un +, un - , un fil signal, par principe)

Modifié (le) par CriTof
Lien vers le commentaire
Partager sur d’autres sites

  • 1 month later...

Tiens, ça m'intéresserait d'avoir vos réglages au niveau GPS rescue sur le Nazgul 5 (le mien est en 4S mais ça ne doit pas changer tant que ça) car j'ai visiblement trop peu de gaz (de mémoire j'ai réglé le niveau à 1200 et il n'arrive pas à se maintenir en altitude à cette valeur). Je retrouve mes settings et edit ce message.

Au passage, j'ai fait un test en poussant un peu le VTX (jusqu'alors j'avais jamais dépassé le 25mV) et j'atteins 450m sans problème, c'est déjà beaucoup pour moi mais c'est chouette de voir qu'on a un quad qui serait capable de voler en long range en fait (oui pour moi au delà de 200m c'est déjà du long range! [emoji28]). 0998e5f435fa7f5e1b122167a377e495.jpg

Lien vers le commentaire
Partager sur d’autres sites

il y a 9 minutes, PsK a dit :

c'est déjà beaucoup pour moi mais c'est chouette de voir qu'on a un quad qui serait capable de voler en long range en fait (oui pour moi au delà de 200m c'est déjà du long range! emoji28.png). 

Mid range pour être précis 😉

J'ai juste modifié dans les réglages, 5 sat acquisition et la hauteur à 40m au déclenchement. Cela me semble être parfait là ou je vole en général. 

Modifié (le) par CriTof
  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

Merci!
Je viens de monter un peu les gaz en maintien, j'avais 1250 mais je le sentais "chuter" puis remettre un coup de gaz pour maintenir l'altitude en mode rescue. Peut être trop peu pour du 4S. On verra bien ce que ça donne à 1400 (sûrement un poil trop, je peaufinerai on the track).

 

 

Capture d’écran 2021-03-21 213851.png

Lien vers le commentaire
Partager sur d’autres sites

  • 3 months later...
Le 18/03/2020 at 22:57, Chanmard a dit :

oui j'ai une petite led rouge qui clignote en "pps" mais pas celle du "tx" mais je sais pas si c'est normal...

Je pense qu'il le reconnait sous betaflight car c'est lui qui le met directement en 57600 lorsque je met automatique.

J'ai entouré mes branchements sur la fc lorsqu'elle était encore belle 🤣 en me basant sur cette photo. J'ai juste mis sur le GND d'en face car je n'arrivais pas à le faire tenir en le mettant en double avec celui du buzzer/ led

769646941_codecouleurgps.thumb.jpg.1367a1f92d263b54903bde50f62a6c21.jpg134078155_branchementgps.thumb.jpg.b8dffc36d268543dbd18d0ffdd64745d.jpg

salut j'ai effectuer du coup le meme branchement sur mon V2 du coup le gps est sur l'uart 1 mais quand je regarde la doc le vtx aussi est brancher sur l'uart 1 apparement  et pourtant tout fonctionne vtx et gps c'est normal? voiçi la doc 

doc fc.png

Lien vers le commentaire
Partager sur d’autres sites

  • 1 month later...
  • 7 months later...

Hello,

Dsl j'ai une question en rapport avec le GPs et le Nazgul5.

J'ai également un Nazgul5V2 mais en 6S et j'ai installé le GPS, ma question est de savoir si on a un indicateur pour revenir au point de départ ?

Dans bétaFlight j'ai pas vue l'information dans L'OSD, est-ce que c'est possible car j'ai vu des OSD (non DJI) avec le retour au point de départ.

Par contre j'ai trouvé les informations pour la vitesse, altitude, distance, boussole et je crois que c'est tout!

Moi je voulais voler sans risque de me perdre, dans certain zone tu décolle et tu te sent perdu direct^^ tout se ressemble aucun point de repère familier !!!

Alors j'ai acheté un GPS en me disant que c'est rassurant je peux aller voler tout seul et pas me perdre 🙂

 

Merci d'avance pour ton retour,

Lien vers le commentaire
Partager sur d’autres sites

Oui tu as dans l'OSD la possibilité de voir le point de départ indiqué par une flèche cela indique au moment ou ton GPS capte donc bien attendre avant de décoller si tu veux que cela soit cohérent !!! ( voir plus haut une photo de PSK de son OSD il la mis en dessous de Nazgul5 😉 )

Lien vers le commentaire
Partager sur d’autres sites

@Def Oui pas de soucis. 

C'est à activer d'une part dans l'onglet config du GPS et d'autre part dans l'onglet OSD. 

@Chanmard a tout dit: surtout bien attendre que le point home soit à zéro (mètre)  pour décoller. 

Sinon si tu pars avant, il prendra son repère home au moment où il se sera activé en cours de vol... 

As tu bien le symbole GPS d'allumé en haut du configurateur, quand tu le branches ? Et pour info il sera casi certain que tu n'accroches aucuns sat en étant chez toi. 

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...