Aller au contenu
DroneBuilds

Pas d'input dans betaflight (Ch1 et 2 ok, cablage ok)


Messages recommandés

Bonjour a tous, j'ai recement acheté un flywoo explorer avec une tango 2 et un masque DJI,

Avant de faire mon premier vol je voulais checker que tout etait bien parametrer dans betaflight et reperer quel switch fait quoi (c'est mon premier quad).

J'ai donc lancé betaflight apres avoir bindé ma tango, tout fonctionnais bien (en l'occurence je voyais mes inputs dans betaflight) mais impossible de l'armer a cause du GPS, je voulais donc desactiver la securité qui empeche d'armer s'il y a pas 5 gps locked, je ne trouvais pas comment faire et la j'ai eu la pire idée qui m'a fait entrer dans ce cauchemar, j'ai utiliser le CLI de Joshua Bardwell (qui a une config bizarre avec tout les AUX sur un AUX). Depuis que j'ai fait ca impossible de retrouver des inputs dans betaflight, pour essayer de regler ce pb j'ai essayé plusieurs choses :

- Reflasher le firmware fourni par flywoo + CLI fournis par flywoo

- Flasher en 4.2.5 (celui de flywoo est en 4.1.1) + CLI flywoo

A chaque fois je remettais le crossfire dans betaflight mais toujours aucun input.

Je precise aussi que depuis que j'ai mis le CLI de Bardwell la tension en USB dans betaflight et tres variable en 5 et 6.5v en 2s et la meme chose avec une lipo branché, j'ai aussi essayé de checker si j'avais toujours un retour video dans les DJI, ca marche mais j'ai pas d'OSD

 

Cablage OK,

Output 1 - CRSF TX

Output 2 - CRSF RX

Nano RX - led verte continue

 

 

Ca fait litteralement 2 jours que je passe ma journée a chercher une solution sur internet, je trouve rien qui colle avec mon cas, si quelqu'un peut m'aider je lui serais extremement reconnaissant :)

 

Dump.txt diff all.txt

Lien à poster
Partager sur d’autres sites
  • Réponses 77
  • Created
  • Dernière réponse

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Effectivement, ça ne va pas au niveau des ports. Uart 1 : crsf ok Uart 2 on devrait avoir le msp Le gps sur le softserial

Bon, je pense qu'il faut que tu règles sur l'uart 2 : enlèves GPS et dans périphérique tu mets MSP ; au niveau de soft sérial tu mets le GPS.

N'oublies pas "SAVE" après chaque modif ! Ensuite re test si çà fonctionne.  Sinon reprend le setting du crossfire en t'aidant du tuto d'oscarliang qui est très bien fait :  https://osc

Posted Images

Salut,
Il est dangereux de s’amuser avec le cli quand on en perçoit pas totalement la portée, tu l’as constaté.
Je vois dans ton diff qu’il y a une config. D’où vient elle ?

Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Il ne suffit pas de mettre telem on.
Fais voir ton impression d’écran pour la config.
Sais tu sur quel uart ton nano rx est ?

Lien à poster
Partager sur d’autres sites

Moi je serais toi, je passerai le CRSF en UART 2 et le GPS en soft serial ! 

Le softserial c'est validé que ce n'est  pas fait pour de la transmission radio ! (Trop lent à reflechir  😴)

Même Fred Helico Micro le rappelle à sa juste raison dans son article Flywoo LR 4"

Modifié (le) par CriTof
Lien à poster
Partager sur d’autres sites

Oui les cablages sont bons (check ici)

Je viens de les rechecker a l'instant en partant de l'hypothese que peut etre il y avait un faux contact entre les soudures et que j'avais fait un court circuit en branchant la lipo mais non, les soudures sont propres, les cables bien branché et j'ai bien en output 1 Tx et en 2 RX

Lien à poster
Partager sur d’autres sites

Effectivement, ça ne va pas au niveau des ports. Uart 1 : crsf ok
Uart 2 on devrait avoir le msp
Le gps sur le softserial

  • +1 1
Lien à poster
Partager sur d’autres sites
il y a 6 minutes, CriTof a dit :

Moi je serais toi, je passerai le CRSF en UART 2 et le GPS en soft serial ! 

Le softserial c'est validé que ce n'est  pas fait pour de la transmission radio ! (Trop lent à reflechir  😴)

Même Fred Helico Micro le rappelle à sa juste raison dans son article Flywoo LR 4"

Tu veux dire deplacer les fils sur la carte comme ca ?

image.thumb.png.26a00d659b80fbbe8d542ac0b078fdde.png

Lien à poster
Partager sur d’autres sites
Et tu as quoi sur le Softserial en MSP ? UART1 sur RX1(pas sur inverter) et TX1 c’est bon...

Le serial rx invented est sur off dans le dump.
Lien à poster
Partager sur d’autres sites
Tu veux dire deplacer les fils sur la carte comme ca ?
image.thumb.png.26a00d659b80fbbe8d542ac0b078fdde.png

Oui tu peux essayer ça mais ça devrait marcher en uart1.
D’ailleurs, tu as bien compris dans betaflight, il faut save à chaque page ?
Lien à poster
Partager sur d’autres sites
il y a 3 minutes, Syrex a dit :

Effectivement, ça ne va pas au niveau des ports. Uart 1 : crsf ok
Uart 2 on devrait avoir le msp
Le gps sur le softserial

Je ne comprends de quoi vous parlez quand vous parlez de MSP ?

Lien à poster
Partager sur d’autres sites
il y a 3 minutes, Syrex a dit :


Oui tu peux essayer ça mais ça devrait marcher en uart1.
D’ailleurs, tu as bien compris dans betaflight, il faut save à chaque page ?

Oui mais tu fais bien de me le rappeller, Mais du coup je comprends pas ce que je suis sensé faire la, est ce que je dois activer le bouton dans la colonne "configuration/MSP" de l'UART2 ?

Lien à poster
Partager sur d’autres sites
il y a 52 minutes, Proto Dols a dit :

Oui je m'en suis vite aperçu 😕

La je suis en 4.1.1 avec le .hex fourni par flywoo + CLI fourni par flywoo ici

image.thumb.png.ec283fa003c9c5117aecb2116eb65d1b.png

Bon, je pense qu'il faut que tu règles sur l'uart 2 : enlèves GPS et dans périphérique tu mets MSP ; au niveau de soft sérial tu mets le GPS.

  • +1 1
Lien à poster
Partager sur d’autres sites

Aussi je sais pas si c'est une info pertinente ou pas mais dans les paramètres du nano RX dans la tango en output map j'ai :

-Output 1 : CRSF TX

- Output 2 : CRSF RX

- Output 3 : CH3

- Output 4 SmartAudio

- Output 5 BST SCL

- Output 6 : BST SDA

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×
×
  • Créer...