Aller au contenu
DroneBuilds

Compatibilité R9M ACCESS


Messages recommandés

Bonjour, je me suis acheté un r9m access et un r9 mini-ota  access pour mon drone.

je possède une taranis QX7 ACCST et (je m'y attendais un peu) je n'arrive pas à binder ma radio avec ma machine, pourtant quand j'ai acheté le r9m le vendeur spécifiait bien que ma radio accst et le r9m access était compatible, je me suis fait avoir ou y'a t-il vraiment un moyen de faire fonctionner le r9m ? 

Quant à la radio je pense avoir bien effectué les procédures pour binder.

merci d'avance.

Lien à poster
Partager sur d’autres sites
  • Réponses 60
  • Created
  • Dernière réponse

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Tout n’est pas perdu, tu peux flasher le R9M (2019) en ACCST ! Certaines radio, peuvent être modifiées, mais pas la QX7 ! https://github.com/opentx/opentx/wiki/Externalaccessmod

SAlut, t'as aussi un tuto assez bien fait en deux parties pour la QX7 & R9  : https://www.youtube.com/watch?v=12rxIgyGXXM https://www.youtube.com/watch?v=Sd4W9HgBshk   Le

J'avais aussi dit :    C'est pas un truc que je tenterais en tout cas 😉 

Posted Images

Il y a 6 heures, ygg.fpv a dit :

y'a t-il vraiment un moyen de faire fonctionner le r9m ? 


Tout n’est pas perdu, tu peux flasher le R9M (2019) en ACCST !

Certaines radio, peuvent être modifiées, mais pas la QX7 !

https://github.com/opentx/opentx/wiki/Externalaccessmod

  • +1 1
Lien à poster
Partager sur d’autres sites

SAlut,

t'as aussi un tuto assez bien fait en deux parties pour la QX7 & R9  :

https://www.youtube.com/watch?v=12rxIgyGXXM

https://www.youtube.com/watch?v=Sd4W9HgBshk

 

Le truc est de tout passer en ACCST, et de choisir entre Fport ou SBUS perso j'ai choisi le FPort que je trouve plus simple.

Modifié (le) par spid99
SBUS !
  • +1 1
Lien à poster
Partager sur d’autres sites

Le problème c'est que j'ai déjà essayé de flasher le r9m en ACCST, le plus étrange c'est que j'ai l'impression que le module arrive à communiquer avec la radio (les leds fonctionnent), je vais essayer en

f-port mais peut être que le problème ne vient pas du module mais d'autre part. 

Lien à poster
Partager sur d’autres sites
il y a 21 minutes, ygg.fpv a dit :

Le problème c'est que j'ai déjà essayé de flasher le r9m en ACCST, le plus étrange c'est que j'ai l'impression que le module arrive à communiquer avec la radio (les leds fonctionnent), je vais essayer en

f-port mais peut être que le problème ne vient pas du module mais d'autre part. 

Tu as aussi flasher le RX ?

tu as les firmware ici https://opentx-doc.fr/wiki/firmwares-2020-12-01

Modifié (le) par Attafr
Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Alors dans le doute j'ai tout reflashé, et j'arrive à bind, mais la radio capte le signal pendant 1 sec et la perd ensuite, le recepteur qui avait une led verte et un led rouge passe désormais à une led verte seule, et les leds du r9m s'allume toutes (preuve que le bind a fonctionné) de plus une icone de signal s'allume sur l'écran de ma radio mais apres une ou deux secondes le signal se coupe et laisse la led verte du recepteur allumé et sur betaflight j'ai aucune réponse. 

Des solutions ? 

Lien à poster
Partager sur d’autres sites
il y a 8 minutes, ygg.fpv a dit :

mais la radio capte le signal pendant 1 sec et la perd ensuite

Il est possible que tu sois trop près du qwad avec ta radio

Lien à poster
Partager sur d’autres sites

Effectivement quand je m'éloigne ça fonctionne mieux mais j'ai toujours aucune réponse sur betaflight, lorsque je tape "status" dans la console j'ai rxloss et noprearm et aucun moyen de démarrer les moteurs.

Lien à poster
Partager sur d’autres sites
il y a 48 minutes, ygg.fpv a dit :

noprearm

C’est que tu as définis un prearm avant le arm, mais surtout il ne voit pas ton rx (RXLOSS)...

Pour ton RX, c’est un problème de configuration, le bind définis le lien entre la radio et le rx, pas entre le rx et la FC !

Citation

Sur le R9MM, le pin dédié au F.Port et celui labellisé S.Port. C'est le fait de flasher le RX en F.Port qui fait que le S.Port devient en fait F.Port. L'aspect non inversé vient s'ajouter par dessus tout ça. Avec un R9MM tu as bien 2 pins F.Port, le premier qui est inversé (standard FRSky) et le second qui est non-inversé (que FrSky a souvent la brillante idée d'appeler inverted S/F.Port

https://forum.wearefpv.fr/topic/11462-bind-r9m-accst-rx-ota-acces/?do=findComment&comment=139983

Pour le R9 mini, il n’y a pas de inverted S.Port ?!

https://www.frsky-rc.com/wp-content/uploads/Downloads/Manual/R9 Mini-OTA/R9 Mini-OTA-Manual.pdf

https://www.frsky-rc.com/r9-mini-ota/

Lien à poster
Partager sur d’autres sites
il y a une heure, ygg.fpv a dit :

Mais je me demande si j'ai soudé le fil S-F port au bonne endroit je l'ai mis sur le pad sbus j'ai pas trouvé d'autre endroit sur la notice de ma fc (mamba f405 mk2) 

TX1 en SBUS(RX1) ça fonctionnera jamais !

C’est quoi ta FC 

Modifié (le) par Attafr
Lien à poster
Partager sur d’autres sites
il y a 34 minutes, ygg.fpv a dit :

Faut donc que je le branche sur le pad tx1 ?

Oui

Par contre il faut être sûr que ton R9Mini est flashé et configuré FPORT , ainsi que betaflight !

il y a 34 minutes, ygg.fpv a dit :

Si oui j'ai déjà essayé et ça ne fonctionne pas.

Après sur une FC F4 il faut peut-être déclarer depuis le CLI :

set serialrx_halfduplex=ON

set serialrx_inverted=ON ou OFF ?

save

Je connais pas bien le R9M @Jerome et @CriTof sont plus doué que moi !

Lien à poster
Partager sur d’autres sites

Le F.Port ne marchera pas avec ta FC et le R9 Mini, le signal étant inversé, tu es obligé de te mettre en SBUS.

Lien à poster
Partager sur d’autres sites
il y a 12 minutes, Jerome a dit :

Le F.Port ne marchera pas avec ta FC et le R9 Mini, le signal étant inversé, tu es obligé de te mettre en SBUS.

Pourtant...

167F81CE-3CE7-43FC-B2BF-2FD74A72DF2A.jpeg.ec48e0d9d4d81e122a46cf790e436f70.jpeg

et c’est toi qui l’avais dit...

https://forum.wearefpv.fr/topic/11112-taranis-qx7-r9m-r9-mini-ota-x220s-f4-pas-de-télémétrie/?do=findComment&comment=136484

Lien à poster
Partager sur d’autres sites
il y a 2 minutes, Attafr a dit :

et c’est toi qui l’avais dit...

J'avais aussi dit :   

Le 20/06/2020 at 12:41, Jerome a dit :

Il semblerait qu'il y ait moyen de récupérer le S.Port inversé via une soudure sur un R9 Mini, mais je ne connais personne qui ait testé la manip

C'est pas un truc que je tenterais en tout cas 😉 

  • +1 1
Lien à poster
Partager sur d’autres sites
Il y a 14 heures, Jerome a dit :

Le F.Port ne marchera pas avec ta FC et le R9 Mini, le signal étant inversé, tu es obligé de te mettre en SBUS.

Effectivement, pour le Fport il faut le le R9mm .. J'avais fait la connerie de prendre un "mini" une fois. Du coup j’avais été obligé de le brancher en SBUS, mais il faut aussi mettre un TX sur le "SPort", si non il ne fonctionnait pas l'abruti ! Bizarre non ?

image.png.adabf140ed01a637d0dd89b79f5087ae.png

https://oscarliang.com/setup-r9m-r9-mini-betaflight/

Modifié (le) par spid99
  • +1 1
Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×
×
  • Créer...