Aller au contenu
DroneBuilds

Aucun bind sur USB XSR-SIM ni drone trashcan et erreurs de scripts


Messages recommandés

Sujet : Aucun bind sur USB XSR-SIM ni drone trashcan
 

Bonjour,

 
Ma radio Taranis QX7 ACCESS ayant rendu l'âme au bout d'1 mois (sous garantie), StudioSport m'en a renvoyé une autre toute neuve.
Avec l'ancienne, j'utilisais le script isrm_region.lua pour switcher de LBT (pour ma clé usb XSR-SIM ) à FCC (pour mon drone). J'étais en  Opentx-x7access 2.3.10
 
Mon matériel actuel
Radio TARANIS QX7 ACCESS est en EU-LBT
Le drone traskcan est en frsky FCC
Ma clé usb  XSR-SIM est en EU-LBT
 
Voici ce que j'ai fait :
J'ai commencé par faire la mise à jour de la radio avec la version Opentx-x7access 2.3.11
 
open-version.jpg.f329e4461b9fca53aa4b7eb17191eb3f.jpg
 
J'ai essayé de binder ma clé  XSR-SIM qui est en LBT avec la radio en LBT. Etrange, le bind ne se fait pas. J'ai pourtant suivi la procédure (appuis sur le bouton de la clé, connexion puis bind en accst D16 ) Les 2 leds s'allument fixe, mais le bind ne se fait pas.
 
J'ai ensuite essayé de binder le drone en passant la radio en FCC.
J'ai mis aussi en D16, je clique sur le bouton bind du trashcan. Les leds du drone arrêtent de clignoter mais dans BF, aucune information n'est transmise dans l'onglet réception.
 
Là, me sentant un peu perdu, j'ai décidé de flasher le module RF. J'ai mis la dernière version 2.1.6EU cad, ISRM-N_X7(S)ACCESS_v2.1.6.frsk. 
 
isrm.jpg.2666248434a58ab4d4eb0d1a04bcdfa8.jpg
 
Mais depuis, c'est pire, je me retrouve avec des erreurs de script sur la création de nouveau modèle
 
new_model.jpg.5b528900c793068ee777b09d8eb13ce2.jpg
 
idem lorsque j'execute le script  Change ISRM mode 
region_resultat.jpg.b65c5d5cfbef5eaf7b50e44308254d57.jpg
 
 
A ce stade, je ne bind toujours pas. Avec mon ancienne QX7, j'étais en  Opentx-x7access 2.3.10. Je me suis dit qu'il y avait peut être un truc dans la dernière version qui ne plait pas à ma radio.
Je ne comprend pas comment downgrader en version  Opentx-x7access 2.3.10 car lorsque j'installe Compagion 2.3.10, il télécharge toujours la dernière version, cad la Opentx-x7access 2.3.11.
 
Je ne sais plus du tout quoi faire. Si vous avez une idée je suis preneur 🙂
 
Merci d'avance.
 
 
 
Modifié (le) par MrOizo
Ajout photo
Lien à poster
Partager sur d’autres sites
  • MrOizo changed the title to Aucun bind sur USB XSR-SIM ni drone trashcan et erreurs de scripts
il y a une heure, MrOizo a dit :

Là, me sentant un peu perdu, j'ai décidé de flasher le module RF. J'ai mis la dernière version 2.1.6EU cad, ISRM-N_X7(S)ACCESS_v2.1.6.frsk. 

OpenTX n’a RIEN à voir avec la version de ta RF...

Donc tu dois flasher ton RX en ACCST V2 LBT

Quand tu as flashé openTX tu n’as peut-être pas sélectionné les bons paramètres de compilation (LUA)

https://opentx-doc.fr/wiki/options-de-compilation
 

Pour les Firmwares, tu trouveras tout ici :

https://opentx-doc.fr/wiki/firmwares-2020-12-01

 

Comment flasher le RX :

https://opentx-doc.fr/wiki/flasher-un-rx-depuis-sa-radio

 

Comment flasher le module interne (RF/TX) :

https://opentx-doc.fr/wiki/flasher-le-module-rf-interne

 

Il faut une correspondance entre ACCST ou ACCESS, V1.x ou V2.x, FCC ou LBT(EU)

Pour mieux comprendre le merdier FrSky :

https://opentx-doc.fr/wiki/annexes#paragraph-annexe-3-frsky-et-la-jungle-des-firmwares

 

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

Oui, merci pour ces infos. C'est bien sur ces pages que j'ai récupéré le firmeware et les infos pour le flash. Je suis désormais en ISRM-N-X7(S)-ACCESS_v2.1.0

J'ai corrigé mon soucis d'execution de script.

Cependant, je stagne toujours au même point de ne pas pouvoir binder une Taranis EU-LBT avec une clé XSR-SIM EU LBT en ACCST D16,

Ca devrait binder direct non? Ca fonctionnait avec mon ancienne QX7 sans flasher la clé.

Je ne comprend probablement pas pourquoi je dois flasher la clé usb. elle est deja en Version EU ACCST D16 V1.xx

achetée ici : https://www.drone-fpv-racer.com/frsky-xsr-sim-3903.html

j'ai bien suivit la procédure de bind  https://www.wearefpv.fr/test-frsky-xsr-sim-20190125/

Est il possible que ma radio soit défectueuse? comment en etre certain?

Merci

Modifié (le) par MrOizo
  • J'aime 1
Lien à poster
Partager sur d’autres sites
il y a 2 minutes, MrOizo a dit :

Cependant, je stagne toujours au même point de ne pas pouvoir binder une Taranis EU-LBT avec une clé XSR-SIM EU LBT en ACCST D16,

Tu as pas tout bien lu... Problème V1.x V2.x !

tu es en V2.x sur la radio

Modifié (le) par Attafr
Lien à poster
Partager sur d’autres sites

Ah oui, bien vu. En effet, j'étais en V2. En passant sur le access V1 j'ai bindé du premier coup.

Je vais enchainer les binds pour le trashcan et le LAL5 Style.

Merci  pour ton aide.

  • +1 1
Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Bon, je déterre un peu le topic.... je viens de recevoir mon xsr sim.... meme symptomes, mais je suis pas sur d'avoir pigé la solution ??

jai une xlite pro, dernière mise a jour opentx (je sais rien à voir) et le module interne est en 1.1.3.... je sais que le 2.1.0 ou 2.1.6 est la dernière  version.... donc, concrètement, ta solution a été laquelle ?? j'ai la SD de lapin, donc tout les fw sont présent...

 

pour le moment, je n'ai pas flashé le module usb.

Lien à poster
Partager sur d’autres sites
il y a 48 minutes, crabos a dit :

jai une xlite pro, dernière mise a jour opentx (je sais rien à voir) et le module interne est en 1.1.3.... je sais que le 2.1.0 ou 2.1.6 est la dernière  version.... donc, concrètement, ta solution a été laquelle ?? j'ai la SD de lapin, donc tout les fw sont présent...

Rien de mieux que ça :

 

OpenTX n’a RIEN à voir avec la version de ta RF...

Donc tu dois flasher ton RX en ACCST V2 LBT

Quand tu as flashé openTX tu n’as peut-être pas sélectionné les bons paramètres de compilation (LUA)

https://opentx-doc.fr/wiki/options-de-compilation


Pour les Firmwares, tu trouveras tout ici :

https://opentx-doc.fr/wiki/firmwares-2020-12-01

Comment flasher le RX :

https://opentx-doc.fr/wiki/flasher-un-rx-depuis-sa-radio

Comment flasher le module interne (RF/TX) :

https://opentx-doc.fr/wiki/flasher-le-module-rf-interne 

Il faut une correspondance entre ACCST ou ACCESS, V1.x ou V2.x, FCC ou LBT(EU)

Pour mieux comprendre le merdier FrSky :

https://opentx-doc.fr/wiki/annexes#paragraph-annexe-3-frsky-et-la-jungle-des-firmwares


 

il y a 50 minutes, crabos a dit :

pour le moment, je n'ai pas flashé le module usb.

Tu entends quoi là ?

Lien à poster
Partager sur d’autres sites

Alors, de mes quelques recherches, je pense que mon module interne date de la version 1.1.3... donc je suppose un module D16 v1 !

le module xsr usb est neuf, en eu lbt, et du coup, je pense en D16 V2....

 

donc en upgradant le module de ma radio xlite pro en 2.1.0 ou 2.1.6 (dernière version en date) ma radio parlerais D16 v2...

 

MAIS j'ai peur que cela merde.... je n'ai pas flasher le module..... j'ai les fw issu du site frsky, mais j'ai pas envie de faire les soudures... si le récepteur est défecteux, je vais m'assoier dessus..

 

voila  où j'en suis.

Lien à poster
Partager sur d’autres sites
Il y a 3 heures, crabos a dit :

donc en upgradant le module de ma radio xlite pro en 2.1.0 ou 2.1.6 (dernière version en date) ma radio parlerais D16 v2...

 

Regarde page 7/7 du menu SYS sur ta radio... sous menu RX, tu as la configuration de ta RF/XJT (tu fais une photo)

j’te confirme ce qu’il sera le plus simple 

Lien à poster
Partager sur d’autres sites

Comme, je le suppose, mon module interne est en 1.1.3 eulbt donc d'avant le D16 v2.... je suppose ensuite que le dongle usb acheté là, a du etre fabriqué post 2020, donc en D16 v2....

 

à mon sens, un upgrade du fw de l'émetteur interne en 2.1.0 ou 2.1.6 devrait permettre de parler en D16 v2..... ou alors je flashe le dongle en fw pré D16 v2.... mais l'upgrade de la xlite pro va plus vite et reste plus simple...

 

je précise que la xlite pro n'est reliée à aucun drone pour le moment, j'utilisais ma QX7 avant... d'acheter la xlite qui me permet de me convertir au pilotage pouce.

IMG_20210318_211621.jpg

IMG_20210318_211533.jpg

Lien à poster
Partager sur d’autres sites
il y a 48 minutes, Attafr a dit :

Regarde page 7/7 du menu SYS sur ta radio... sous menu RX, tu as la configuration de ta RF/XJT (tu fais une photo)

j’te confirme ce qu’il sera le plus simple 

voilà

Lien à poster
Partager sur d’autres sites
il y a 32 minutes, crabos a dit :

voilà

Tu as déjà d’autres qwad/avions ou autres bindé avec ta radio ? Si c’est le cas, tu upgrades ton RX en V1.x LBT !

Sinon upgrade ton ISRM en V2.x LBT !

Tu es sûr que ton RX est en LBT ? (Tu l’as acheté où ?)

Lien à poster
Partager sur d’autres sites
il y a 5 minutes, Attafr a dit :

Tu as déjà d’autres qwad/avions ou autres bindé avec ta radio ? Si c’est le cas, tu upgrades ton RX en V1.x LBT !

Sinon upgrade ton ISRM en V2.x LBT !

Tu es sûr que ton RX est en LBT ? (Tu l’as acheté où ?)

la radio et le dongle possède bien le sticker eulbt.

 

Radio viens du coincoin, achat chez studiosport (facture l'appuie) et le rx provient directement de chez studiosport, acheté mardi ^^

 

je n'ai aucun drone avec cette radio... toute ma flotte est sur ma qx7 pour le moment.

Lien à poster
Partager sur d’autres sites
il y a 3 minutes, crabos a dit :

je n'ai aucun drone avec cette radio... toute ma flotte est sur ma qx7 pour le moment.

Ça veut dire que ta flotte qx7 est en ACCST V1.x LBT ?

Lien à poster
Partager sur d’autres sites
il y a 33 minutes, Attafr a dit :

Ça veut dire que ta flotte qx7 est en ACCST V1.x LBT ?

non, qx7 en fcc, les drones sont en D8 ou D16 v1.

 

bbhawk R (D8), plusieurs uk / us65 (D8 de mémoire), un 5 pouces en xm+ fcc.... lui D16, mais facilement flashable.
j'ai le module xlite pour le mode D8, donc je devrais pas permettre de trop puisque le D8 est sans région. ^^

Modifié (le) par crabos
Lien à poster
Partager sur d’autres sites
il y a 12 minutes, crabos a dit :

non, qx7 en fcc, les drones sont en D8 ou D16 v1.

Ok alors passe ton ISRM en V2.x LBT...

Sur ta radio ACCESS (en V1.x ou V2.x) tu peut temporairement switcher FCC<->LBT avec un LUA !

Lien à poster
Partager sur d’autres sites
Il y a 8 heures, Attafr a dit :

Ok alors passe ton ISRM en V2.x LBT...

Sur ta radio ACCESS (en V1.x ou V2.x) tu peut temporairement switcher FCC<->LBT avec un LUA !

oui, le script est déjà présent.... bon, tu confirme mon analyse, y aplus qu'a !

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...