Aller au contenu
DroneBuilds

betaflight Souci sur RUSHFPV Rush Blade F722 FC


JackFly
 Share

Messages recommandés

Bonsoir,

J'ai un souci avec la FC RUSHFPV Rush Blade F722 : jusqu'à maintenant tout fonctionnait parfaitement.
Aujourd'hui, j'ai perdu le signal radio en vol (à moins de 50m), le drone est passé en F/S : atterrissage, pas de casse.
Après moultes contrôles, voici les résultats :
Les UART 1 et 5 ne délivrent que 2,28 V (lipo 4S branchée).
L'UART navi donne bien 4,78V (5V annoncé)
La tension d'arrivée à la FC, depuis les ESC est bien identique à la tension de la Lipo.
Fait bizarre : lorsque je branche via USB la FC à l'ordinateur, l'UART 1 (radio) affiche 4,78V et se connecte à la radio.
Je n'y comprends plus rien.
Cette FC peut-elle présenter un défaut ?
Je vole tous les jours ou presque, depuis que j'ai reçu tout le drone, commandé avec cette stack, et tout a bien fonctionné jusqu'à aujourd'hui.

Je suis un peu paumé...
Merci de votre aide.

Lien vers le commentaire
Partager sur d’autres sites

Il y a 19 heures, Attafr a dit :

Sûrement un BEC 5V !

Mais alors pouquoi les uart 1 et 5 plafonnent à 2,28V (que ce soit en 3S, 4S, ou 6 S) ?

Quand je l'ai installé, ça fonctionnait bien en 5V. Comprends pas ce qui s'est passé

Lien vers le commentaire
Partager sur d’autres sites

il y a 1 minute, JackFly a dit :

Mais alors pouquoi les uart 1 et 5 plafonnent à 2,28V (que ce soit en 3S, 4S, ou 6 S) ?

Quand je l'ai installé, ça fonctionnait bien en 5V. Comprends pas ce qui s'est passé

C'est très bizarre, mais c'est possible que l'uart 1 et l'uart 5 soient sur des BECs différents

Lien vers le commentaire
Partager sur d’autres sites

il y a 34 minutes, JackFly a dit :

Mais alors pouquoi les uart 1 et 5 plafonnent à 2,28V (que ce soit en 3S, 4S, ou 6 S) ?

Quand je l'ai installé, ça fonctionnait bien en 5V. Comprends pas ce qui s'est passé

Un UART (TX/RX) n’ont pas 5V... Tu trouveras du 5V sur les pad 5V 🤦‍♂️ et sur BUZ+ !

Modifié (le) par Attafr
Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV
Posté(e) (modifié)
Il y a 14 heures, Attafr a dit :

Un UART (TX/RX) n’ont pas 5V

sur la FC, tu choisis 3,3V ou 5V pour le RX (petite soudure à faire au dos de la FC), image jointe. Pardonne moi si je n'utilise pas le vocable approprié, mais qu'on sache de quoi je veux parler.

J'ai soudé pour avoir 5V sur cet UART, et j'avais bien 5V au début. Pourquoi j'ai perdu ça, et pourquoi le R-XSR ne fonctionne plus sur cet UART, sauf si je branche le câble USB à l'ordi ?

rushfpv-rush-blade-f722-flight-controller-dji-fpv.thumb.jpg.fe75176700f3b354e146f08f43c39766.jpg

Modifié (le) par JackFly
Lien vers le commentaire
Partager sur d’autres sites

il y a 21 minutes, JackFly a dit :

sur la FC, tu choisis 3,3V ou 5V

C’est où il y a les flèches rouge que tu dois avoir 5V entre GND et 5V...

si tu as 5V c’est bon, maintenant si tu as une autre tension, tu as un problème avec le BEC 5V de ta FC

le pad 5V du RX1/TX1 (ton choix) peut être alimenté en 3.3V, si par exemple tu as un DSMX !

D2015408-5399-4545-BD7C-0F944CD5656A.jpeg.54c3381770eaef10ee4bc7f826b121d3.jpeg

Modifié (le) par Attafr
Lien vers le commentaire
Partager sur d’autres sites

Les flèches rouges ? je vois pas. Par contre je lis très bien 5V sur le pad concernés.

A te lire, j'aurai un problème de BEC, ce qui me semble logique puisque je n'ai pas 5V au RX1/TX1, bien que soudé comme tel. Merci de ton retour.

Je vois avec Drone FPV Racer si cette carte est garantie. Elle n'a même pas 1 mois...

  • Haha 1
Lien vers le commentaire
Partager sur d’autres sites

Posté(e) (modifié)

Avec le schéma c'est mieux en effet 🙂

Dernière question : est-ce que ça peut se réparer un BEC défectueux ?

Modifié (le) par JackFly
Lien vers le commentaire
Partager sur d’autres sites

il y a une heure, JackFly a dit :

Avec le schéma c'est mieux en effet 🙂

Dernière question : est-ce que ça peut se réparer un BEC défectueux ?

Oui, mais il faut du matos et si connaître une minimum. Ça resemble à ça...

54581874-8B11-4097-9BFB-B85289F92521.thumb.jpeg.77206149c4982bcf4911d5a7f461decb.jpeg

Lien vers le commentaire
Partager sur d’autres sites

Posté(e) (modifié)

Ok, je peux voir ça avec un ami.

Par contre, je me rends compte aussi, que mon récepteur n'est plus reconnu sur BetaFlight, alors que la liaison radio est bonne, tout du moins le bind est correct (refait 3 fois).

Comment contrôler un R-XSR pour être sûr que toutes ses fonctions sont ok ?

Modifié (le) par JackFly
Lien vers le commentaire
Partager sur d’autres sites

Il y a 4 heures, JackFly a dit :

Par contre, je me rends compte aussi, que mon récepteur n'est plus reconnu sur BetaFlight,

Ben si il n’est pas alimenté en 5V c’est normal 🤪

Lien vers le commentaire
Partager sur d’autres sites

Je m'exprime mal :-)

Le Rx est connecté au drone, lumière verte ok, donc appairé à la radio. Il est connecté à la radio puisque la radio me donne la qualité RSSI. Le Rx fonctionne puisque la FC est connectéé à l'ordi (bizarrement ça fonctionne dans ce cas, comme expliqué au dessus).

Par contre, dans ce cas précis où tout semble ok, la radio n'est pas reconnu sur BF. Le paramétrage BF ok.

D'où ma question : Comment contrôler un R-XSR pour être sûr que toutes ses fonctions sont ok ? J'entends pas toutes ces fonctions : émission, réception, télémétrie, communication avec la FC.

Lien vers le commentaire
Partager sur d’autres sites

il y a une heure, JackFly a dit :

D'où ma question : Comment contrôler un R-XSR pour être sûr que toutes ses fonctions sont ok ? J'entends pas toutes ces fonctions : émission, réception, télémétrie, communication avec la FC.

Je comprends pas, ou tu t’exprimes mal ?

Si tu retires ton câble usb (pas connecté à l’ordinateur) et que tu alimentes ton qwad, as tu 5V sur les pads que je t’ai indiqué?

Ton RX est il toujours alimenté avec signal RSSI sans câble usb et avec lipo !

Tu peux effacer sur la dernière page de ton modèle depuis la radio les capteurs et relancer une recherche des capteurs.

Si tu trouves TOUT tes capteurs c’est un problème SBUS/port/etc... pas un problème de smarport (r-xsr télémétrie)

Lien vers le commentaire
Partager sur d’autres sites

Le 07/04/2021 at 22:13, Attafr a dit :

Je comprends pas, ou tu t’exprimes mal ?

je dois mal m'exprimer et à la fois, c'est pas banal...

Merci en tout cas de ta patience.

Une vidéo sera plus claire pour comprendre mon souci. A savoir que sur cette vidéo, j'ai changé le R-XSR, tout neuf, reçu et flashé ce matin.

J'espère que ce sera plus claire comme ça.

Merci encore de votre aide à tous (le message "signal RF critique" vient du fait que j'ai installé l'antenne FRSKY extérieur, sans changer la programmation radio).

Lien vers le commentaire
Partager sur d’autres sites

Il y a 1 heure, JackFly a dit :

J'espère que ce sera plus claire comme ça.

Pas vraiment...
 

Le 07/04/2021 at 22:13, Attafr a dit :

Si tu retires ton câble usb (pas connecté à l’ordinateur) et que tu alimentes ton qwad, as tu 5V sur les pads que je t’ai indiqué?

Apparemment pas... d’ailleurs QUAND  tu connectes ton câble usb, il lance une initialization...

Lien vers le commentaire
Partager sur d’autres sites

Posté(e) (modifié)
Le 10/04/2021 at 18:33, Attafr a dit :

d’ailleurs QUAND  tu connectes ton câble usb, il lance une initialization...

oui, c'est bizarre. Ca veut dire quoi ? j'avais jamais vu ça avant. Je pense vraiment que cette FC est défaillante. J'aimerais savoir ce qu'il s'est passé.

 

Le 10/04/2021 at 18:33, Attafr a dit :

Pas vraiment...

Alors je peux pas mieux l'expliquer. Désolé. C'est pas grave, merci du temps que tu as pris.

Modifié (le) par JackFly
Lien vers le commentaire
Partager sur d’autres sites

Le 07/04/2021 at 22:13, Attafr a dit :

Si tu retires ton câble usb (pas connecté à l’ordinateur) et que tu alimentes ton qwad, as tu 5V sur les pads que je t’ai indiqué?

avec cette photo, tu verras ce que j'ai en sorties (il n'y aura pas de confusion UART/pads).

IMG_4209.thumb.jpeg.75a41ee1c7b1067c1d0d43462d4dcb44.jpeg

Lien vers le commentaire
Partager sur d’autres sites

il y a 58 minutes, JackFly a dit :

avec cette photo, tu verras ce que j'ai en sorties (il n'y aura pas de confusion UART/pads).

Si tu branches ton câble USB, je pense que tu as 5V !

c’est bien ta FC qui a un problème de bec 5V !

donc si tu n’as pas la possibilité de changer le bec + peut-être d’autre composants, ta FC est morte...

Tu as aussi la possibilité d’utiliser un UBEC et d’alimenter tes différents éléments depuis cette source 5V !

Modifié (le) par Attafr
  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

Posté(e) (modifié)
il y a 19 minutes, Attafr a dit :

Si tu branches ton câble USB, je pense que tu as 5V !

oui, en effet. C'est pour ça je pense que le récepteur passe au vert, entre autre

 

il y a 19 minutes, Attafr a dit :

donc si tu n’as pas la possibilité de changer le bec + peut-être d’autre composants, ta FC est morte...

c'est bien ce que je pense, et donc elle est normalement encore sous garantie : problème survenue même pas un mois après mise en service. Drone FPV Racer m'a envoyé chez RushFPV directement. J'attends leur retour.

Sinon, merci pour ta solution UBEC. Je note 🙂

Modifié (le) par JackFly
Lien vers le commentaire
Partager sur d’autres sites

  • 4 weeks later...

Hello, suite et fin de ce mauvais épisode.

DFPVR m'a renvoyé chez Rush en direct, c'est la procédure avec Rush. Tu m'étonnes, Rush à des milliers de kilomètres ont plus de facilités pour me dire que c'est de ma faute. Sur la photo que j'ai envoyée, l'analyse du brillant Eliot conclue que la soudure est mal faite et que ça a provoqué un court-circuit, à moins que ce ne soit du côté de l'ESC qu'un câble dénudé serait venu toucher la FC ! N'importe quoi en gros. Le drone a volé parfaitement une semaine au moins, sans aucun souci.

Bref, Merci à DFPVR d'avoir fait le lien, et fuck RushFPV (pardonnez ma vulgarité, mais ça mérite pas mieux) sur lesquels je fais définitivement une croix dessus : pas sérieux comme SAV !!!

Heureusement, il y a d'autres fabricants, espérant que ce sera plus sérieux.

Quels seraient vos conseils ?

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
 Share

×
×
  • Créer...