Aller au contenu
DroneBuilds

Furious FPV F35 sous INAV


Messages recommandés

Bonjour à tous,

J'essai de programmer une aile volante et voici ma config:
Modèle: Sonicmodell AR Wing 800
- Carte de vol: Furious FPV F35 (Firmware: inav_2.5.0_FF_F35_LIGHTNING.hex - date: 2020-6-7 12:13)
- Moteur: Emax RSII 2207 2300KV
- ESC: T-Motor F45A 3-6S 32bit
- Caméra: Caddx turbo Micro F2
- VTX: Emetteur AKK X2 ULTIMATE
- GPS: Tarot TL2970
- AIRSPEED: ARKBIRD Airspeed Meter (en test)
- Logiciel: INAV v2.50
- RX: R9 Slim+  flasher en FCC FLEX
- Radio: X9D+ OPENTX v2.37 avec module R9M 2019 flasher en FCC FLEX

Mes questions:
- 1: j'ai connecté le fil blanc (OSD, à moins qu'il fallait que je connecte l' "AUDIO") de ma caméra au fil blanc du la F35 (Cam_Ctrl), maintenant, j'ai les deux OSD qui s'affiche (OSD Caméra + OSD INAV) (UART5 sur RUNCAMDevice dans "PORTS")

     

j'ai trouvé pour masqué l'OSD d'INAV, mais pour enlever et contrôler l'OSD de la caméra, là, je sèche...

mini_200615095042605559.jpg  mini_200615095042752566.jpg  mini_20061509504310859.jpg

 - 2: J'ai voulu connecter un Airspeed de ARKBIRD sur la prise AIRSPEED de la F35, résultat:
       Sans l'AIRSPEED branché, le SENSOR est totalement aléatoire
       Avec l'AIRSPEED branché, le SENSOR est à "0"
       Si je souffle (fort) dans l'AIRSPEED,  le SENSOR est toujours à "0"

Le problème vient t'il de mes branchements, d'une différence de protocole, (je souffle pas assez fort  ).


- 3: j'ai un ESC T-Motor compatible jusqu'à DSHOT1200, est-ce que je dois le laisser en "MULTISHOT" actuel), ou le mettre en DSHOT1200 ou le remettre en "STANDARD" 


STATUS sous "CLI":
# status
System Uptime: 13 seconds
Current Time: 2041-06-28T01:04:00.000+00:00
Voltage: 0.38V (1S battery - NOT PRESENT)
CPU Clock=168MHz, GYRO=MPU9250, ACC=MPU9250, BARO=BMP280, MAG=MPU9250, PITOT=ADC
STM32 system clocks:
SYSCLK = 168 MHz
HCLK = 168 MHz
PCLK1 = 42 MHz
PCLK2 = 84 MHz
Sensor status: GYRO=OK, ACC=OK, MAG=OK, BARO=OK, RANGEFINDER=NONE, OPFLOW=NONE, GPS=NONE
Stack size: 6144, Stack address: 0x10010000, Heap available: 1728
I2C Errors: 0, config size: 5639, max available config: 131072
ADC channel usage:
BATTERY : configured = ADC 3, used = ADC 3
RSSI : configured = none, used = none
CURRENT : configured = ADC 2, used = ADC 2
AIRSPEED : configured = ADC 1, used = ADC 1
System load: 2, cycle time: 1002, PID rate: 998, RX rate: 49, System rate: 9
Arming disabled flags: NAV RX CLI
VTX: band: A, chan: -, power: / (24664 mW)


Fichier "dump all" joint 



Je suis à votre écoute....

Merci d'avance

Bonne journée et bon vol à tous

dump all du 2020-06-15.txt

Lien à poster
Partager sur d’autres sites
Le 15/06/2020 at 15:40, yoyodec a dit :

Mes questions:
- 1: j'ai connecté le fil blanc (OSD, à moins qu'il fallait que je connecte l' "AUDIO") de ma caméra au fil blanc du la F35 (Cam_Ctrl), maintenant, j'ai les deux OSD qui s'affiche (OSD Caméra + OSD INAV) (UART5 sur RUNCAMDevice dans "PORTS")

Salut, voilà le manuel de la caddx  Pour gérer l'OSD de la caméra, connecte l'osd (le vert) et la masse sur le contrôleur (joystick) qui  dû être fournit avec la caméra. Dans le menu, tu y trouveras l'option de ne pas afficher l'OSD.33c7bb1f4a.jpg.2f62f5014da13dcfbabd47de3e6e4a21.jpg

Pour le reste, je ne suis pas assez réveillé .. @CriTof C'est pour toi 😉

Modifié (le) par spid99
Lien à poster
Partager sur d’autres sites

Chut... @spid99 dort encore 😁

Je vais pas être tres en forme sur le coup because je n'ai pas encore attaqué ma Mini AR wing 600 sous Inav. Et que ce sera une premiere aussi pour moi avec ce FW ( Matek F411dédiée ailes, pour mon choix de FC)

Deux/trois petites choses à dire mais pas rédhibitoires:

Sonicmodell AR Wing 800 900. Tu viens donc de gagner 10cm d'envergure 😉

Sur cette taille, l'aile commence à faire son poids, un moteur de 2400/ 2450 Kv sera un bon p'tit plus.

A moins de vouloir voler avec du 6S... L'ESC de 45 amp n'est pas utile. (Generalement c'est du 30 amp pour de la 3 ou 4S)

quand à la Cam, je botte en touche car Caddx m'a déçue à deux reprises. C'est fini ! (sauf le produit HD compatible DJI) 

Lien à poster
Partager sur d’autres sites

Bonjour à tous,

@invamf

1. merci pour le lien, très intéressant.

2.sais tu comment on active l'Airspeed et la télémétrie dans INAV ?

3. pas de souci.

 

@spid99

En fait, je voudrait paramétrer l'OSD de la caméra en l'ouvrant avec un inter  et naviguer avec les stick de la radio, merci quand même.

 

@CriTof 

 

il y a une heure, CriTof a dit :

Sonicmodell AR Wing 800 900

Merci pour l'info.

il y a une heure, CriTof a dit :

Sur cette taille, l'aile commence à faire son poids, un moteur de 2400/ 2450 Kv sera un bon p'tit plus.

Pourtant, c'est le même KV que d'origine...

Sinon, j'ai Lumenier MB2206-9 2450kv freybot que j'échange avec celui de mon aile Cutlass 10.

il y a une heure, CriTof a dit :

A moins de vouloir voler avec du 6S... L'ESC de 45 amp n'est pas utile. (Generalement c'est du 30 amp pour de la 3 ou 4S)

J'ai que ça en stock, vu que, qui peut le plus, peut le moins, cela devrait aller...

Vu que, pour la caméra, j'ai que celle-là, je crois que vais virer le fil blanc si je trouve pas...

 

Sinon, voici l'onglet "Ports" de INAV:

mini_200617035711879550.jpg

Lien à poster
Partager sur d’autres sites
  • 2 weeks later...
Youtube WE are FPV

Test de puissance au Wattmètre:

 Moteur: Emax RSII 2207 2300KV + ESC: T-Motor F45A 3-6S 32bit + hélice 5x5x3 (celle d'origine) + LIPO 4S 1500mah 45C= 640w env...

Sinon, personne n'a eu de souci avec une télémétrie "partielle", c'est à dire, que "BtRx" et "RSSI" de visible....
 

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

ENFIN, j'ai trouvé,

j'ai fouillé dans le fichier "dump all" créé avec "save to file" a partir de l'onglet "CLI" dans INAV, et j'ai vu que le problème venais de "set telemetry_halfduplex =" qui étais sur "ON".
Donc, j'ai mis "set telemetry_halfduplex =" sur OFF, et j'ai enregistré mon fichier TXT, puis je l'ai chargé dans "CLI" avec "load from file".

Au redémarrage de la FC, j'ai fait "découvrir capteur" sur ma X9D+, (MIRACLE) j'ai pu trouver (ENFIN) tous mes capteurs de télémétrie 👍👍👍


mais, je ne sais pas du tout ou se trouve le switch qui correspond à la ligne "set telemetry_halfduplex = OFF" dans INAV....

 

MERCI A TOUS POUR VOTRE AIDE

Modifié (le) par yoyodec
Lien à poster
Partager sur d’autres sites
Il y a 1 heure, yoyodec a dit :

ENFIN, j'ai trouvé,

j'ai fouillé dans le fichier "dump all" créé avec "save to file" a partir de l'onglet "CLI" dans INAV, et j'ai vu que le problème venais de "set telemetry_halfduplex =" qui étais sur "ON".
Donc, j'ai mis "set telemetry_halfduplex =" sur OFF, et j'ai enregistré mon fichier TXT, puis je l'ai chargé dans "CLI" avec "load from file".

Au redémarrage de la FC, j'ai fait "découvrir capteur" sur ma X9D+, (MIRACLE) j'ai pu trouver (ENFIN) tous mes capteurs de télémétrie 👍👍👍


mais, je ne sais pas du tout ou se trouve le switch qui correspond à la ligne "set telemetry_halfduplex = OFF" dans INAV....

 

MERCI A TOUS POUR VOTRE AIDE

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...