Aller au contenu
DroneBuilds

Pas de communication entre RC et Rx


Messages recommandés

Bonjour, j’ai récemment fait l’acquisition d’un cinewhoop chasers 138 Hd BNF V1.2 GOKUF722FC ET XM+ en receiver. J’ai une taranis Qx7 en radio commande, malgré le blindage entre les deux et la led verte qui reste fixe sur le Rx, les deux ne communiquent pas. Sur betaflight, je n’arrive pas à faire fonctionner les différents modes de mon récepteur (Roll, Pitch,...) ainsi que les autres auxiliaires que j’ai programmé sur ma radio commande. 

J’ai déjà tout rebooté, rien ne fonctionne. 
Est ce que quelqu’un pourrait m’aider à trouver une solution?

Lien à poster
Partager sur d’autres sites
il y a 19 minutes, Remy G a dit :

Bonjour, j’ai récemment fait l’acquisition d’un cinewhoop chasers 138 Hd BNF V1.2 GOKUF722FC ET XM+ en receiver. J’ai une taranis Qx7 en radio commande, malgré le blindage entre les deux et la led verte qui reste fixe sur le Rx, les deux ne communiquent pas. Sur betaflight, je n’arrive pas à faire fonctionner les différents modes de mon récepteur (Roll, Pitch,...) ainsi que les autres auxiliaires que j’ai programmé sur ma radio commande. 

J’ai déjà tout rebooté, rien ne fonctionne. 
Est ce que quelqu’un pourrait m’aider à trouver une solution?

La solution devrait arriver après... Ton coucou 😉

https://forum.wearefpv.fr/15-présentation/

A très vite ! 

Lien à poster
Partager sur d’autres sites

Après quelques recherches et plusieurs essais, je ne comprends pas comment un Rx livré monté sur le drone pourrait être défectueux sachant qu’il est bien installé dans son compartiment à l’abri des chocs. 

Lien à poster
Partager sur d’autres sites
Il y a 9 heures, Remy G a dit :

Après quelques recherches et plusieurs essais, je ne comprends pas comment un Rx livré monté sur le drone pourrait être défectueux sachant qu’il est bien installé dans son compartiment à l’abri des chocs. 

Parce qu'il ne l'est probablement pas 😉 

Les RX arrivent flashés avec un firmware spécifique, si ce dernier ne correspond pas à celui de ta radio, il faut alors le reflasher. Par exemple :

  • Tu as peut-être une radio ACCESS alors que le RX est arrivé flashé en ACCST
  • Ou bien l'inverse
  • Ou bien ta radio  est en ACCST 1.x alors que le RX est en ACCST 2.x
  • Ta radio est peut-être en EU-LBT et le RX en FCC

Comme on ne sait jamais dans quel firmware arrive le RX, à moins que le vendeur te l'ai indiqué, le plus simple est de le flasher avec un firmware adapté à ta radio, il y a de forte chance que cela règle le prbl.

Sans connaître ton modèle exact de radio, le firmware flashé dessus, sans savoir ce qui a été flashé sur le RX ni la config faite dans Betaflight, on ne pourra guerre t'aider plus.

Modifié (le) par Jerome
Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

@Remy G Jerome à parfaitement résumé la situation.

Tu es toi aussi confronté à la JUNGLE mise en place par frsky depuis ces deux dernières années. Une purge sans nom pour nous aussi si cela peut te rassurer. 

Va donc visionner (et digérer..) ce superbe tuto video (tout frais) de Lapin fou, qui résume tout l'enfer Firmware frsky. https://www.youtube.com/watch?v=lLEgpSZaYwE

Et un site incontournable (Toujours Lapin Fou) https://opentx-doc.fr

Modifié (le) par CriTof
Lien à poster
Partager sur d’autres sites

Sans chercher bcp plus loin, il y a un premier souci : ton serial RX est associé à 2 UARTs. Assure-toi de n'activer le serial RX uniquement sur l'UART auquel est connecté ton RX.

  • +1 1
Lien à poster
Partager sur d’autres sites

Oulala... Y’a beaucoup d’UART définis, sûrement trop 😜

Déja on voit pas la dernière colonne à droite sur l’onglet PORT.

Ensuite, tu as 3 UART MSP, le USB ok, mais 3 et 5 c’est quoi ? (DJI, GPS)?

Pour les Serial RX 1 et 2, il y en a sûrement 1 pour le RX.

Si tu peux poster une autre photo de la page port... et une référence de ta machine (lien ou photo) des connections.

C’est celle-ci ta carte ?

006A4FA9-641E-46F7-BF4D-825FBCD8265C.thumb.png.4fe2289d36323cb9666fbe0fd5329317.png

Lien à poster
Partager sur d’autres sites

C'est un exemple par rapport à leur "suggestion d'UARTs" :

image.png.d0ec28ae2a7a4a70b6e816860a11d06d.png

En réalité, tu n'as jamais les 2 en même temps, c'est l'un ou l'autre. C'est vrai que ca prête un peu à confusion. Désactive l'UART 2 et teste déjà comme ca 🙂 

Modifié (le) par Jerome
Lien à poster
Partager sur d’autres sites

J’essaie ça et je vous tiens au courant, merci pour votre patience et votre aide, le monde du drone fpv est tout nouveau en therme de technicité et je vous remercie!

Lien à poster
Partager sur d’autres sites
il y a 43 minutes, Jerome a dit :

C'est un exemple par rapport à leur "suggestion d'UARTs" :

image.png.d0ec28ae2a7a4a70b6e816860a11d06d.png

En réalité, tu n'as jamais les 2 en même temps, c'est l'un ou l'autre. C'est vrai que ca prête un peu à confusion. Désactive l'UART 2 et teste déjà comme ca 🙂 

Pas mieux que Jerome et Attafr.  Dans ton cas ou tu es Frsky, Désactiver l 'Uart 2 dans l'onglet "Ports" de ton configurateur. (Ne conserver que l' Uart 1 sur ON)

Nous imaginons que c'est un R-XSR  ton rx radio... ? 

Modifié (le) par CriTof
Lien à poster
Partager sur d’autres sites

Bonjour, finalement c’était sur l’user 2 qu’il fallait l’activer. J’ai bien toutes mes réponses de commandes dans la partie récepteur. 
Mon problème maintenant est que dans la partie « modes » j’avais assigné mes switches avec les bon aux mais juste pour l’armement, il s’affiche en rouge écrit désactivé. 
Le drone n’a jamais volé, j’ai pu lire un post sur ce problème mais pas plus d’infos. Est ce une sécurité qui empêche l’armement? 
J’ai tapé status dans le CLI m’indiquant que je suis en MSP CLI mais même après avoir débranché l’usb et sortie de BF, en armant, le drone bip mais aucune action des moteurs, Th à zéro. 

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...