Jump to content
Sign in to follow this  
  • entries
    4
  • comments
    39
  • views
    952

Pb sur smart audio tbs

Fpvaquitaine

1,363 views

Bonjour à tous,

je rencontre un pb avec mon smartaudio, en effet suite à la destruction de mon Cinewhoop, voici le liens si ça vous intéresse,

je me suis refait un set up, tout fonction nikel , en beta 4.1.1, Sauf que je ne parvins par a régler mon vtx via le smartaudio tbs sur l'osd et dans le CLI, je suis brancher en tx3, dans beta j'ai bien la confirmation qu'il est reconnu, mais j'ai que des - - - - sur mon osd et des valeurs nulles en CLI.

Sur Beta, dans l'onglet " émetteur vidéo" j'ai cela

1362637753_betaflightvtx.thumb.jpg.9680cfe953ffe245d9d79bf8453143d5.jpg

C'est la première fois que je flash en 4.1.1, et je ne trouve pas de solution.

J'ai bien cherché sur tous les sites que je fréquente mais je reste dans l'impasse.

Si Quelqu'un a une solution je suis preneur.

 

Merci à tous et bon vol. (enfin s'il s'arrête de flotter punaise).

 

Apolo.



31 Comments


Recommended Comments



Hello !

tu dois maintenant recharger la VTX table dans betaflight pour que ça fonctionne. 
 

C’est passé sur mon 5 » mais impossible de la recharger sur mon HX100 et mon HX150 et je ne sais pas pourquoi

  • J'aime 1

Share this comment


Link to comment

T'as pété tout ça avec juste ce micro crash ? 😱

C'est vrai que ton écran a une drôle de tête, il manque plein de libellés et les boutons pour charger les VTX Tables. Je commencerais par reflasher la FC en effaçant toutes les valeurs, pour voir ce que ça donne.

  • J'aime 1

Share this comment


Link to comment
il y a 29 minutes, Laurenzo17 a dit :

Hello !

tu dois maintenant recharger la VTX table dans betaflight pour que ça fonctionne. 
 

C’est passé sur mon 5 » mais impossible de la recharger sur mon HX100 et mon HX150 et je ne sais pas pourquoi

Merci , je vais tester ça, je te fait un retour.

Share this comment


Link to comment
il y a 12 minutes, Jerome a dit :

T'as pété tout ça avec juste ce micro crash ? 😱

C'est vrai que ton écran a une drôle de tête, il manque plein de libellés et les boutons pour charger les VTX Tables. Je commencerais par reflasher la FC en effaçant toutes les valeurs, pour voir ce que ça donne.

Ouai , c'est chelou, tout a cramé, les esc fonctionnent encore, mais il manque un condo, le problème vient peut être de là.

je vais tester le reflash et te dire ce qu'il en ait, merci pour la rapidité du retour.

Share this comment


Link to comment

C good, ca fonctionne, merci à vous pour toutes ces infos

j'ai chargé les tables Vtx, j'avais jamais eue ce cas avant, c'est depuis la 4.1.1?

Comme vous tous je vol en 25 mw....Mais je peux pas changer le power sur osd, il le rebloque  en 25mw, es-ce un blocage software sur la 4.1.1? je ne rencontrais pas ce soucis sur les versions antérieurs.

 

Merci encore les gars.

 

Apolo

Share this comment


Link to comment
il y a 7 minutes, Jerome a dit :

Oui, ca date de la 4.1. Tu as utilisé quoi comme VTX Table ? T'as bien pris une version USA ?

j'ai pris la EU, la us est mieux?

Edited by Fpvaquitaine

Share this comment


Link to comment

C’est un vague traduction du wiki https://github.com/betaflight/betaflight/wiki/VTX-tables
 

Tables VTX à utiliser dans le configurateur

Mode d'emploi:

  • clic droit sur le fichier, 'Enregistrer le lien sous';
  • dans le configurateur, allez dans l'onglet «Video Transmitter», utilisez «Load from file» pour charger le fichier enregistré à l'étape précédente;
  • cliquez sur «Enregistrer» pour enregistrer la table VTX sur le contrôleur de vol.

Pour une vidéo rapide sur la façon de déterminer votre version Smart Audio: https://youtu.be/eaSmoOPk9KY?t=65

Touche Smart Audio Debug [0]: 
100 = SA 1.0 
116 = SA 1.0 déverrouillé 
200 = SA 2.0 
216 = SA 2.0 déverrouillé 
300 = SA 2.1 
316 = SA 2.1 déverrouillé

Mise à jour: 30 octobre 2019: les tables SmartAudio pour l'UE avaient un bug qui faisait que les bandes F et R avaient des fréquences incorrectes. Ils ont été corrigés, veuillez réinstaller les tableaux mis à jour.

Fabricants / Modèles avec lesquels utiliser ce fichier Fichier
Protocole IRC Tramp:  
IRC Tramp IRC Tramp (États-Unis)
  IRC Tramp (UE)
MATEKSYS VTX-MINI VTX-MINI (INT)
iFlight The Force Long Range Force LR (États-Unis)
  Force LR (INT)
RunCam TX200U IRC Tramp (États-Unis)
  IRC Tramp (UE)
RunCam TX100 IRC Tramp (États-Unis)
  IRC Tramp (UE)
Speedy Bee TX500 IRC Tramp (États-Unis)
  IRC Tramp (UE)
   
Protocole TBS SmartAudio:  
TBS (SA 1.0 n'était utilisé que sur les appareils TBS de première génération) SmartAudio 1.0 (États-Unis)
  SmartAudio 1.0 (UE)
TBS (utilisé sur la plupart des VTX qui prennent en charge SmartAudio) SmartAudio 2.0 (États-Unis)
  SmartAudio 2.0 (UE)
TBS (actuellement applicable uniquement aux derniers modèles TBS comme EVO ou Pro32) SmartAudio 2.1 (États-Unis)
  SmartAudio 2.1 (UE)
   
VTX intégré:  
Contrôleurs de vol avec VTX embarqué RTC6705 (USA)
  RTC6705 (UE)

Configuration des tables VTX dans CLI

Voir https://github.com/betaflight/betaflight/blob/master/docs/VTX.md#vtx-table

 

Share this comment


Link to comment

Hi

Sur mon HX115 (tû neuf d'hier, ah pardon, d'avant hier) depuis que je l'ai reflashé en  4.1.5, le smart audio déconne à plein tube, il s'ouvre mais refuse de me donner la main à la puissance du VTX (et accessoirement à la fréquence) et pire, cette saleté se bloque un coup sur deux 😡

Comment s'y prendre pour restaurer la fonction ? (en terme simple, pour chèvre s'entend 🤓)

 

Ps: @Jerome et @Glloq: au secours ! 

Edited by naviluminor

Share this comment


Link to comment

Essaie avec ça dans le CLI :

vtxtable bands 5
vtxtable channels 8
vtxtable band 1 BOSCAM_A A FACTORY 5865 5845 5825 5805 5785 5765 5745 5725
vtxtable band 2 BOSCAM_B B FACTORY 5733 5752 5771 5790 5809 5828 5847 5866
vtxtable band 3 BOSCAM_E E FACTORY 5705 5685 5665 5645 5885 5905 5925 5945
vtxtable band 4 FATSHARK F FACTORY 5740 5760 5780 5800 5820 5840 5860 5880
vtxtable band 5 RACEBAND R FACTORY 5658 5695 5732 5769 5806 5843 5880 5917
vtxtable powerlevels 2
vtxtable powervalues 0 1
vtxtable powerlabels 25 200

Save

🤞

  • J'aime 1
  • Merci ! 1

Share this comment


Link to comment

Malheureusement aucun changement, identique comportement 😟

Dans le déroulant :

"FEATURES" puis au choix :

VTX = si tu coche ça, tout est bloqué et il faut débrancher la lipo pour recommencer

VTX SA = ouvre:  -VTX SMART AUDIO- puis comme choix "statX" (qui n'accède à rien d'intéressant)

VTX TR = pas "ouvrable" mais ne bloque rien

 

Ps: peut on définir fréquence et puissance directement dans le CLI ? est-ce "consultable" via le CLI ces données ?

Edited by naviluminor

Share this comment


Link to comment

@naviluminor Repasse en 3.5.7 !

Mon FW préféré, stable et qui reste simple ! (Quel purge depuis la 4.1 je trouve... )

Sinon, tres honnêtement je n'hesiterai pas un instant en basculant vers EMUFLIGHT 😉

Edited by CriTof

Share this comment


Link to comment

Question con, mais t'as bien activé le Smart Audio sur le bon UART dans l'onglet PORTS ?

Tu peux tenter les commande classiques sinon pour le configurer en manuel (get pour avoir la valeur) :

set vtx_band = 5
set vtx_channel = 3
set vtx_power = 2
set vtx_freq = 5732

Share this comment


Link to comment
il y a 58 minutes, Jerome a dit :

set vtx_power = 2

= 200 mW ?

il y a 59 minutes, Jerome a dit :

Question con, mais t'as bien activé le Smart Audio sur le bon UART dans l'onglet PORTS

Non non pas con du tout (enfin moi si) = rien n'est moins sur 🤔 

Share this comment


Link to comment
il y a 2 minutes, naviluminor a dit :

Non non pas con du tout (enfin moi si) = rien n'est moins sur 🤔 

Alors c'est le premier point à vérifier qui pourrait expliquer pas mal de choses 😛 

il y a 3 minutes, naviluminor a dit :

= 200 mW ?

C'est ce qu'ils semblent dire sur la doc du VTX : https://betafpv.com/products/a01-25-200mw-5-8g-vtx

Citation

For example, set the frequency to 5865 and power to 200mW ( 1 for 25mW / 2 for 200mW);

set vtx_band=1
set vtx_channel=1
set vtx_freq=5865
set vtx_power = 2
save 

Share this comment


Link to comment
Il y a 4 heures, Jerome a dit :

Question con, mais t'as bien activé le Smart Audio sur le bon UART dans l'onglet PORTS ?

= Ben NAN 😬 (c'était bien ça)

La burne que je suis vous remercie bien bas  courbe10.png

  • J'aime 1

Share this comment


Link to comment

Tu me copieras 10 fois "quand un périphérique ne marche pas je commence par vérifier les UARTs" 🤣

Cool, bonne nouvelle que ça ne soit que ça 🙂 

Edited by Jerome

Share this comment


Link to comment

Hello

Le smart audio qui se mets à faire des farces, vous avez déjà eu ?

Je m'explique, lorsque je veux afficher le smart audio dans mes binocles, ça veut bien le faire une fois ou deux puis zob, ce n'est plus "reproductible"

Autre truc, une fois connecté à BF, le changement de PID profil (via les sticks) ne fonctionne que deux ou trois fois de rang, puis plus (du tout)

Je pige pô  😟 mais bon, il n'y a pas mort d'homme, le bidule fonctionne comme une fusée (et BF répond parfaitement au clavier d'ordi, à défaut du smart audio)   

Edited by naviluminor

Share this comment


Link to comment

Sauf que mon ventilateur n'a jamais voulu tolérer la greffe de BF 4.1, il a fallut le remettre dans sa version initiale (3.5.6) avec laquelle il vole très bien

Maintenant je n'ai pas de critique sur son comportement, il va parfaitement là où mes doigts le guide (malheureusement certes)

Début de semaine, j'ai voulu lui assigner 3 profils PID différents, et pour vérifier qu'ils étaient bien "switchables" (via la taranis), j'ai connecté le 115 à BF..

J'ai constaté qu'effectivement cela sautait bien sur les 3 profils, j'ai insisté comme un gamin avec les sticks  3-4 fois de suite (= impec) puis tout d'un coup : zob, ça veut plus 😟  

Share this comment


Link to comment
Il y a 8 heures, Joelamoule a dit :

Il paraît qu'il y a des bug de smartaudio sur bf 4.1...le gourou du fpv en parle dans une vidéo....

Emu !

  • +1 1

Share this comment


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...