Aller au contenu
DroneBuilds

Problème alimentation drone de 4S à 6S


Messages recommandés

Bonjour

J'ai acheté mon équipement pour voler avec le système DJI. J'ai monté mon drone et celui-ci fonctionne bien en 4S. Par contre je rencontre un problème lorsque je veux le faire fonctionner en 6S. Mes moteurs sont des Emax ECO Series 2306 moteur 1700KV. La FC est  iFlight SucceX-D Mini F7 TwinG Flight Controller w / 40A BL_32 4in1 ESC Stack for DJI Air Unit.

Normalement la FC supporte la 6S mais ça ne fonctionne pas. Quand je la branche les 4 moteurs BIP. Quand je remet la batterie 4S ça refonctionne normalement.

 

Merci pour votre aide.

Lien à poster
Partager sur d’autres sites

Il n’y a pas de raison que cela ne fonctionne pas.

Tu as peut-être un paramètre dans betaflight qui génère ces bips...

quand tu branches la 4S tu as les bips de mise en route, as tu la même musique avec la 6S et après ça bip ?

  • +1 1
Lien à poster
Partager sur d’autres sites

Je rejoins @Attafr.. ça devrait pas poser problème. Le fait que ça bipe n’est pas forcément un problème. Peux-tu mieux décrire ce qu’il se passe ? Quels sont les bips que tu entend (tonalité, fréquences) en 4s et 6s

Modifié (le) par Jon
Lien à poster
Partager sur d’autres sites

Je rejoins @Attafr et @Jon

Une capture écran de ton onglet Alimentation de Betaflight serait aussi bienvenue, ainsi que la copie de ton "diff all" dans le CLI

Modifié (le) par CriTof
Lien à poster
Partager sur d’autres sites

Voici la capture d'écran concernant l'alimentation. 

Sinon concernant les bips, lorsque je branche une lipo, les moteurs bips comme d'habitude, elles font une petite mélodie puis s'arrête. Par contre lorsque je branche la lipo 6S, les moteurs font la petite mélodie puis une succession de bip s'enchaine. Impossible d'arrêter les bips. Aucune commande, impossible d'armer. Seule solution débrancher la batterie. Sinon le drone vole bien en 4S.  Par contre j'ai acheté mon équipement pour le faire voler en 6S.

Dois-je faire une manip avec blheli ou autre chose ? 

J'ai pris une vidéo voici le lien

https://1drv.ms/v/s!AmC6G6vX9_VWgZkn-886sXlgPBy-aw?e=giNgsF

 

Merci pour votres aides

# diff all

# version
# Betaflight / STM32F7X2 (S7X2) 4.2.4 Oct 20 2020 / 08:20:06 (fbcaf8c50) MSP API: 1.43
# config: manufacturer_id: IFRC, board_name: IFLIGHT_F722_TWING, version: bc19b7dc, date: 2020-04-01T04:37:12Z

# start the command batch
batch start

# reset configuration to default settings
defaults nosave

board_name IFLIGHT_F722_TWING
manufacturer_id IFRC
mcu_id 0048004c3338510939393832
signature

# mixer
mixer QUADX1234

# feature
feature MOTOR_STOP

# serial
serial 0 64 115200 57600 0 115200
serial 1 1 115200 57600 0 115200

# master
set acc_calibration = -35,0,34,1
set dshot_idle_value = 500
set vbat_max_cell_voltage = 420
set gyro_2_align_yaw = 900

profile 0

profile 1

profile 2

# restore original profile selection
profile 0

rateprofile 0

rateprofile 1

rateprofile 2

rateprofile 3

rateprofile 4

rateprofile 5

# restore original rateprofile selection
rateprofile 0

# save configuration
save

 

CAP 1.jpg

Modifié (le) par Ramzam
Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Salut,

première chose importante, enlève les hélices quand tu faits des tests avec une batterie  !!!!

Perso, je ferais une réinstallation de la carte (flash du firmware), mais avant je ferais une impression écran de tous les panneaux de bétafligth afin de pouvoir remettre les bons paramètres de ports etc ..Je ne suis pas partisan de faire des diffs ou dump et de les remettre, je préfère remettre tout à la mano,  mais chacun son école 😉

Tapes status dans le cli une fois la batterie branchée en aillant enlevé les hélices !!! et montre nous ce qu'il indique.

  • +1 1
Lien à poster
Partager sur d’autres sites

Bonjour Spid99 et merci pour ton aide et tes conseils.

Je ferai plus attention la prochaine fois avec les hélices.

Sinon voilà ce que ça donne avec la commande "status" 

 

# STATUS
MCU F722 Clock=216MHz, Vref=3.27V, Core temp=77degC
Stack size: 2048, Stack address: 0x20010000
Config size: 3962, Max available config: 16384
Gyros detected: gyro 1, gyro 2
GYRO=ICM20689, ACC=ICM20689
OSD: MAX7456
System Uptime: 22 seconds, Current Time: 2020-10-30T12:33:27.264+00:00
CPU:2%, cycle time: 125, GYRO rate: 8000, RX rate: 33, System rate: 9
Voltage: 2433 * 0.01V (6S battery - OK)
I2C Errors: 10
SD card: Not configured
Arming disable flags: RXLOSS CLI MSP

Lien à poster
Partager sur d’autres sites

La radio est allumée ?

Un truc m'étonne, si il fonctionne en 4s :

Arming disable flags: RXLOSS CLI MSP

Il ne voit pas le RX..Ce qui expliquerait les bips ..

Quel est ton RX est-ce du Dji aussi (voir l'encadré ci-joint) ? Et voir avec quelqu'un qui connait les Dji, pas moi..  Si non lequel ?

carte-de-vol-drone-f7-succex-d-f7-twing-

PS : Ne laisse pas branché trop longtemps je vois ta température à 77° ..Pas bon ça .. 🙂

Modifié (le) par spid99
Lien à poster
Partager sur d’autres sites

Oui le tout est du DJI (radio, casque et air unit). Que la radio soit connecté ou pas j'ai toujours les bips. Par contre lorsque je passe en 4S ça fonctionne correctement. Je pense que j'ai un souci avec le FC. 

Modifié (le) par Ramzam
Lien à poster
Partager sur d’autres sites

Refais un status avec une 4s et regarde si tu as toujours RXLOSS (Normalement tu ne devrais pas l'avoir)

Je pense que cela vient de l'alimentation du RX, mais je ne connais pas les Dji, si quelqu'un peut expliquer le problème ? @Jerome ou @Motard Geek ?

Modifié (le) par spid99
Lien à poster
Partager sur d’autres sites

La FC semble bien fonctionner, aucun flag anormal empêche l'armement (RXLOSS, MSP et CLI, c'est normal). On voit d'ailleurs que BF détecte bien que ta lipo est du 6S.

Tu es en Air Unit ou Vista ? C'est alimenté comment ? Tu aurais des photos du build qu'on voit comment c'est câblé  (et des captures d'écran des Ports et Config)? Si tu es en 6S avec un Air Unit et que tu alimentes en direct lipo, ça pourrait être une explication, vu que le Air Unit est aussi le RX dans ta config.

Tu peux aussi essayer de remonter la tension Max par élément à 4.3V. A 4.2V, avec une lipo pleine, tu peux parfois dépasser un peu et ça pourrait peut-être aussi générer une alerte.

  • +1 1
Lien à poster
Partager sur d’autres sites
il y a 15 minutes, Jerome a dit :

(RXLOSS, MSP et CLI, c'est normal)

Si la radio est bien allumée il ne devrait pas y avoir de "RXLOSS" ? A moins que ce soit spécifique à DJI ?

Pour ma culture .. 🙂

image.png.a82b8d7f75200e5640793abc0db3c413.png

Lien à poster
Partager sur d’autres sites
il y a 44 minutes, spid99 a dit :

Si la radio est bien allumée il ne devrait pas y avoir de "RXLOSS" ? A moins que ce soit spécifique à DJI ?

Oui bien sûr, je partais du principe que la radio n'était pas allumée au moment du "status" 😉

  • Merci ! 1
Lien à poster
Partager sur d’autres sites
il y a 54 minutes, spid99 a dit :

Si la radio est bien allumée il ne devrait pas y avoir de "RXLOSS" ? A moins que ce soit spécifique à DJI ?

Pour ma culture .. 🙂

image.png.a82b8d7f75200e5640793abc0db3c413.png

Et surtout TOI tu as pas d’erreurs I2C !

  • +1 1
Lien à poster
Partager sur d’autres sites
il y a 29 minutes, Attafr a dit :

Et surtout TOI tu as pas d’erreurs I2C !

Ouaip j'avais aussi vu les erreurs de Razmam , je ne sais pas à quoi ça correspond ? (toujours ce besoin de me cultiver 😉 )

J'ai trouvé ça mais vu qu'il en a 10 ..J'ais pas compris, cela voudrait bien dire qu'il ne détecte pas l'un des composant, le RX ? alors que sur ma capture on voit 0 et pourtant dans le premier cas il ne voit pas non plus le RX, y'a des mystères ..

Citation

Perfectly normal. The error is simply trying to detect hardware, not getting a response, so you get 1 error. If there was an issue, the I2C error count would increase with every loop.. by several thousand per second.

Modifié (le) par spid99
  • J'aime 1
Lien à poster
Partager sur d’autres sites

Les UARTs (RX et DJI) c'est une simple communication série, ils ne sont pas connectés en I2C. Ca nous dit pas d'où viennent ces erreurs, je suis d'accord 😉  Mais comme en 4S il a les mêmes erreurs et que ça marche, je ne pense pas que ça soit un gros souci.

Lien à poster
Partager sur d’autres sites
Il y a 1 heure, Jerome a dit :

Si tu es en 6S avec un Air Unit et que tu alimentes en direct lipo, ça pourrait être une explication, vu que le Air Unit est aussi le RX dans ta config.

Merci pour l'explication Jerome .. 🤨 Tu dois avoir raison, pas d'importance, vu que j'en avais aussi sur certaines configs et que ça ne l’empêchait pas de fonctionner.

Je pencherais pour ta réponse que j'ai cité ...Ses bips me rappellent trop un RXLoss avec le biper du Dshot activé ..

Lien à poster
Partager sur d’autres sites

Bonjour à tous.

Ce n'est pas le buzeur qui bip mais les moteurs. Que je connecte ma radio ou pas ça ne change rien. Quand je branche la 4S ça bip pas, mais quand c'est du 6S ça bip.

Je pense que j'ai un problème avec mon FC. J'attends une réponse de banggood. 

Lien à poster
Partager sur d’autres sites

C’est vrai que le air unit ne peux pas être alimenté en 6S directement. Ce qui pourrait (même si c’est bizarre) expliquer cette différence entre 4s et 6s. Comment est alimenté ton Air Unit ? Peux-tu envoyer une photo de tes branchements ?

Lien à poster
Partager sur d’autres sites

Je suis branché exactement comme ça. J'au juste soudé les moteurs sur ESC et l'alim de la lipo. sur la FC j'ai pas une seule soudure.  

 

CAP 3.jpg

Modifié (le) par Ramzam
Lien à poster
Partager sur d’autres sites

L'air unit est alimenté en 9V et c'est distribué par la FC.

 

Voilà ce que j'ai trouvé sur le net

 

 

Intégration avec DJI

iflight-succex-x-mini-f7-twing-dji-03-33Le contrôleur de vol peut être alimenté avec du 2S à 6S, et ne dépasse pas le 9V en sortie pour respecter les requis d’alimentation du FPV Air Unit. L’OSD de DJI affichera la tension de la batterie et l’accès aux réglages temporaires des PID sans besoin de soudure supplémentaire. Bien que vous deviez tout de même souder les moteurs et le câble d’alimentation sur l’ESC, cet intégré simplifie beaucoup le montage d’un micro racer… Il est possible d’ajouter un GPS, au besoin, un buzzer et des LED – mais il faudra aussi souder. Si la radiocommande de DJI ne vous convient pas, il est possible de souder un récepteur radio SBUS (FrSky, Flysky, Crossfire) ou DSM. Il sera proposé à 71 € chez Banggood (sans le port, sans les taxes).

Modifié (le) par Ramzam
Lien à poster
Partager sur d’autres sites
il y a 35 minutes, Ramzam a dit :

Je pense que j'ai un problème avec mon FC. J'attends une réponse de banggood.

Je ne pense pas que la FC soit le problème et encore moins que Banggood te sera d'une grande aide 😉 

Est-ce que tu as reflashé ta FC ? Est-ce que tu as essayé de remonter la tension max comme suggéré plus haut ? Ca vaut le coup de flasher aussi les ESCs s'ils ne sont pas dans la dernière version.

Après sans vidéo du probl, sans photos du montage et sans captures des onglets on peut pas faire grand chose de plus...

Tu peux essayer de désactiver un par un les motifs de "bip", quand ça ne bip plus, c'est que tu as trouvé la cause, à moins que ça ne soit uniquement lié aux ESCs et que la FC n'ait rien à voir dans l'histoire (d'où le flash des ESCs).

Lien à poster
Partager sur d’autres sites

J'ai bien flashé les ESC ainsi que le FC avec les dernières versions. Rien ne change. J'ai bien, monté la tension a 4,3 V. Concernant le montage, il est très très simple. C'est exactement comme sur la photo. Pas de soudure sur le FC. J'ai juste souder mes 4 moteurs ainsi que Le câble d'alimentation de la lipo sur l'ESC. La radio et le casques DJI est bindé sur l'air unit. 

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...