Aller au contenu
DroneBuilds

Tyro119 rxloss


Messages recommandés

Bonjour à tous, 

J'ai des problèmes de rxloss sur mon récent tyro119 avec lequel j'ai fait quelques batteries.  Je m'explique. 

Après un petit crash dans une branche d'arbre j'ai depuis des rxloss incessants quand je vole. Ca arrive en général quand je met des punch sur la manette des gaz : rxloss quelques secondes le drone continue de monter même si j'ai rebaissé les gaz et je reprends le contrôle au bout de quelques secondes. 

Je sais que c'est dangereux j'ai pas configuré le failsafe je vais le faire maintenant. Au début j'ai cru que c'était le jst du récepteur sur la FC parce qu'il était très lâche et se débranchait facilement. Pour régler ce problème j'ai soudé le récepteur direct sur la FC et toujours les mêmes problèmes de rxloss lors des grosses accélérations.

J'avais deux hypothèses du coup soit le jst du récepteur  qui fasse faux contact lors des grosses accélérations ou alors un autre problème que j'ignore. J'ai donc essayé de puncher à l'arrêt sans les hélices pour voir si c'est plutôt la piste faux contact à cause de l'accélération. Et effectivement en mettant plein gaz sans hélices j'ai pas de rxloss donc je suis plutôt la piste de l'accélération qui déconnecte un truc. 

Ce matin j'ai donc refait un test 3 fois, en volant, je met plein gaz et aussitôt je remet les gaz à 0 le plus rapidement possible donc le drone a pas encore pris l'altitude et le rxloss apparait directement  puis il continue de monter et je peux reprendre le contrôle après 1 ou 2 secondes quand il est monté. 

J'espère que vous pourrez m'aider parce que là malgré mes investigations j'ai pas d'autre idée ! 

Merci d'avance. 

Matériel : Tyro119, Fs-i6, EV 200D

Lien à poster
Partager sur d’autres sites
Youtube WE are FPV
Il y a 2 heures, Attafr a dit :

Problème d’antenne sur ton RX ? 

Hm oui peut-être mais je sais pas comment le déterminer. Je vais essayer de voler demain avec le récepteur et la radio d'un ami pour voir si j'ai toujours les problèmes. Ca donnera une idée plus précise de quel est le problème. 

 

Il y a 1 heure, Latout a dit :

Aïe aïe aïe ca sent pas bon ... et voler sans failsafe tu es un grand fou comme on en fait plus !

Je vais éviter à l'avenir 😄 

Lien à poster
Partager sur d’autres sites
Le 19/10/2020 at 16:36, Attafr a dit :

Problème d’antenne sur ton RX ? 

J'ai refait quelques tests aujourd'hui en resimulant le problème en mettant gaz à fond et effectivement  le problème arrive systématiquement dans ce cas. 

J'ai aussi, je pense, compris pourquoi mon failsafe ne s'activait pas. Ma durée de rxloss minimum de betaflight pour déclencher le failsafe n'est pas atteinte. Et donc j'ai un rxloss une fraction de seconde qui ne déclenche pas le failsafe, ça continue de monter et après une seconde environ je recupère le contrôle comme j'ai expliqué dans le premier message. 

J'ai essayé avec un autre récepteur et une autre radio et le problème est toujours là. Ca vire l'hypothèse du RX deffecteux du coup ? 

J'aurai préféré que ça soit lui le problème, ça aurait pu être résolu plus vite 😄

Lien à poster
Partager sur d’autres sites

Ca serait pas tout simplement un calibrage de tes sticks radio à revoir proprement Et dans ton configurateur, recaler les plages de ces deniers: 1000 - 2000.

idée... 

Lien à poster
Partager sur d’autres sites
Il y a 23 heures, CriTof a dit :

Ca serait pas tout simplement un calibrage de tes sticks radio à revoir proprement Et dans ton configurateur, recaler les plages de ces deniers: 1000 - 2000.

idée... 

J'ai regardé et effectivement ma chaine des gaz était à 2005 en valeur max donc peut-être que ça fait un micro rxloss quand j'émet une valeur "interdite".

J'ai remapé correctement en vérifiant que ça dépassait pas 2000. Puis test en vol premier essai je met trois fois plein gaz et aucun problème (c'est une situation où d'habitude j'ai le problème). 

Super content je me dis c'est résolu mais je réessaye au cas ou. J'ai mis un coup de  gaz à fond et rxloss comme d'hab il est monté super haut, j'ai repris le contrôle, deuxième rxloss avant que j'arrive à le poser et après gros crash. 😢

J'y croyais vraiment là, ça me semblait plausible comme solution...

Lien à poster
Partager sur d’autres sites

Combo Flysky, Fs-i6 et A8S. 

Quand j'ai fait un test avec Rx et TX de quelqu'un d'autre c'était les mêmes modèles par contre. 

Est ce qu'avec les choses qu'on sait actuellement on peut éliminer certains composants en disant que ça ne vient pas deux et que ça peut venir de tel ou tel composant ? 

Parce-que vu le prix du spare pourquoi pas essayer de changer une pièce qui pourrait être défectueuse.

J'ajoute également que quand j'ai build le drone, 3 choses étranges sur la fc

- un socket jst pas soudé (aucune patte) 

- pas de flèche pour indique le sens de la fc

- les écritures des pads sur la fc étaient quasi illisibles (flous) 

Modifié (le) par damelko
Lien à poster
Partager sur d’autres sites

Petite update, comme le premier test d'hier avant le crash était concluant j'avais un petit espoir et je suis retourné voler aujourd'hui. 

J'ai fait 3 batteries en incluant des push plein gaz qui d'habitudes déclenchent le problème mais aucun rxloss aujourd'hui. 

A moitié soulagé car même si je n'ai pas eu le problème, il y a eu ce fameux vol ou ça l'a refait hier donc je me dis à tout moment en plein vol un jour ça peut arriver de nouveau.

A suivre... 

Lien à poster
Partager sur d’autres sites

vraiment étrange... c'est quoi comme FC que tu as ?? Au vu de ce que tu décris plus haut, je n'aurais pas confiance en la FC.... C'est peut-être ce composant qui pause problème. Ou la gestion du courant lors de grosse demande... Bec 5 volt foireux ?

Lien à poster
Partager sur d’autres sites

Effectivement vu les problèmes que j'avais déjà vus dessus j'étais d'avis que la FC pouvait poser problème. 

C'est une Eachine GPS F405 celle de base. Après bon les drones comme ça ils font tellement de séries différentes que je peux être tombé sur une mauvaise série. Déjà elle ne ressemble pas trop à celle du tyro119 d'un ami. 

Pour le bec ou l'ESC j'ai pas vraiment de moyen de vérifier ? 

Lien à poster
Partager sur d’autres sites

Tu peux déjà vérifier la tension de sortie sur un pad 5v. Après ça te renseignera pas vraiment si le problème survient lors des gros coups de gaz

Lien à poster
Partager sur d’autres sites

Les 5V sont OK après vérification. Mais de toute façon le problème vient quand même certainement de cette FC... 

D'ailleurs j'ai remarqué aussi que le "voltmètre pour la batterie et pas du tout bon. Après une minute de vol je suis déjà vers 14.5V en 4S avec des batteries vérifiées à 16.8V. J'ai même des descentes à 13V assez fréquentes pendant les push mais quand je vérifie mes natteries psot-vol je suis toujours au dessus de 15V. La calibration est donc pas top, ça vient de la FC ? (je crois que c'est paramétrable dans BF aussi non ? )

Du coup, pour être tranquille, je pense passer en stack Mamba F405 sur le tyro119, bon choix ? En espérant que ça règle les problèmes. Et niveau RX/TX je vais upgrade un peu plus tard aussi avec une QX7/T12 et R9M. 

 

 

 

Un autre rxloss que j'ai eu aujourd'hui, très étrange, dans cette vidéo à 3min0sec.  

Lien à poster
Partager sur d’autres sites
Il y a 6 heures, damelko a dit :

La calibration est donc pas top, ça vient de la FC ? (je crois que c'est paramétrable dans BF aussi non ? )

Oui, voici un tuto: https://culturefpv.fr/calibrer-capteur-courant-betaflight-guide-20181003/

Lien à poster
Partager sur d’autres sites

Super merci. Je sais pas si c'est le bon sujet sinon je referai un topic. 

J'ai branché à BF tout à l'heure et quand je fais des changements et save and reboot j'ai échec de fermeture du port série et les changements sont pas pris en compte. Le dernier save and reboot que j'ai fait ça a même supprimé l'uart activé pour le récepteur... C'est de la sorcellerie vraiment 😂

Ça peut venir des drivers ou plutôt de la FC ? 

Parce-que j'avais déjà eu des soucis pour connecter au début j'ai fait zadig et Impulse RC qui échoue d'ailleurs. 

Lien à poster
Partager sur d’autres sites
Il y a 6 heures, damelko a dit :

Super merci. Je sais pas si c'est le bon sujet sinon je referai un topic. 

J'ai branché à BF tout à l'heure et quand je fais des changements et save and reboot j'ai échec de fermeture du port série et les changements sont pas pris en compte. Le dernier save and reboot que j'ai fait ça a même supprimé l'uart activé pour le récepteur... C'est de la sorcellerie vraiment 😂

Ça peut venir des drivers ou plutôt de la FC ? 

Parce-que j'avais déjà eu des soucis pour connecter au début j'ai fait zadig et Impulse RC qui échoue d'ailleurs. 

Salut, au vu des problèmes étranges auxquels tu est confronté, je pencherais pour une FC sérieusement délirante ...    si t'arrive a te connecter les drivers sont ok. Tu n'a pas une autre FC sous la main pour tester ? 

Pour ton dernier problème : j'ai pu remarquer que si tu choisis le mauvais uart dans les réglages , la modification n'est pas prise en compte même en sauvegardant ( donc en 1er lieu, être sur d'avoir choisi le bon port ) 

Et Du coup lors de ton dernier changement, ton recepteur a peut être fait un RX Lost au momment de sauvegarder, d'où la désactivation du uart 😉

Lien à poster
Partager sur d’autres sites

D’ailleurs tu utilise quoi comme LiPo ? C’est vrai que si tu peux te permettre de tester avec une autre FC, au point où t’en es ça peut être pas mal. Je sais pas comment tu fais pour voler avec ces pertes de signal qui te pendent toujours au nez 😅

Lien à poster
Partager sur d’autres sites
Il y a 9 heures, feust2 a dit :

Salut, au vu des problèmes étranges auxquels tu est confronté, je pencherais pour une FC sérieusement délirante ...    si t'arrive a te connecter les drivers sont ok. Tu n'a pas une autre FC sous la main pour tester ? 

Pour ton dernier problème : j'ai pu remarquer que si tu choisis le mauvais uart dans les réglages , la modification n'est pas prise en compte même en sauvegardant ( donc en 1er lieu, être sur d'avoir choisi le bon port

La semaine prochaine je pourrai tester avec une autre FC je verrai à ce moment là. 

J'avais vu ça pour le port oui merci et j'ai bien vérifié que ça soit le bon. D'ailleurs ce problème d'échec de fermeture du port série je l'ai depuis le premier jour où j'ai branché la FC. 

Il y a 3 heures, Jon a dit :

D’ailleurs tu utilise quoi comme LiPo ? C’est vrai que si tu peux te permettre de tester avec une autre FC, au point où t’en es ça peut être pas mal. Je sais pas comment tu fais pour voler avec ces pertes de signal qui te pendent toujours au nez 😅

Jai une URUAV 4s 1.8A 75C et deux Zop power 4s 1.5A 100C

J'ai volé avec la URUAV 90% du temps pour l'instant. 

Je vol tranquille pas trop loin ni trop haut c'est pas top mais bon pour l'instant... 

Lien à poster
Partager sur d’autres sites
Il y a 4 heures, damelko a dit :

La semaine prochaine je pourrai tester avec une autre FC je verrai à ce moment là.  

Je suis quasi certains que ton soucis vient de la FC,puisque tu a écarter la piste du RX défaillant. Et un problème de chauffe ne surviendrait pas seulement lors des accélérations . 

Je vol tranquille pas trop loin ni trop haut c'est pas top mais bon pour l'instant... 

Le problème c'est que tu va vite te faire ch... Outre le fait de ne pouvoir voler ni trop loin, ni trop haut , ni au dessus d'une zone difficile d'accès , la perte du RX aléatoire doit te mettre un sacré frein dans l'apprentissage des figures et des vols a hautes vitesse . Perso je ne sais pas si j'oserais un simple flip , alors les chutes libre a 200 m de hauteur  ou en rasant un bâtiment ... Je t'en parle même pas ... C'est dommage 

Lien à poster
Partager sur d’autres sites
Il y a 5 heures, feust2 a dit :
Il y a 9 heures, damelko a dit :

La semaine prochaine je pourrai tester avec une autre FC je verrai à ce moment là.  

Je suis quasi certains que ton soucis vient de la FC,puisque tu a écarter la piste du RX défaillant. Et un problème de chauffe ne surviendrait pas seulement lors des accélérations . 

Je vol tranquille pas trop loin ni trop haut c'est pas top mais bon pour l'instant... 

Le problème c'est que tu va vite te faire ch... Outre le fait de ne pouvoir voler ni trop loin, ni trop haut , ni au dessus d'une zone difficile d'accès , la perte du RX aléatoire doit te mettre un sacré frein dans l'apprentissage des figures et des vols a hautes vitesse . Perso je ne sais pas si j'oserais un simple flip , alors les chutes libre a 200 m de hauteur  ou en rasant un bâtiment ... Je t'en parle même pas ... C'est dommage 

Dérouler  

Je pense aussi après tout ce qu'on a vu que c'est un problème de FC. C'est pour ça que j'ai suggéré dans un de mes posts de passer en stack mamba f405 car c'est pas beaucoup plus cher que la eachine et je pense mieux. 

 

Sinon pour l'apprentissage je suis entièrement d'accord que ça me brime et que c'est pas top mais pour l'instant j'ai pas le choix je préfère quand même voler en vrai en plus du simu. 

Le confinement va un peu changer la donne pour le coup mais sinon je compte bien changer de FC pour profiter pleinement et voler sans limites. 

Lien à poster
Partager sur d’autres sites
il y a une heure, damelko a dit :

Je pense aussi après tout ce qu'on a vu que c'est un problème de FC. C'est pour ça que j'ai suggéré dans un de mes posts de passer en stack mamba f405 car c'est pas beaucoup plus cher que la eachine et je pense mieux. 

Je pense que la mamba est un bon choix du coup !

Modifié (le) par Jon
Lien à poster
Partager sur d’autres sites
Il y a 1 heure, damelko a dit :

Je pense aussi après tout ce qu'on a vu que c'est un problème de FC. C'est pour ça que j'ai suggéré dans un de mes posts de passer en stack mamba f405 car c'est pas beaucoup plus cher que la eachine et je pense mieux. 

 

Sinon pour l'apprentissage je suis entièrement d'accord que ça me brime et que c'est pas top mais pour l'instant j'ai pas le choix je préfère quand même voler en vrai en plus du simu. 

Le confinement va un peu changer la donne pour le coup mais sinon je compte bien changer de FC pour profiter pleinement et voler sans limites. 

+1 pour la mamba , excellent choix . Tu peux aussi te diriger vers une f7, si tu garde tes ESC et change seulement la FC, la Zeus f722  chez hlgrc coûte quasiment le même prix , voire moins cher que la diatone. Mais bon... Les deux sont du bon matos . 

Pour voler pendant le confinement  l'astuce c'est de rallier la balade du chien avec une petite session en prairie 😉 enfin... Si t'habite pas en centre ville ... Et il faut être équipé d'un chien bien sûr 🙃

Modifié (le) par feust2
Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...